Excel 2019
Data Analysis

The Computer Workshop, Inc.

800-639-3535

www.tcworkshop.com
training@tcworkshop.com
Lesson 1: Tables

Tables ........................................................................................3
Creating a Table ........................................................................4
Using Home Tab .......................................................................4
Using the Insert Tab ..................................................................5
Using the Quick Analysis Tool ...............................................6
Table Components .....................................................................10
Records and Fields ...................................................................14
Resizing A Table .....................................................................15
Using the Resize Handle ......................................................15
Resizing a Table Using the Design Ribbon ............................15
Adding Fields ..........................................................................17
Using the Right Click Insert Menu .......................................17
By Selecting an Adjacent Column ..........................................18
Using the Ribbon .....................................................................18
Adding Records .......................................................................19
Adding Records Inside the Table ............................................19
Adding Records at the End of the Table ................................19
Deleting Records or Fields ....................................................20
The Total Row .........................................................................25
Adding a Total Row ................................................................25
Hiding the Total Row ...........................................................26
Using the QAT to Create a Total Row ...................................26
Data Forms .............................................................................28
Adding the Form Tool to the QAT .......................................28
Using a Form to Enter Records ............................................29
Slicers .....................................................................................32
Adding Slicers to a Table ......................................................32
Formatting the Slicer .............................................................33
Using the Slicer .......................................................................33
Clearing a Slicer Filter ..........................................................34
Closing or Deleting a Slicer ..................................................34

Lesson 2: Importing Data

Importing Data from other sources .......................................39
Using Excel and Access ..........................................................40
Creating a Table from an Access Object ...............................41
Using the Data Ribbon ..........................................................41
Setting the Refresh Properties ..............................................42
Importing Data Using the Microsoft Query Connection ..........46
Setting up a Query Connection ..............................................46
Importing Data from a Text File ............................................55
Opening A Text File in Excel .................................................55
Importing a Text file into a Workbook .................................58
<table>
<thead>
<tr>
<th>Table of Contents, continued</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Lesson 3: Data Management</strong></td>
</tr>
<tr>
<td>Understanding Structured Data ......................................... 65</td>
</tr>
<tr>
<td>Guidelines for Data Structure ........................................ 65</td>
</tr>
<tr>
<td>Cleaning Up Raw Data ..................................................... 65</td>
</tr>
<tr>
<td>Removing Blank Rows ....................................................... 66</td>
</tr>
<tr>
<td>Removing Duplicates .......................................................... 69</td>
</tr>
<tr>
<td>Conditional Formatting .................................................... 72</td>
</tr>
<tr>
<td>Using Conditional Formatting To Find Duplicates ................ 72</td>
</tr>
<tr>
<td>Comparing Two Lists With Conditional Formatting .......... 73</td>
</tr>
<tr>
<td>Sorting Data ................................................................. 77</td>
</tr>
<tr>
<td>Applying a Simple Sort .................................................... 77</td>
</tr>
<tr>
<td>Basic Sorting in a Table .................................................. 78</td>
</tr>
<tr>
<td>Sorting on Multiple Fields ................................................. 81</td>
</tr>
<tr>
<td>Flash Fill .......................................................................... 85</td>
</tr>
<tr>
<td>Flash Fill to Combine or Separate Data .......................... 85</td>
</tr>
<tr>
<td>AutoFilters ....................................................................... 89</td>
</tr>
<tr>
<td>Basic Filtering ............................................................... 89</td>
</tr>
<tr>
<td>Custom AutoFilters .......................................................... 92</td>
</tr>
<tr>
<td>Creating a Custom AutoFilter .......................................... 92</td>
</tr>
<tr>
<td>Using the Search Feature .................................................. 94</td>
</tr>
<tr>
<td>Using Wildcards .............................................................. 94</td>
</tr>
<tr>
<td>Clearing Filters .............................................................. 95</td>
</tr>
<tr>
<td>Advanced Filter .............................................................. 97</td>
</tr>
<tr>
<td>Using an Advanced Filter ................................................ 97</td>
</tr>
<tr>
<td>Clearing the Filter .......................................................... 98</td>
</tr>
<tr>
<td>Copying Filtered Records ................................................... 99</td>
</tr>
<tr>
<td>Copying Filtered Records to a New Location .................... 99</td>
</tr>
<tr>
<td><strong>Lesson 4: Database Functions</strong></td>
</tr>
<tr>
<td>Database Functions .......................................................... 105</td>
</tr>
<tr>
<td>Basic Syntax of D-Functions ............................................. 107</td>
</tr>
<tr>
<td>Creating a D-Function Formula ......................................... 108</td>
</tr>
<tr>
<td>Entering the Function Manually ....................................... 109</td>
</tr>
<tr>
<td>Expanding D-Functions ................................................... 114</td>
</tr>
<tr>
<td>Adding Drop-down Menu’s .............................................. 116</td>
</tr>
<tr>
<td>Data Validation Lists ....................................................... 116</td>
</tr>
</tbody>
</table>
## Lesson 5: Data Modeling

Data Modeling ................................................................. 123
   Enabling Power Pivot ............................................... 123
Understanding Relationships ........................................ 126
   Relational Databases ............................................... 126
Preparing the Tables .................................................... 127
   Structuring the Data ............................................... 127
   Convert the Data to a Table ..................................... 127
   Rename the Table .................................................. 127
Creating Relationships ................................................... 129
   Find the Related Data ............................................. 129
   Creating Relationships .......................................... 129
Managing the Data Model ................................................ 133
   To Open Excel’s Power Pivot window ...................... 133
   Power Pivot Views ............................................... 134
   Adding a New Connection .................................... 136
Creating PivotTables ..................................................... 138
   Creating PivotTables .......................................... 138
Working with a PivotTable ............................................ 140
   Adding a Calculated Column ................................. 145
   Inserting a Function column ................................. 145
Welcome to the *Advanced Excel 2013* course. This manual and the data files are designed to be used for learning, review and reference after the class. The data files can be downloaded any time from *The Computer Workshop* website:

http:\\www.tcworkshop.com

There is no login or password required to access these files. You will also find handouts and supplementary materials on the website in the Download section.

**To Download Data Files**

Once on *The Computer Workshops* website, look at the bottom of any page to find the link *Download*. Clicking this link opens the *Download* page where you can choose either *Data Files* or *Handouts*.

1. *Data Files* opens a list of general application types.
2. Click once on the *Microsoft Office Courses* link.
3. Click once on the software related to the course.
4. Click once on the version related to the course.
5. If there are multiple folders, click on the *TCW* folder.
6. Click on the course name to download the data files.

You can choose to open or save the zipped folders content to your computer.

The handouts are in PDF format and also available to you without login or password. Simply open the PDF and either print or save to your computer.
Conventions Used in this Manual

The hands-on exercises (Actions) are written in a two-column format. The left column (“Instructions”) gives numbered instructions, such as what to type, keys to press, commands to choose from menus, etc. The right column (“Results/ Comments”), contains comments describing results of, reasons for, quick keys, etc. for the instructions listed on the left.

◊ Key names and Functions are bold and enclosed in square brackets:

[Enter], [Tab], [F5], [F10]

◊ Keys you press simultaneously are separated by a plus (+) sign, typed in bold and enclosed in square brackets. You do not press the plus.

[Shift + F5]

◊ Keys you press in sequence are separated by a space, bold and enclosed in square brackets.

[Home] [Down Arrow]

◊ Ribbon tab names are in bold and italic: Example: Home

◊ Group names are in bold: Example: Font

◊ Dialog box names are in italic: Example: Save As

◊ Button names are bold and enclosed in square brackets: Example: [Sort]

◊ Information you are to type will be in bold. Example: This is the first day of the rest of your life.

◊ Information that you need to supply will be indicated with pointed brackets. Example: Type: <your name>. 
Lesson 1: Tables & Data Management

Lesson Overview

You will cover the following concepts in this chapter:

- Data Management
- Locating Blanks
- Removing Blank Rows
- Removing Duplicates
- Combining Cell Values
- Splitting Cell Values
- Flash Fill
- Tables
- Creating a Table
- Autofilters
- Advanced Filter
- Data Forms
Data Management

Understanding Structured Data

While data in Excel can be laid out in many different ways some analytical features require the data be in a specific structure. As an example: creating tables, sorting, and/or filtering data will not work properly if there are gaps in the data. Since Excel recognizes adjacent rows and columns of data as a dataset, a blank row or column indicates the end of the data set, which can give partial views of the complete data set.

Guidelines for Data Structure

◊ Only one row of labels for the header row.
◊ Each column contains only one type of data.
◊ Continuous rows and columns of data; *no gaps and no decorative rows or columns*.
◊ Break data down into the smallest value necessary for sorting or filtering.
  ◊ An address should be broken down into columns
    Address | Appt | City | State | Zip
◊ Each row of data represents only one record.
◊ A spreadsheet containing a list of employees personal information, one employee per row.
◊ No duplicate rows of data.

Cleaning Up Raw Data

Before you are able to begin working with data, it may be necessary to ensure there are no problems within the data. Excel offers several tools to speed this process up significantly; duplicate removal, splitting combined elements into component data, and combining data into new columns of required information. It is a good idea to quickly check for and correct possible issues early on to avoid issues further down the road.
Locating Blanks

While removing blank rows can be easily managed, you may need to see where the blanks are before removing the entire row. This can be done for an individual column or the entire data set by using the Conditional Formatting tool.

**Conditional Formatting Blanks**

- Select the column or data set to be searched.
- On the *Home Tab* in the *Styles Group*, click the [Conditional Formatting] button drop-down.
- Choose *New Rule...* from the menu.
- The *New Formatting Rule* dialog opens.
- From the list of Rule Type, select *Format only cells that contain*.
- In the *Edit the Rule Description* section, click the first field drop-down and select *Blanks* from the list.
Locating Blanks, continued

◊ Click the [Format...] button.
◊ The *Format Cells* dialog opens.

◊ Activate the *Fill Tab* in the *Format Cells* dialog.
◊ Choose an easily noticed color and click [OK].
◊ Click the [OK] button to close the dialog and apply the formatting.

**Sorting Based On Cell Color**

◊ If the *Conditional Formatting* has been applied in a single column, right-click a colored cell in the column.

◊ Choose *Put Selected Color On Top* from the *Sort* options in the menu.

   - OR -

◊ If the data set has been *Conditionally Formatted*, right-click any cell in the data set.

◊ Choose *Custom Sort...* from the *Sort* options in the menu.

◊ The *Sort* dialog opens.

◊ Click the *Sort by* field drop-down and choose the first column to sort by.

◊ Click the *Sort on* field drop-down and choose *Cell Color*.

◊ Click the *Order* field drop-down and choose the color and set the location to On Top.

**Note**

Sort tools can also be accessed from the *Home Tab* in the *Editing Group* in the [Sort & Filter] button, or on the *Data Tab* in the *Sort & Filter Group*. 
Locating Blanks, continued

◊ Click the [Add Level] button.
◊ Repeat the setting for this level just as before.
(If there is no color listed in the Order field drop-down, change the Sort by field value to the next column.)

◊ Repeat until all columns containing colored cells are included in the custom sort.

◊ Then click the [OK] button to apply the sort.

You are now able to see what information is missing and decide whether or not to remove the record.
Removing Blank Rows

When managing the data, the first thing to consider is eliminating any blank rows or columns which are breaking up the data set. Using the Conditional Formatting tools to locate individual blanks cells allow you to see what data can be removed based on the entire record.

There are times when a columns' data is integral to a valid record, a blank in this column on a row would completely negate the entire record. This type of situation makes the need to search every column for blanks unnecessary. In cases such as these, removing rows based on a blank is easily done by selecting the blanks and deleting the entire row.

Selecting Blank Cells

◊ Select a key column. (An ID column would be a prime example.)

◊ Open the Go To dialog by:

◊ On the Home Tab, in the Edit Group click the Go To Special option from the [Find & Select] drop-down button.

◊ Use the [F5] key to open the Go To dialog and click the [Special] button.
Lesson 1: Tables & Data Management

Removing Blank Rows, continued

In the Go To Special dialog, choose Blanks, and click the [OK] button.

Any blank cells are selected.

On the Home Tab in the Cells Group click the [Delete] drop-down and choose Delete Sheet Rows.

All blanks rows are removed.

Counting Blanks

To help in getting an idea of how many blanks exist within a data set, you can use the Count, CountA, or CountBlank formulas.

Count: This returns the number of cell containing numeric data from a range.

=COUNT(range1,[range2])

CountA: this function returns the number of cell containing data from a range.

=COUNTA(range1,[range2])

CountBlank: This returns the number of empty cells from a range.

=COUNTBLANK(range)
Action 1:1 - Locating Blank Cells

Instructions:

1. Open the EmployeeStart.xlsx file.

2. Save the file as MyEmployeeStart.xlsx

3. Active the MissingDataPoints worksheet.

4. Select cell A8.

5. Holding both the Ctrl and Shift keys down, tap the Right Arrow key once, then the Down Arrow key three times.

6. Activate the Home Tab.

7. In the Style Group, click the [Conditional Formatting] button drop-down and choose New Rule.. from the menu.

8. Select the Format only cells that contain in the list of rule types at the top of the dialog.

9. In the first field, change the Cell Value to Blanks.

10. Click the [Format] button.

11. Activate the Fill Tab, choose a color, and click the [OK] button.

12. Click the [OK] button to apply the formatting.

Results/ Comments:

This is an example of messy data which needs to be cleaned up before beginning to work.

[F12].

The first cell in the data set.

Using the Ctrl And Shift keys allows for quick and efficient directional selection.

If necessary.

The New Formatting Rule dialog opens.

The options below in the Edit the Rule Description section change, offering control associated with the selection of rule type.

The controls change again to reflect your choice.

The Format Cells dialog opens.

This will be the color used to highlight blank cells.

All blank cells are now highlighted.
### Instructions:

13. Select cell **A24**.

14. Right-click the colored cell, hover on the **Sort** option and choose *Put Selected Cell Color On Top* from the menu.

15. Re-select all the data in the data set.

16. On the **Home Tab**, click the *[Sort & Filter]* button drop-down, then select *Custom Sort* from the menu.

17. The first level sort should already be set.

18. Click the *[Add Level]* button.

19. Continue adjusting the parameters of each sort level. Add levels related to columns **A**, **D**, **E**, **H**, and **J**. When done, click the *[OK]* button.

20. Right-click the row header for row 8 and choose *Delete* from the menu.

21. On the **Home Tab**, click the *[Conditional Formatting]* button and choose to *Clear Rules from Entire Sheet*.

22. Save the file.

### Results/ Comments:

This is the cell the sort will be based on.

All the records are sorted with all blanks in the column A on top.

Cells **A8:N78**.

The **Sort** dialog opens. Using the right-click method would also give access to the custom sort. This will allow you to set blanks across all the columns top the top of the data set.

If not then set the first sort level to **Sort By to Column A**, the **Sort On** to **Cell Color**, the **Order** to **color**, and leave the locate set to **On Top**.

This will allow for a secondary search and sort. Each new level will be run after the previous level is completed.

All records with blank cells are shown at the top of the data set in descending order of importance.

Since this record is invalid without an ID, the record needed to be removed.

All highlights are removed.

[Ctrl+S].
Action 1:2 - Removing Blank Rows

Instructions:

1. MyEmployeeStart.xlsx file should still be open.

2. Activate the InvalidRecords worksheet.

3. Select column A.

4. On the Home Tab click the [Find & Select] button drop-down in the Editing Group and choose Go To Special.

5. Click the Blanks radio button and click [OK].

6. On the Home Tab, click the [Delete] button drop-down in the Cells Group and choose Delete Sheet Rows.

7. Click into any cell containing data.

8. Save the file.

Results/ Comments:

If not, re-open the file.

In this case, any records without an ID must be removed.

Use the [F5] key to open the Go To dialog and click the [Special] button to open the Go To Special dialog.

Only blank cells are selected.

All the blank rows have been removed. Note: if there are blank cells within the data set doing this could remove records from the data set. This is another reason why having blank cells in the data can cause problems.

To deselect the current selection.

[Ctrl+S].

Excel 2019: Data Analysis, Rel. 1.0, 5/6/2020
Lesson 1: Tables & Data Management, Page 11


### Remove Duplicates

One feature that makes restructuring data simpler is **Remove Duplicates**. It is available for regular or tabular data. It examines selected data and removes duplicate lines based on a repeated values within column values. Data can have empty cells here and there, but the column value used to find duplicates cannot have any empty cells. The first record found in the process is maintained while all subsequent records are removed.

Since only the first record is retained when a duplicate is found. You can also consider using conditional formatting to identify duplicates before removal to ensure the correct record is being removed. *More on this later.*

- Click any cell in the range of data that contains duplicates.
- For Normal Data:
  - On the **Data Tab**, click the [Remove Duplicates] button in the **Data Tools Group**.
- For Tabular Data:
  - On the **Table Tools Design Tab**, click the [Remove Duplicates] button in the **Tools Group**.

- In either case, the **Remove Duplicate** dialog opens.

\[Image of Remove Duplicates dialog box\]
Removing Duplicates, continued

◊ If the data set has headers be sure to check the My data has headers checkbox. (It may already be checked.)

◊ If you are looking for a complete duplication of a record, leave all the Column checkboxes checked to include them in the comparison.

◊ If you are looking for certain aspects of the records to be duplicates then click the [Unselect All] button and check the box next to each column to be compared.

◊ Click the [OK] button.

◊ A message box appears indicating the number of duplicate rows to be removed and how many rows will remain in the list. Click [OK].
### Action 1.3 - Removing Duplicates

**Instructions:**

1. The **MyEmployeeStart** file should still be open.

2. Select the **InvalidRecords** sheet then click and drag it beside the original sheet while holding the **[Ctrl]** key.

3. Repeat step 2 to create a third copy of the sheet.

4. Save the file.

5. Select the first **InvalidRecords** sheet tab.

6. Click any cell containing data.

7. On the **Data Tab**, click the **[Remove Duplicates]** button in the **Data Tools Group**.

8. Ensure that the **My data has headers** checkbox is checked in the **Remove Duplicates** dialog.

9. Click the **[Unselect All]** button.

10. Click the checkbox for **Emp#** and click **[OK]** the button.

11. Read the message and click the **[OK]** button to close the message window.

12. Save the file.

**Results/ Comments:**

- **If not, re-open the file.**

  Holding the **[Ctrl]** as sheet tab is dragged to a new position will duplicated the entire spreadsheet. You should now see a second sheet tab labeled as **InvalidRecords(2)**.

  There should now be three copies of the same sheet in the workbook.

- **[Ctrl+S]**.

  The original sheet is active.

  If necessary.

  The **Remove Duplicate** dialog opens and all connected cells are selected.

  If the data set does not have headers, then the **My data has headers** checkbox should not be checked. Which will include the first row within the search for duplicates.

  All the check marks in the checkboxes beside each column are removed.

  This will be the only column being searched for duplicate entries. A message window opens, stating: "7 duplicate values found and removed; 64 unique values remain."

  **[Ctrl+S]**.
Removing Duplicates, continued

When using the Remove Duplicate function, the first record of many found will be the only one kept, all others are removed. While this will work in most cases there will be times when you need to see the duplicates in order to determine which is the correct one to be retained. The Conditional Formatting tool allows for this to be done in a quick and efficient manner.

Using Conditional Formatting To Find Duplicates

◊ Select the range of cells to be searched and formatted.

◊ Think of this as selecting the column in the Remove Duplicates dialog.

◊ On the Home Tab, click the [Conditional Formatting] button drop-down and choose New Rule from the menu.

◊ In the New Formatting Rule dialog choose Format only unique or duplicate values from the list of Rule Types.

◊ In the Format All drop-down field choose Duplicate.
Removing Duplicates, continued

◊ Click the [Format] button.

◊ In the Format Cells dialog, click the Fill Tab and choose any color you want.

◊ You can choose to apply any formatting changes to the Numbers, Text, Borders, and/or Fill.

◊ Click the [OK] button to close the Format Cells dialog.

◊ Click the [OK] button to close the New Formatting Rule dialog and apply the your formatting to the duplicate values.

Once the duplicate values are formatted you can sort the data set based on the cells color and examine the duplicate records to determine which are the ones to be deleted. Select the unwanted rows and delete them by right-clicking the selection and choosing Delete from the menu.

Comparing Two Lists With Conditional Formatting

There will be times when you have data in two tables or worksheets that require a comparison to find duplicate values. This can be done by using a Countif formula within conditional formatting.

◊ Select the data in the column which may contain duplicate values

◊ Click the [Conditional Formatting] button drop-down in the Styles Group on the Home Tab.

◊ Choose New Rule from the menu.
Removing Duplicates, continued

◊ The New Formatting Rule dialog opens.

◊ Choose Use a formula to determine which cells to format in the Select a Rule Type: field.

◊ In the Format values where this formula is true: field, enter the following formula

◊ =countif(

◊ Click the worksheet or table containing the comparison data,

◊ Select the cell range containing the data,

◊ Type in a comma,

◊ Click back to the first cell of the data being formatted,
Removing Duplicates, continued

◊ This will be an absolute address which needs to be converted into a relative address. Use the F4 key to cycle through the cell addressing until all $ are removed.

◊ Type in the ).

◊ This will apply formatting to all matching cells.

◊ Click the [Format] button to open the Format Cells dialog.

◊ Choose what ever formatting options you want and click the [OK] button.

◊ Click the [OK] button to apply the formatting to all cells that match the other cell range.

Now you are able to sort the data in the column based on cell color, select either the unwanted duplicates or unique value rows and delete them. Once your unwanted data has been removed clear the Conditional Formatting.
Instructions:

1. Select the InvalidRecords(3) sheet.
2. Select cell A2.
3. Hold the [Ctrl] and [Shift] keys then tap the [Down Arrow] key.
4. On the Home Tab, click the [Conditional Formatting] button drop-down in the Style Group.
5. Choose New Rule... from the menu.
6. Choose the Format only unique or duplicate values option in the Select a Rule Type: field.
7. Choose Duplicate from the Format All field drop-down.
8. Click the [Format] button.
9. Click the Fill Tab in the Format Cells dialog.
10. Choose any color from the list and click the [OK] button.
11. Click the [OK] button in the New Formatting Rule dialog.
12. Save and close the file.

Results/ Comments:

This is the third sheet created earlier.
The first cell containing the data to be formatted, In this case the unique employee ID number.
The rest of the column is selected.
The Conditional Formatting options are displayed.
The New Formatting Rule dialog opens.
The options related to the Format only unique or duplicate values are displayed.
You can choose to apply formatting to either unique or duplicate values form the drop-down.
The Format Cells dialog opens.
The fill cells options are displayed.
This will be the color applied when a duplicate is found. Choose a color that will stand out from the rest of the formatted data set.
The dialog is closed and the formatting applied to all duplicates.
[Ctrl+S] and [Ctrl+W].
Combining Cell Values

Data can come broken down into the smallest usable parts but that may not what is required in the current file, it would be better to re-combine the data into a single cell. Excel offers several methods to assist in this type of undertaking; a simple add formula, the new CONCAT function, or TEXTJOIN function.

Simple Combining Formula
This is a very basic formula used to combine content into a single cell. If the contents are in cells, use the cell addresses.

First String   Second String
  ↓         ↓
=text1&text2&.....

Ampersand will join the elements

You can add strings of your own by wrapping the string in quotation marks.

CONCAT Function
A new function which replaces the Concatenate function. Although the Concatenate function will still work, ensuring older files using that function continue to work as excepted.

The Concat function is used to combine text strings from multiple cells. The text strings can be held in cells or added from within the formula itself. Should a delimiter such as a blank space, be required, it must be added within the formula.

Syntax

Function   First String
  ↓         ↓
=CONCAT(text1,[text2],.....)

Second String

If the string is held within a cell, the formula will use the cell addresses. To add the subsequent strings, use a comma to separate one string from the next.
Combining Cell Values, continued

When required text or a required delimiter is not in a cell, wrapping it inside quotation marks will add those into the results of the formula.

**TEXTJOIN Function**

Similar in function to the CONCAT formula, this can add a delimiter directly into the returned value. Instead of having to add a quoted space or comma to separate each string the TEXTJOIN functions first argument allows you to define a delimiter once.

**Syntax**

=TEXTJOIN(delimiter,ignore_empty,text1,.....)

- **Delimiter**: as a text entry it should be held inside of quotation marks. for a space you would enter- " "
- **Ignore_Empty**: this will be either True or False. True will ignore empty cells in the returned value while False would add empty cells as blank spaces in the formula results.
- **Text1,Text2,..**: these are the cell addresses that are to be joined by the formula.

---

Combining Cell Values, continued

=CONCAT("text1"," ", "text2")

When required text or a required delimiter is not in a cell, wrapping it inside quotation marks will add those into the results of the formula.

**TEXTJOIN Function**

Similar in function to the CONCAT formula, this can add a delimiter directly into the returned value. Instead of having to add a quoted space or comma to separate each string the TEXTJOIN functions first argument allows you to define a delimiter once.

**Syntax**

=TEXTJOIN(delimiter,ignore_empty,text1,.....)

- **Delimiter**: as a text entry it should be held inside of quotation marks. for a space you would enter- " "
- **Ignore_Empty**: this will be either True or False. True will ignore empty cells in the returned value while False would add empty cells as blank spaces in the formula results.
- **Text1,Text2,..**: these are the cell addresses that are to be joined by the formula.
Case Functions

When raw data has a mix of cases, creating issues of inconsistent formatting, Excel has other text functions to help correct those issues.

- **PROPER**: will capitalize the first letter in each text string.
- **UPPER**: will capitalize the entire text string.
- **LOWER**: will remove any capitals from the text strings.

These are often used to apply text formatting by nesting other formulas inside of the argument. As an example, see the formula below:

=PROPER(CONCAT(text1,text2))
Action 1.5 - Combining Cells

Instructions:

1. Open the **CleanUp** file from the data files folder.

2. Select the **Names** sheet.

3. Select cell E3.

4. Enter the following formula:
   
   =A3,"&",B3,"&",C3

   [Ctrl+Enter] to apply the formula.

5. Use the autofill to combine the other names.


7. Enter the following formula:
   
   =CONCAT(J3,"",K3,"",L3)

   [Ctrl+Enter] to apply the formula.

8. Use the autofill to combine the other names.

9. Select cell E22.

10. Enter the following formula:

    =TEXTJOIN(" ",True,B22,C22,A22)

    [Ctrl+Enter] to apply the formula.

11. Use the autofill to combine the other names.

Results/ Comments:

You will combine the first name in this cell.

This is a simple combination formula. Using the [Ctrl+Enter] keys applies the formula and keeps cell E3 selected.

Double clicking the autofill handle runs the formula down

This cell will use a CONCAT function to combine the names.

The " " are used to add the blank space delimiters between the the cell values.

This cell will use a TEXTJOIN function to combine the names.

The first argument of this formula defines what the delimiter will be, TRUE will ignore any blank cells in the returned value, then the list of cell addresses are what will be joined.
Instructions:

12. Re-select cell M3.

13. Enter the following formula:
   =PROPER(CONCAT (J3,"",K3,"",I3))
   [Ctrl+Enter] to apply the formula.

14. Use autofill to correct the rest of the names in this list.

15. Save the file.

Results/ Comments:

The data is using a mix of upper and lower case text and the formula result reflect these inconsistencies.

Nesting the CONCAT function inside a PROPER function will return the data formatted in the desired manner.

[Ctrl+S].
Splitting Cell Values

It may become necessary to split a cell into smaller data components spanning adjacent columns. Excel offers a variety of tools and methods to accomplish this task. Just as there are function formulas used to combine cells, there are function tools used to extract data from cells; LEFT, MID, RIGHT, the [Text to Columns] button, and Flash Fill.

Text to Columns

This tool works best when the data has a consistent structure with a common character to use as the delimiter.

◊ Examine the Column to be broken into multiple columns in order to determine how many columns will be needed.

◊ Select that number of columns to the right of the column being separated, right-click on the selected columns and choose Insert from the menu.

◊ Select the column to be separated.

◊ Activate the Data Tab.

◊ Click the [Text to Columns] button.

◊ The Convert Text to Columns Wizard dialog opens to Step 1 of 3.

Note: If columns are not added before completing the Text to Columns, existing data will be replaced to accommodate the additional columns.
If necessary, select the **Delimited** radio button, and click the [Next] button to advance to **Step 2 of 3**.

Check the checkbox for the appropriate delimiter.

Other will allow you to define the delimiter.

Watch the **Data preview** window to see how the data will be broken apart.

When the data has empty adjacent cells, checking the **Treat consecutive delimiters as one** will combine empty cells into a single cell.

Once the delimiter is set, click the [Next] button to advance to **Step 3 of 3**.

Select each column to set the data type with the **Column data format** radio buttons.
Lesson 1: Tables & Data Management

Splitting Cell Values, continued

◊ Unnecessary columns can be selected and skipped by choosing the Do not import column (skip) radio button.

◊ Once the data formatting is done, you are able to set the Destination of where the data will be placed.

◊ Click the [Finish] button.

**Function Formulas**

*Right*: This function returns the right-most character or characters from a string. The number of characters specified will be what is returned.

**Syntax**

=RIGHT(text,[num_chars])

◊ *Text*: The cell address which contains the text string to be extracted.

◊ *Num_chars*: if this is not included in the formula, then only the last character is extracted from the string. Entering a value will return that number of characters from the string, blanks are considered characters.

*Left*: this function returns the left most character or characters from a text string. The number of character specified will be what is returned.

**Syntax**

=LEFT(text,[num_chars])

◊ *Text*: The cell address which contains the text string to be extracted.

◊ *Num_chars*: if the is not included in the formula, then only the first character is extracted from the string. Entering a value will return that number of characters from the string, blanks are considered characters.
Mid: This function will return a specific number of characters from a text string. You are able to set the starting position, in number of character from the left, as well as the number of character being extracted.

Syntax

\[=\text{MID(text,start_num,num_chars)}\]

- \textit{Text:} The cell address which contains the text string to be extracted.
- \textit{Start_num:} The number of characters over from the left where the extraction is to begin. (Blank spaces are characters)
- \textit{Num_chars:} Sets to number of characters to be extracted from the text string.

When dealing with text string of variable lengths which do also contain fixed parts, the Len functions can prove a useful addition to a Left or Right function.

\textit{Len:} returns the number of characters in a string.

Syntax

\[=\text{LEN(cell)}\]

- \textit{Cell:} contains the string whose characters are to be counted. Spaces are included in the results as they are hidden characters.

Nesting Len Inside Left or Right

Syntax

\[=\text{LEFT(cell,LEN(cell)-value)}\]

- \textit{LEFT(cell,:} where the left characters will be extracted from.
- \textit{LEN(cell):} counts the number of characters in the Left functions cell.
- \textit{-value:} sets the starting point of left character extraction from the cell. This completes the LEFT function.
**Action 1.6 - Splitting Cells- Text to Columns**

**Instructions:**

1. The **CleanUp** file should still be open.
2. Activate the **Splitting_TextToColumns** worksheet.
3. Select columns B:D.
4. Right-click the selected columns and choose **Insert** from the menu.
5. Select column A.
6. On the **Data Tab**, in the **Data Tools Group**, click the [Text to Columns] button.
7. Check to see the **Delimited** radio button is active and click the [Next] button.
8. In the **Delimiters** section, check only the **Other** checkbox and in the field enter a -(Hyphen)-. Check the **Treat consecutive delimiters as one** checkbox, then click the [Next] button.
9. Select the third column in the preview and in the **Column data format** section, choose the **Date:** radio button.
10. Set the cursor into the **Destination:** field and set the cell address to B1. Then click the [Finish] button.
11. Add the headers for columns C:D.
12. Save the file.

**Results/ Comments:**

- If not, re-open it.
- The first column of data needs to be broken up into Class, Location, and Date.
- To avoid replacing data, it is a good idea to set up space for the new columns to be added before splitting up the data.
- This is the column to be split apart.
- The **Text to columns** dialog opens.
- Step 1 is completed and the dialog advances to step 2.
- As delimiter checkboxes are modified, the preview of how the data is separated changes. Since a hyphen separates each component part of the data, that is the delimiter needed to break the data into the desired sections. Step 2 is completed and the dialog advances to step 3.
- This ensures the data type is correctly set and formatted.
- By not using cell A1 as the destination, the original data is not replaced and lost.

- Location and Date

- [Ctrl+S].

Excel 2019: Data Analysis, Rel. 1.0, 5/6/2020
Lesson 1: Tables & Data Management, Page 29
### Instructions:

1. The CleanUp file should still be open.
2. Activate the Splitting_Functions worksheet.
3. Select column K:L.
4. Right-click the selected columns and choose Insert from the menu.
5. Select cell K1 and type in: **Course_Category_Number**.
6. Select cell K2 and enter the following formula:
   
   ```excel
   =LEFT(J2,4)
   ``
   [Ctrl+Enter] when done.
7. Use Autofill to complete the rest of the column.
8. Select cell L1 and type in: **Course_Application_Version_Number**.
9. Select cell L2 and enter the following formula:
   
   ```excel
   =RIGHT(J2,4)
   ``
   [Ctrl+Enter] when done.
10. Use Autofill to complete the rest of the column.
11. Save the file.

### Results/ Comments:

If not, re-open it.

To add space before splitting up data.

This is the column header.

This formula will extract the first four characters from the value in cell J2. The [Ctrl+Enter] keys apply the formula and keep cell K2 selected.

Double-click the autofill handle.

This column header.

This formula extracts the last four characters from the string in cell J2.

[Ctrl+S].
Flash Fill

Flash Fill can often replace the need for formulas like PROPER, CONCAT, TEXTJOIN, LEFT, and RIGHT. Flash Fill recognizes patterns to combine, separate, or reformat data based on an example created by the user. Flash Fill uses multiple applications and lines of code in the background of Excel to anticipate the data you want it to fill in the list. If it cannot get a complete list because the pattern is not recognizable, you can add additional examples to expand the list and Excel will apply them along with the previous examples to create a more complete list.

◊ Click in a blank cell next to the data. Do not leave an empty column between the data and the flash fill column. Type the content you want to extract from your list and press [Ctrl+Enter].

◊ Make sure the active cell is still the one with the example data or the active cell is below the example data. Click the [Fill] button from the Editing Group on the Home Tab, and select Flash Fill.

**Note**

You can be at any row in the column where the Flash Fill is to be run in order to use this feature. Although, the sample data you create must be from the same row you are in.

**- OR -**

◊ Click on the Data Tab to activate it.

◊ Select the [Flash Fill] button in the Data Group.
## Instruction:

1. Click the *FlashFill* sheet tab.

2. Select cell I1 and type: Full Name.

3. Select cell I2 and type: Jones, Alan.

4. Select cell I3 and begin typing: Adams
   - when the Flash Fill list is displayed, tap the [Enter] key.

5. Auto adjust the width of column I.

6. Select cell J1 and type: Email.

7. Select cell J2 and type: a.jones@twc.com.

8. Select cell J3 and use the [Ctrl+E] shortcut.

9. Save and close the file.

## Results/ Comments:

This will be the header for the new column

This is how the first and last names will be combined.

As you begin entering the second entry, Flash Fill recognizes the pattern and prompts to apply it.

Set the cursor between columns I and J, double-click when the cursor is a double-headed arrow.

A new column header is added.

This will both extract and combine data from existing data with addition you have entered.

Flash fill is run and the column of email addresses has been added.

[Ctrl+S] and [Ctrl+W].
Managing and analyzing related data is made easier when the range is converted into an Excel table. Tables are comprised of adjacent columns of data, each with unique labels or headings, and each row represents an individual entry within the table. Another way to consider the structure of a table is that the columns are fields and rows are records. When creating tables, it is recommended to not include any blanks rows or columns.

Tables offer a variety of tools to assist in managing of the data they hold. When any cell in a table is active the **Table Tools Design Tab** are active in the ribbon, this tab has tools for formatting, adding or removing table elements, exporting, or refreshing table data. Filtering is automatically engaged as tables are created. A type of freezing panes is also in play, when you scroll down in a table the table headers replace the column headers.

### Table Elements

**Header Row:** Tables can have a header row. When the header row is enabled, filtering is also turned on by default. Filtering offers the ability to both sort and filter data in the data.

**Calculated Columns:** When entering a formula in a cell within in a table column or in a blank column beside the table, the formula is instantly applied to all other cells in the column. If the column was not part of the table, it is added to the table.

**Total Row:** Tables can have a total added, the row comes with a drop-down which offers a list of common built-in formulas. These are similar to using the AutoSum functions found on the Home and Formula Tabs.

**Banded Rows or Columns:** To make the table easier to read cell shading can be added to alternating rows and/or columns. (Do not apply both since it will make it hard to understand the data.)

When using the Get Data tools, Excel will automatically bring the data in as a Table by default. Although, you are able to choose to bring the data in as a PivotTable, or PivotChart with Table.
**Creating a Table Using Home Tab**

- Select a cell in the range of data to be included in the **Table**. **It is not necessary to select all the data but all the data must be connected.**

- Activate the **Home Tab**, click on the **Format as Table** button in the Styles Group.

- This will display a gallery of **Table** styles.

- Click one of the **Table** style options to format the selected range as a **Table**.

- The **Format as Table** dialog will be displayed.

- If there are column headings in the first row of the range you selected for your **Table**, check the box that says, **My table has headers**.

- Make sure the cell range shown is the range that you want for your **Table**; if it is not, just type the correct range in the **Where is the data for your table** field.
Creating a Table, continued

◊ Click the [OK] button to create your Table.

◊ In the example here, note the Autofilter buttons are automatically added to a Table.

Using the Insert Tab

◊ Select a cell in the range of data to be included in the Table.

◊ Activate the Insert Tab.

◊ Click on the [Table] button in the Tables Group.

◊ The Create Table dialog.

◊ If there are column headings in the first row of the range you selected for your Table, check the box that says, My table has headers.

◊ Make sure the cell range shown is the range that you want for your Table; if it is not, just type the correct range in the Where is the data for your table field.
Creating Tables, continued

Using the Quick Analysis Tool

◊ Select the range to be converted into a table.
◊ Point to the lower right corner of the range and click the Quick Analysis Tool pop-up.
◊ Select the Tables tab and click the [Table] button.
1. Open the SalesTables file.

2. Save the file as MySalesTables.

3. Select the SalesData spreadsheet and click on any cell containing data.

4. On the Home Tab in the Styles Group, click the [Format As Table] button.

5. Choose the first style from the gallery.

6. In the Format As Table dialog, check to see =A$1:H$193 is displayed in the Where is the data for your table field.

7. Also, make sure the My table has headers checkbox is selected.

8. Click [OK].

9. Observe the Table Tools Design Tab which has been added to the Ribbon.

10. Click any empty cell.

11. Click any cell in the table.

12. Save your workbook. Leave it open.

This file is found in the data files folder.

Notice there are no blank columns or rows included in this dataset.

A gallery of styles will be displayed.

The Format As Table dialog is displayed.

Since all the data is contiguous, Excel should recognize all the connected data as the source for the table.

Excel automatically checks this option since the first row of the dataset is not necessarily in-line with the data beneath. If you remove the checkmark, your headers will be replaced with Column 1, Column 2, etc.

The selected table style is now applied and the data is in a table format.

This is a contextual tab that is only available when any cell in the table is actively selected.

Notice that the Table Tools Design Tab is gone.

Notice that the Table Tools Design Tab is back although, it may not be the active tab.

[Ctrl+S].
### Instructions:

1. Make the *SalesData*(2) spreadsheet active.

2. Click any cell containing data.

3. On the **Insert Tab**, click the **[Table]** button in the **Table Group**.

4. Make sure the **Where is the data for your table** field is displaying the range $A$1:$H$193.

5. Make sure the **My data has headers** checkbox is checked.

6. Click the **[OK]** button.

7. Notice the **Table Tools Design Tab** is active.

8. Save the file.

9. Make the *SalesData*(3) spreadsheet active.

10. Select all the cells containing data.

11. Click the **Quick Analysis** smart tag.

12. Click the **Table** category at the top of the **Quick Analysis** options.

13. Click the **[Table]** button.

14. Save the file.

### Results/ Comments:

<table>
<thead>
<tr>
<th>Results/ Comments:</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is the second sheet in the workbook.</td>
</tr>
<tr>
<td>The <strong>Create Table</strong> dialog is displayed.</td>
</tr>
<tr>
<td>This defines the contiguous range of cells that make up the table.</td>
</tr>
<tr>
<td><em>Excel</em> will automatically add Autofilter drop-downs to each header in the table.</td>
</tr>
<tr>
<td>The table is created.</td>
</tr>
<tr>
<td><strong>[Ctrl+S]</strong>.</td>
</tr>
<tr>
<td>This is the third sheet in the workbook.</td>
</tr>
<tr>
<td>Click into any cell containing data and use the keyboard shortcut <strong>[Ctrl+A]</strong> to select all connected data.</td>
</tr>
<tr>
<td>It will be located at the bottom right corner of the selected range. You can also use the shortcut of <strong>[Ctrl+Q]</strong> to bring the smart tag into view without having to scroll to it.</td>
</tr>
<tr>
<td>It is the fourth option.</td>
</tr>
<tr>
<td>The table is created.</td>
</tr>
<tr>
<td><strong>[Ctrl+S]</strong>.</td>
</tr>
</tbody>
</table>
Autofilters

An **Autofilter** is an *Excel* feature that lets you filter out records from a **Table**. When you select an **Autofilter** option, only records that meet the specified criteria will be shown. When you create a table from raw data or import data into *Excel* as a table, filtering is automatically turned on. Each column header displays a drop-down that allows you to filter the data quickly.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>200</td>
<td>500952</td>
<td>703618</td>
<td>803594</td>
</tr>
<tr>
<td>350</td>
<td>189209</td>
<td>428255</td>
<td>240955</td>
</tr>
</tbody>
</table>

If the Table does not have Filters turned on, go to the **Table Tools Design Tab** and in the **Table Styles Options Group** click the checkbox for **Filters**.

**Basic Filtering**

To filter a **Table** based on a specific criteria do the following:

- Click the **Autofilter** arrow next to the column heading you want to filter.
  - Filtering options will correspond to the type of data held in the field (column).
  - Data can be **Text**, **Numbers**, or **Dates**.

- You will see the corresponding field values from your **Table** in ascending order. Notice that each unique field entry is present in the list. If you have a lot of records in your **Table**, the **Autofilter** list will scroll to show all of the fields.

- Remove the checkmarks by the list items you want filtered out, and leave checkmarks by list items you want shown.
  - Unchecking **Select All** will allow for speedier filtering since you will not have to uncheck as many boxes.
Action 1.10 - Basic Filtering

Instructions:

1. Activate the SalesData sheet.

2. If the Autofilter drop-downs are not visible, check the Filters checkbox on the Table Tools Design Tab.

3. Click the Autofilter drop-down for the Sales Rep column.

4. From the drop-down menu uncheck the Select All checkbox and check the Clotts checkbox and click the [OK] button.

5. Click the Autofilter drop-down on the Product ID header.

6. Uncheck the Select All checkbox and check the 3227 checkbox and click [OK].

7. On the Data Tab, in the Sort & Filter Group, click the [Clear] button.

8. Save the file.

9. Select the SalesData(4) sheet.

10. Select any cell with data.

11. On the Data Tab, in the Sort & Filter Group, click the [Filter] button.

Results/ Comments:

The first sheet with the data formatted as a table.

The Autofilters should be active.

The Autofilter options are displayed.

Since you are picking only one specific item, unchecking all the unwanted items would be very time consuming. By unchecking the Select All option you will only need to find the individual item to filter for. Only records where Clotts was the sales rep are displayed in the table. All the other data is hidden, not deleted.

Now only sales of product 3227 made by Clotts are displayed.

All filter are cleared and all the data is re-displayed in the table.

[Ctrl+S].

The last sheet that doesn't have the data in a table.

It is not necessary to select the entire data set before applying filtering.

The Autofilter drop-downs are placed in the header row.
Action 1.10 - Basic Filtering, continued

Instructions:

12. Click the Autofilter drop-down on the Sales Rep header.

13. Uncheck the Select All checkbox and check the Adams checkbox.

14. On the Data Tab in the Sort & Filter Group, click the [Clear] button.

15. Save the file.

Results/ Comments:

The Autofilter options are displayed.

Only sales by Adams are displayed, just as before. You can also applying filter to multiple columns as when in the Table.

All the data is re-displayed. You can also click the Autofilter button on the State column and choose Clear Filter From "Sales Rep".

[Ctrl+S].
If you display the **Autofilter** menu for a column you will see either **Text Filters**, **Date Filters** or **Number Filters** depending on the type of data held in the column. If you click on any of these **Filter** options, you will see a submenu of further filtering selections.

Clicking one of these options will display the **Custom Autofilter** dialog box. Using the **Custom Autofilter** options, you can set up a customized **Filter** for your **Table**.

### Creating a Custom Autofilter

- Select the **Autofilter** drop-down button for the field that you want to filter.
- Choose either **Text Filters**, **Date Filters** or **Number Filters**.
- Click **Custom Filter** from the submenu. This will open the **Custom Autofilter** dialog.

- Use the drop-down arrows and option buttons to establish filtering criteria for your records. The options in the drop-down include:

<table>
<thead>
<tr>
<th>Text &amp; Number Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Equals</strong></td>
</tr>
<tr>
<td><strong>Is greater than</strong></td>
</tr>
<tr>
<td><strong>Is greater than or equal to</strong></td>
</tr>
<tr>
<td><strong>Begin with</strong></td>
</tr>
<tr>
<td><strong>Ends with</strong></td>
</tr>
<tr>
<td><strong>Contains</strong></td>
</tr>
<tr>
<td><strong>Does not equal</strong></td>
</tr>
<tr>
<td><strong>Is less than</strong></td>
</tr>
<tr>
<td><strong>Is less than or equal to</strong></td>
</tr>
<tr>
<td><strong>Does not begin with</strong></td>
</tr>
<tr>
<td><strong>Does not end with</strong></td>
</tr>
<tr>
<td><strong>Does not contain</strong></td>
</tr>
</tbody>
</table>
Autofilters, continued

<table>
<thead>
<tr>
<th>Date Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equals</td>
</tr>
<tr>
<td>Is After</td>
</tr>
<tr>
<td>Is before</td>
</tr>
<tr>
<td>Begins with</td>
</tr>
<tr>
<td>Ends with</td>
</tr>
<tr>
<td>Contains</td>
</tr>
</tbody>
</table>

- The next drop-down list will contain values from your **Table** belonging to the current field.
- Select the **And** option button or the **Or** option button to incorporate additional criteria into your **Filter**.

- When you use the **And/Or** option buttons to build **Custom Filters**, remember:
  - When using the **And** option, both conditions (A and B) must be satisfied for the record to be shown.
  - When using the **Or** option, records that satisfy either condition will be shown.
- Use the option buttons to combine filtering conditions, or just filter based on options from the first two drop lists.
- Clicking the **[OK]** button will remove from view any data that does not fit within the parameters of your Custom Filtering.
Autofilters, continued

When the data is filtered, the column header will show a funnel icon next to the drop-down list button. You are able to filter by one or as many columns as needed to find specific data within the dataset.

Using the Search Feature

There are times when you know what to filter for, in these cases it is easiest to simply click into the search field and type in what is needed.

Using Wildcards

There are times when you want to search for a set of variables. Using wildcards in the search allows for broader searches. There are two characters used as wildcards;

- * represents any number of any characters.
- ? represents any single character.

If you were to enter a search of PRO*: the results would be any words that simply begin with PRO, no matter how long the word is.

If you entered PRO????: the results would be any word that begins with PRO and contains four more letters.
Clearing Filters

Once you have found specific data and now need to see all the data in the dataset, you will need to clear any or all applied filters.

◊ Click the filtered column Autofilter drop-down and click the **Clear Filter** option on the menu.

◊ If multiple columns are filtered you would do it for each column.

- OR -

◊ Use the **Filter** controls in the **Sort & Filter Group** on the **Data Tab**.

◊ Click either the **Clear** or the **Filter** button to clear all the filters at once.
## Instructions:
1. Select the *SalesData* sheet.
2. Select the Autofilter drop-down for the *Unit Price* column.
3. Select *Number Filters* and choose *Between* from the menu.
4. In the *Custom Autofilter* dialog box,
   - Under the *is greater than or equal to* field, type: 20
   - and under the *is less than or equal to* field, type: 35
5. Click **[OK]** and examine the filtered data.
6. Click the Autofilter drop-down for the *Unit Price* column.
7. Choose *Clear Filter* from the menu.
8. Click the Autofilter drop-down for the *Customer Name* field.
9. In the *Search* field type in: *Merlin*.
10. Clear the filter.
11. Save your workbook.

## Results/ Comments:
The *Custom Autofilter* dialog is displayed.

This establishes the parameters of the data you wish to view based on information in the *Unit Price* column.

Only information matching the defined parameters are displayed. All the other data is hidden, not deleted.

This removes filtering from this column. If several columns were being filtered, you could use the **[Clear]** button on the *Data Tab* in the *Sort & Filter Group* to clear all the filters.

Use the Autofilter drop-down or the **[Clear]** button on the *Data Tab*.

[Ctrl+S].

---

Excel 2019: Data Analysis, Rel. 1.0, 5/6/2020
Lesson 1: Tables & Data Management, Page 46
Advanced Filter

If you can’t get the results you want from a Custom Filter, you can construct an Advanced Filters to create a query that can extract specified information from the dataset. This is a two step process; the first step is to create a set of cells to define which columns in the dataset are being searched and then define the search parameters of the search within the specified columns. The second step in the process uses the Advanced Filters to extract the desired information.

Using an Advanced Filter

Establish a Criteria Range

- Type or copy the column headings that correspond to the Fields in the dataset on which you want to Filter. Paste or type them into a cell outside the Table range. This heading must be exactly the same as the corresponding heading in the Data Table that you want to base the Filter on; so it may be easiest to copy and paste.

![Criteria Range](image)

- Type the constraints below the Column Heading in the Criteria Range.

In this example, you want to show only the Records where the Age Field is less than 40.

Applying the Advanced Filter

- Click on any cell in the Data Table, and then click the Advanced button on the Data Tab.
Advanced Filter, continued

◊ The Data Table will be outlined with a marquee, and the Advanced Filter dialog opens.

◊ Make sure the Table range is the range you want to Filter. It should already be defined by default.

◊ Click into the Criteria range: field and select the cells that contain your filtering criteria (cells F1:F2 in this example).

◊ If Filter the list, in-place option button is selected, the Filtered Records will appear in the same location as the original Table. The rows that do not fit the criteria will simply be hidden.

◊ Click [OK] to filter the dataset using the constraints specified in the Criteria Range.

Clearing the Filter

After examining or working with the filtered data, you will need to clear the advanced filter.

◊ To display the full Table again, select the Data Tab and in the Sort and Filter Group, click the [Clear] button.
You may want to extract your Filtered Records to a new place in the worksheet or even to a different worksheet altogether. Copying your Filtered Records to a new location leaves the view of your original dataset unchanged.

### Copying Filtered Records to a New Location

- Set up a Criteria Range as before, with column headings and the constraints you need. Make sure the Field names match those in the dataset exactly.
- Prepare a range for the Filtered Records to be copied to.
  - Add the column headings for the result set in the range you will be copying to. You do not have to use all of the Fields in the entire Record, just the Fields of your choice.

If you do not put column headings in the copy to range, all of the Fields specified in the Table range will be copied.

- Click a cell in the dataset. Select the Data Tab and in the Sort and Filter Group, click the [Advanced] button. The Advanced Filter dialog will be displayed.
- Set your options as before, but this time, choose Copy to Another Location from the option buttons in the Action section of the dialog.
  - In the Copy to: text box, select the range that you have prepared for the copied Records with your mouse or type it in directly. If you don’t know how large a range to include, just select the column headings in the destination area.
  - Click [OK] to copy the Filtered Records to the destination range. The example at below shows only the Fields for weight and age filtered based on a criteria of people with a height less than 70.

Note: You can also specify Unique records only by clicking the appropriate checkbox in the Advanced Filter dialog. This will ensure that duplicate Records are not selected or copied.
Action 1.12 - Using an Advanced Filter, Filtering In Place

Instructions:

1. Select the SalesData(2) sheet.

2. Select cell D1.

3. Copy the cell and paste it into cell K1.

4. Select cell H1.

5. Copy the cell and paste it into cell L1.

6. Select cell K2, and type: Clotts.

7. Select cell L2, and type: >25

8. Select the Data Tab, and in the Sort & Filter Group, click the [Advanced] button.

9. In the Advanced Filter dialog, set the following:
   Filter the list: in-place
   List range: $A$1:$H$193
   Criteria range: $K$1:$L$2

10. Click [OK].

11. On the Data Tab in the Sort & Filter Group, click the [Clear] button.

Results/ Comments:

The second sheet in the workbook.

This will be the first field of the Advanced Filter.

Copy / pasting will ensure there are no discrepancies with the headers in the data set.

This will be the second field of the Advanced Filter.

Our goal is to construct an Advanced Filter to retrieve the records where a specific Sales Rep sold more than 25 units per sale.

The Sales Rep the filter will search for.

This is the second criteria that must be met in the filter. When the criteria are in the same row it means AND.

The Advanced Filter dialog opens.

Only records where Clotts sold more than 25 units are displayed.

All the records in the data set are re-displayed.
**Instructions:**

1. Select the *Data Tab*, and in the *Sort & Filter Group*, click the *[Advanced]* button.

2. In the *Advanced Filter* dialog, set the following:
   - *Copy to another location*
   - *List range*: $D$1:$D$193
   - *Criteria range*: blank
   - *Copy to*: O1
   - *Unique Values Only* = Checked

3. Click *[OK]*.

4. Save your workbook.

**Results/ Comments:**

The *Advanced Filer* dialog opens.

A list of Sales Reps is added starting in cell O1.

*[Ctrl+S]*.
Data Forms

You can use a **Data Form** to add, find, change, and delete rows in a range or table. To add the **Form**, you need to use the **Form Tool**. The **Form Tool** is not included on the **Ribbon** or in the **QAT** by default.

**Adding the Form Tool to the QAT**

- Click on the **[More]** button on the **QAT**.
- Select **More Commands** from the drop-down menu. This will open the **Excel Options** dialog.
- Click on the drop-down arrow of the **Choose Commands from** text box.
- Select **All Commands**.
- Find the **[Form]** button in the command list and double-click on it or click on **[Add]** to add it to the **QAT**.
Using a Form to Enter Records

◊ Select a cell in the table or data set.
◊ Click on the [Form] button in the QAT. A dialog appears with the Field names and fields to enter information related to the Record.
◊ Click on the [New] button to add a new Record.
◊ Use the [Find Prev] and [Find Next] buttons to navigate between Records.
◊ Use the [Criteria] button to find specific Records.
◊ Wildcards and search criteria can be used to locate specific Records. For example, typing F* in the Company Name: field will find all Records where the Company Name begins with an "F". Or typing >2000 in the Invoice Total: field will find all invoices with amounts greater than $2,000.
◊ Click the [Find Next] button after typing in the Criteria, to locate the required Record.
Action 1.14- Adding the Form Command to The QAT

Instructions:

1. Click the File Tab.
2. Click the Options command.
3. Select the Quick Access Toolbar category.
4. Change the Choose commands from: field to All Commands from the drop-down list.
5. Find the Form... in the list of All Commands.
6. Click the [Add] button.
7. Click the [OK] button.

Results/ Comments:

The Backstage view is displayed.
The Excel Options dialog is opened.
The Quick Access Toolbar modifications are available.
The list of available commands is changed, every command in Excel is displayed in the left panel. The list is laid out in an alphabetical manner.
Scroll through the list to find the command.
The command is added in the right panel that shows any commands already on the QAT. Double-clicking the command in the left panel will also add the command to the right panel.
The Excel Option dialog is closed and the command is now on the QAT.
Instructions:

1. The SalesData sheet should still be active and select any cell in the table.

2. Click the Form command on the QAT.

3. Click the [Find Next] button.

4. Click the [Criteria] button.

5. In the Sales Rep field, type in; <Clotts> and click the [Find Next] button.

6. Click the [Find Next] button.

7. Click the [New] button.

8. Enter the following information; Order ID= 194 Order Date = (today’s date) Customer Name = (your first name) Sales Rep = Smith Product Name = Product 1 Product ID = 3223 Unit Price = 32 Qty= 19

9. Click the [New] button.

10. Click the [Close] button.

11. Save the file.

Results/ Comments:

Click the first sheet in the workbook sheet list if necessary.

The Form dialog opens, notice that the dialog is named the same as the active sheet. It is displaying the first record in the table.

The second record is displayed in the Form dialog.

All the fields are cleared, allowing you to enter search criteria.

In this case you are looking for any records where Clotts was the Sales Rep.

The next record where Clotts was the Sales Rep is displayed.

All the fields are cleared, allowing you to enter a new record into the table.

This represents a new purchase record.

The record is added to the table and you are ready to begin entering another new record.

The Form dialog closes.

[Ctrl+S].

Excel 2019: Data Analysis, Rel. 1.0, 5/6/2020
Lesson 1: Tables & Data Management, Page 55
Lesson 2: Power Query

Lesson Overview

You will cover the following concepts in this chapter:

- Introduction to Power Query
- Get & Transform Data
- Navigator
- Power Query Editor
- Data from Another Workbook
- Data from a Text File
- Data from an Access Database
- Transforming Data
- Spliting Data
- Adding a Column
- Data Types
- Applied Steps
- Loading a Query
- Editing a Query
- Saving and Running A Query
Introduction to Power Query

Data coming into Excel for analysis is a common occurrence. As illustrated in the last lesson, cleaning up the data within Excel is not too difficult a task. *Power Query,* a data connection technology is now the standard tool used to import or gather data into Excel. Users of Excel 2010 and 2013 versions could download and install the Power Query add-in while the 2016 version it had been rolled in to the program alongside the legacy data connection and management tools.

The *Power Query* tool offers a streamlined manner to connect to, import, and manage data. You can connect to one or several data sources in order to build complex models to conduct meaningful analysis, combining data sources, merging tables, adding or removing columns. Once a query has been created, it is possible to save and reuse the query. This can save a considerable amount of time when re-running reports in the future.
Getting Data

Data can be imported into Excel from many different sources by using tools found in the Get & Transform Data Group of commands on the Data Tab. The data can be imported directly into a workbook as is, and then edited or cleaned-up within Excel.

Common types of external data sources have buttons in full view within the Get & Transform Group. There are many others available by using the [Get Data] drop-down button. This menu of options offers a list of data types with fly-out menus.

Once a choice of data type is made the next step in the process is to locate the data source in the Import Data dialog.

After the data source is located and opened, the Navigator dialog opens, which is the next step in the process.
The *Navigator* dialog shows users a list of available tables or data sets on the left and a preview of the data on the right. Choosing a source table, data set, or spreadsheet will change the preview to that of the selected source. If more than a single table from the source is required, checking the *Select multiple items* checkbox allows all selected tables to be imported.

Clicking the **Load** button will place the selected data sets into the workbook, beginning in the actively selected cell. Choosing *Load To...* from the drop-down of the **Load** button opens an *Import Data* dialog. This dialog allows you to determine how and where the data will be placed into the workbook.

Clicking the **Transform Data** button will open the data set in *Power Query*. 
The Power Query window is very similar to the Excel interface in that, both have a Quick Access Toolbar and tabbed ribbon navigation components.

- **QAT**: (Quick Access Toolbar) users can add common commands to this toolbar for easy access.
- **Ribbon**: just as in Excel, the ribbon is a tabbed set of related tools.
- **Query List pane**: all imported data sources are displayed here, clicking a query will display the selected data set in the Main view.
- **Data Set View**: this is the main view where data is previewed and modified.
- **Query Steps pane**: as modifications are made to the data set, those steps are listed in this pane. This can be seen as a history of all actions to prepare the data for importation. Any step in the list can be removed without removing steps made before or after the selected step.
Once all the data modifications are completed; unnecessary row and columns removed, data has been split into more manageable components, and columns of data being combined the data is loaded into an Excel workbook by using the [Close & Load] button on the Home Tab. This button offers the same options and functionality as in the Navigator dialog.

Choosing the Close & Load To.. option from the button’s drop-down will display the Import Data dialog.
Using the Get & Transform tool allows you to connect to data stored in other workbooks. The data can be a simple data set or formatted as a table, either can be brought into and managed in new or existing workbooks.

◊ On the **Data Tab**, in the **Get & Transform Group** click the **[Get Data]** button.

◊ Choose **From File** in the drop-down and then **From Workbook**.

◊ The **Import Data** dialog opens.

◊ Navigate to the other workbooks location and click the **[Import]** button.

◊ The **Navigator** dialog opens.

◊ Choose the spreadsheet or table from the list on the left of the dialog.

◊ If more than one data source is required, check the **Select multiple items** checkbox; and select all sources.
Data from Another Workbook, continued

Loading the data directly into Excel is done by clicking the [Load] button. This will place the data in cell A1 of a new worksheet as a table.

If you need the data to come in on an existing worksheet or as a PivotTable; click the drop-down arrow of the [Load] button and choose Load To ...

The Import Data dialog opens and you are able to set where and how the data will be placed into the workbook.
Instructions:

1. Create a blank new workbook.

2. Activate the Data Tab.

3. Locate the Get & Transform Group.

4. Click the [Get Data] button dropdown and choose From File, then From Workbook.

5. In the Import Data dialog, navigate to the data files folder and choose the Invoices.xlsx file.

6. Locate the list of available worksheets and tables in the source.

7. Check and uncheck the Select multiple items checkbox.

8. Select the Invoices from the list of available sources displayed on the left of the window.

9. Click the [Load] button.

10. Rename Sheet2 as Invoices.

11. Save the file in the data files folder as DataImports.xlsx.

Results/ Comments:

[Ctrl + N].

This is the first group on the Data Tab.

The [Get Data] button offers many options for connecting to external data sources. When the choice is made the Import data dialog opens.

The Navigator dialog opens.

These are all named tables and worksheets in the file. Another example of will it is good practice to name the worksheets and tables in your files.

When the Checkbox is checked, checkboxes are added in front of each options. Checking these will include them in the importation of data. When unchecked you are able to select only one.

The data in that table is displayed in the preview on the right of the window.

A new worksheet is added to the workbook with the imported data in a formatted table.

Double-click the sheet tab to rename it.

[F12].
Many of us will receive data in the form of CSV or tab delimited text files. The process for getting and importing those types of data will be done in the same manner as importing data from other Excel files. Using the tools in the **Get & Transform Data Group**, you will search for and connect to the source data by clicking the **[From Text/CSV]** button. When importing a text file, the **Navigator** dialog just shows the preview along with a set of fields above the preview.

Should the preview show the data breaking in an unexpected manner; use the **Delimiter** field to set the correct delimiter. From the **Delimiter** field drop-down you are able to choose from a list of commonly used delimiters or set your select your own.

Choosing **Custom** will add a new field below the **Delimiter** field where you are able to type in the delimiter of your choosing.

Choosing **Fixed Width** from the **Delimiter** field will add a new number field below the **delimiter** field. Allowing you to set the number of characters to divide the content by in order to generate columns.
Action 2.2 - Importing Data From a Text File

Instructions:

1. DataImports.xlsx should still be open.

2. Activate the Data Tab.

3. Click the [From Text/CSV] button locate in the Get & Transform Group.

4. In the Import Data dialog, navigate to the data files folder and open the CustomerListNorthAmerica.csv file.

5. Locate the Delimiter field.

6. Using the Delimiter field drop-down change the delimiter from Comma to Tab.

7. Change the delimiter back to Comma.

8. Click the [Load] button drop-down and choose Load To...

9. Leave the Select how you want to view this data in your workbook choice as Table.

10. In the Where do you want to put the Data? section, choose the Existing worksheet radio button. Click into the field below, highlight any existing text and delete it, select cell A1 on Sheet1, click the [OK] button.

11. Rename Sheet1 as NA Customers.

12. Save the file and leave it open.

Results/ Comments:

If not, re-open it.

The Import Data dialog opens.

The Navigator dialog opens.

As a textually based source file, you are able to set the delimiter if needed.

The preview now shows all the data in a single column. This is because the source is not using tabs to separate the data.

The data is broken into multiple columns again.

A second Import Data dialog opens.

This will apply a table format to the data.

This allows you to define where the data is placed. This is where it will be placed. The data is placed and formatted as a table. The table does not use the column headers as headers, this will be fixed later.

Double-click the sheet tab to rename.

[Ctrl +S].

Excel 2019: Data Analysis, Rel. 1.0, 5/6/2020
Lesson 2: Power Query, Page 68
Data from an Access Database

Gathering data from an Access Database follows similar lines as within importing Excel or text content. Sometimes we want to bring in a table from a database but not know what other tables are related; the Navigator dialog allows you to **Select multiple items**. When the **Select multiple items** checkbox is checked and a table is selected, the [Select Related Tables] button becomes active. Clicking this button will select all related tables in the database at once; alleviating the need to know and understand the entire database structure.

To connect to the access database use the [Get Data] button dropdown and choose **From Microsoft Access Database** from the list of database types.

![Get Data dropdown menu showing From Microsoft Access Database option]

Should your database type not be listed, contact the manufacturer of your database to see if they have and can send you the required drivers to connect to Excel.

In the Import Data dialog, navigate to and select the desire database then click the [Open] button.
Data from an Access Database, continued

The Navigator dialog opens, in the left of the dialog is the list of tables in the database. You will notice that the [Select Related Tables] button is greyed out and inactive. In order to make it active; you must first check the Select multiple items checkbox, then select a table from the list. Then the [Select Related Tables] button is active. Clicking the button will allow the Navigator to follow all the primary to foreign key threads to include all necessary data in the import.
### Instructions:

1. **DataImports.xlsx** should still be open.

2. Activate the **Data Tab**.

3. Click the [Get Data] button drop-down and choose **From Database**, then **From Microsoft Access Database**.

4. In the **Import Data** dialog, navigate to the data files folder and choose the **ShippingDatabase.accdb**.

5. Select **CompanyNames** from the list of tables.

6. Check the **Select multiple items** checkbox.

7. Check the **CompanyNames** checkbox.

8. Click the [Select related Tables] button.

9. Uncheck the checkboxes for **CompanyNames** and **Countries**.

10. Click the [Select related Tables] button again.

11. Uncheck the **Select multiple items** checkbox.

12. Select the **Orders** table and click the [Load] button.

13. Rename **Sheet3** as **Orders**.

14. Save the file and leave it open.

### Results/ Comments:

If not, re-open it.

The **Import Data** dialog opens.

The **Navigator** dialog opens.

The table is displayed in the preview area.

The preview is removed and checkboxes are added to each table in the list.

The preview is re-displayed.

Since the **Countries** and **Orders** tables have a relation with **CompanyNames** table they are added to the selection.

The table are now deselected.

Any tables related to the **Orders** table are now also selected.

All selections are cleared and the checkboxes are removed.

The data is loaded onto a new worksheet as a formatted table.

Double-click the sheet tab to rename.

**[Ctrl +S]**.
Transforming Data

Raw data is not often configured in the best and most useful manner; requiring users to spend time removing unnecessary data and splitting data into smaller more manageable pieces. This quickly becomes very time consuming when updated data is required every week or two. With the Transform tools available in Power Query you can take care of most of those changes before bringing the data into Excel. Once the connection has been established along with a process to transform the raw data into useful data developed, the query can be saved and rerun as new data is comes in.

Opening Power Query

This begins with importing data into Excel, but instead of simply loading the data set, choosing the [Transform] button in the Navigator dialog.

- On the Data Tab, use the appropriate Get Data option.
- In the Import Data dialog, navigate to and open the source data.
- In the Navigator dialog, choose the required data sources.
- Click the [Transform] button to open the raw data in Power Query.
- Power Query opens.
Transforming Data, continued

Removing Rows and Columns

Row Removal

♦ On the Home Tab you will find the Reduce Rows Group.

♦ Click the [Remove Rows] button, a menu of option is displayed. There is no need to select the rows before using this tool.

♦ Choose Remove Top Rows from the menu.

♦ The Remove Top Rows dialog opens.

♦ Enter the number of rows to be remove from the top of the data set and click the [OK] button.

Column Removal

♦ When removing columns, select the columns to be removed or kept.
  ♦ use the Shift key for continuous selection
  ♦ use the Ctrl key for noncontinuous selection
Transforming Data, continued

◊ Once the columns have been selected, go to the **Home Tab** and locate the **Manage Columns Group**.

◊ Click the [**Remove Columns**] button drop-down.

◊ Choose the appropriate option to either remove or keep the selected columns.

**Making Top Row the Headers**

After any unwanted rows have been removed from the top, the top row may contain the actual column headers.

◊ On the **Home Tab**, locate the **Transform Group**.

◊ Click the [**Use First Row as Headers**] button.

◊ Notice the column headers of A, B, C.. have been replaced with your data.

**Removing Duplicates and Blank Rows**

One important task is checking for and removing duplicate records from the data set. Using the [**Remove Rows**] button drop-down, you will find the ability to remove duplicates.

◊ On the **Home Tab**, click the [**Remove Rows**] button drop-down and choose **Remove Duplicates**.

◊ Click the [**Remove Rows**] button again and choose **Remove Blank Rows** from the menu.
### Instructions:

1. **DataImports.xlsx** should still be open.

2. Activate the **Data Tab**.

3. Click the **[From Text/CSV]** button located in the **Get & Transform Group**

4. In the **Import Data** dialog, navigate to the data files folder and choose the **EmployeeList.txt** file.

5. Click the **[Transform]** button.

6. Examine the **Power Query Editor** interface.

7. Click the arrow at the top of the **Queries** pane to expand the pane. Use the arrow again to collapse the pane.

8. On the **Home Tab**, locate and click the **[Remove Rows]** button. Choose **Remove Top Rows** from the menu.

9. Enter **4** in the **Number of rows** field and click the **[OK]** button.

10. On the **Home Tab**, locate and click the **[Remove Rows]** button. Choose **Remove Blank Rows** from the menu.

11. On the **Home Tab**, locate and click the **[Remove Rows]** button. Choose **Remove Duplicate Rows** from the menu.

### Results/ Comments:

- If not, re-open it.

- The **Import Data** dialog opens.

- The **Navigator** dialog opens.

- The data is opened in the **Power Query Editor** window.

- Locate the **QAT**, click through the tabs in the ribbon, note the left **Queries** pane is collapsed, and the **Query Settings** pane is expanded on the right.

- The **Queries** pane is on the left of the data view. When expanded, it shows and gives access to all queries in the current workbook.

- The **Remove Top Rows** dialog opens.

- The top four rows are removed from the data.

- Any blank rows are removed from the data.

- Any duplicate rows are removed from the data.
Instructions:

12. On the **Home Tab**, locate and click the **[Use First Row as Headers]** button in the **Transform Group**.

13. Select the **Name** header cell, right-click on it and choose **Rename** from the menu.

14. Rename the column as **F_Name**.

15. Rename the **Name_1** header as **L_Name**.

16. Scroll to right to locate and select the **Age**, **Vision**, **Dental**, and **Health** columns.

17. On the **Home Tab**, locate and click the **[Remove Columns]** button in the **Manage Columns Group**.

18. Leave the file as is.

Results/ Comments:

The default names of Column A, Column B, etc... are replaced with the values in the first row of the data.

A **[Rename]** button can also be found on the **Transform Tab** in the **Any Column Group**.

Use either the button or right-click method to rename the header.

Select the first column then hold the Ctrl key as you select the others.

The columns are removed from the data. If you wanted to keep only these columns, use the **[Remove Columns]** button drop-down and choose **Remove Other Columns**.

Do not exit the **Power Query Editor**.
Splitting Data

One aspect of the Rules of Normalization is that data should be broken down into the smallest logical components. As an example consider an address; to be normalized it should have a column(field) for street, city, state, and zip to truly be used effectively.

Data may not be normalized when you first receive it, so it may be necessary to re-organize the data in a more useful manner. This can also be done within the Power Query environment.

Splitting Data

◊ Select the column which needs broken into smaller component parts.

◊ Oh the Home Tab locate the [Split Column] button in the Transform Group.

◊ Clicking the button opens the menu of option for splitting the column.

◊ Choosing any of the top three options opens a dialog, where you are able to set the specific parameters to split the data.

◊ The others will do as their names suggest.
Choosing the *By Delimiter* option opens the *Split Column by Delimiter* dialog.

- In this dialog, you are able to choose from a list of common delimiters from the *Select or enter delimiter* field.
- Choosing *Custom* from the list adds a field where you type the character to use as a delimiter. Consider using an @ to split the user name from the domain name in a list of email addresses.
- Below the delimiter selector area are radio buttons offering choices on how the delimiter will be applied.
- The *Advanced Options* arrow will expand the dialog.

- Once all the parameters have been set, click the [OK] button to apply the split.
Action 2.5 - Split Column

Instructions:

1. Select the Address column.

2. On the Home Tab, locate and click the [Split Column] button in the Transform Group.

3. Choose the By Digit to Non-Digit option from the drop-down list.

4. Select the Address.1 heading and rename it Address_Number.

5. Select the Address.2 heading and rename it Street_Name.

6. Select the Date column.

7. On the Home Tab, locate and click the [Split Column] button in the Transform Group.

8. Choose the By Delimiter option from the drop-down list.

9. From the Select or enter delimiter field drop-down choose Custom (if necessary), in the new Delimiter field type in a /, in the Split at section, choose Each occurrence of the delimiter radio button (if necessary), and click the [OK] button.

10. Select the Date.1 heading and rename it DOB_Month.

Results/ Comments:

The Power Query Editor should still be open. If not, repeat the previous exercise.

A drop-down menu is displayed allowing you to choose how the column will be split.

The leading number of the addresses are separated from the text and there are now two columns to represent the address data.

Use either of the renaming methods from the previous exercise.

The list of options are displayed.

The Split Column by Delimiter dialog opens.

Often when choosing By Delimiter, the data is analyzed and the correct delimiter is put in place.

The data is now broken into three separate columns.

Try double-clicking the header in order to rename it.
Action 2.5 - Split Column, continued

**Instructions:**

11. Select the **Date.2** heading and rename it **DOB_Day**.

12. Select the **Date.3** heading and rename it **DOB_Year**.

13. Leave the file as is.

**Results/ Comments:**

Do not exit the *Power Query Editor.*
Adding a Column

At times, the raw data may be segmented to be used effectively. It may be necessary to create new columns by combining existing columns or even creating calculated columns.

Create a Combined Column

This example will be a joining of the first and last names columns to create a full name column.

◊ Activate the **Add Column Tab**.
◊ Click on the **[Custom Column]** button in the **General Group**.
◊ The **Custom Column** dialog opens.
◊ Name the column by typing into the **New column name** field.
◊ In the **Custom column formula** field, set your cursor after the equal sign.
◊ In the **Available columns** list select the **first Name** column and click the **[Insert]** button.
◊ Then type in: **&" "&**. This will add the blank space after the first name and allow you to add the next column. The **&** acts as an add function.

**Note**

Quotation marks are used to string together any values that are not part of an existing field. This is similar to concatenating but uses a symbol instead of a function.
Adding a Column, continued

◊ Then select the last name column from the list of Available columns and click the [Insert] button.

◊ Click the [OK] button to add the column.

◊ The new column will be added to the far right of the column, click the header and drag it into position.

Create a Calculated Column

◊ Activate the Add Column Tab.

◊ Click on the [Custom Column] button in the General Group.

◊ The Custom Column dialog opens.

◊ Name the new column in the New column name field.

◊ Set the cursor into the Custom column formula field.

◊ Select the first column of data to be used in the formula from the Available fields list, and click the [Insert] button. (Double-clicking the choice in the Available fields list will also insert it.)

◊ Add a mathematical operator. (+, -, *, /)

◊ Select the second column of data to be used in the formula and click the [Insert] button, or add a specific value.

◊ Click the [OK] button when done.

If there are any errors in the syntax of your formula, you will be notified and the [OK] button will also not be active.
### Action 2.6 - Adding Columns

**Instructions:**

1. The Power Query Editor should still be open.

2. Activate the *Add Column Tab*.

3. Locate and click the `[Custom Column]` button in the *General Group*.

4. In the *New column name* field enter the name: **Full Name**.

5. Set the cursor into the *Custom column formula* field beside the equal sign, choose the *F_Name* column in the *Available columns* field and click the `[Insert]` button, type in `&" "&`, choose the *L_Name* column in the *Available columns* field and click the `[Insert]` button, then click the `[OK]` button.

6. Click the Column header and drag it into position after the *L_Name* column.

7. Click the `[Custom Column]` button again.

8. In the *New column name* field enter the name: **YearlySalary**.

9. Set the cursor into the *Custom column formula* field, beside the equal sign, choose the *WEEKLY PAY* column in the *Available columns* field and click the `[Insert]` button, type in `*52`, then click the `[OK]` button.

10. Click the Column header and drag it into position after the *Weekly Pay* column.

**Results/ Comments:**

The *Power Query Editor* should still be open. If not, repeat the previous exercise.

- This should be the second button on the tab. The *Custom Column* dialog opens.
- This will be the column name.
- This will add the values in the *F_Name* column, to a blank space, and the values in the *L_Name* column together to combine these fields.
- Double-clicking the column name in the *Available columns* list will also insert the column into the formula.
- New columns are added to the far right of the columns.
- The column is now in the correct position.
- The *Custom Column* dialog opens.
- This will be the column name.
- This will multiply the values in the *WEEKLY PAY* column by 52. If there is an error in your formula, you will see a warning and the [OK] button is inactive.
- The column is now the correction position.
Data Types

As data is brought into the Power Query Editor it is analyzed and data type is applied to each column. Data will fall into one of three data types: text, dates, or numbers. Within each of these data types are formatting variations: date, date and time, whole number, currency, percentages. When the format is applied within Power Query, the data is simply being defined not visually formatted. Formatting will be done in Excel after the data is imported.

Applying Data Types

◊ Select the column of data to be typed.
◊ On the Home Tab, locate the [Data Type] button drop-down,

◊ Choose the appropriate data type.

◊ Each column header cell displays an icon to represent the data type.

Applied Steps

As changes are made to the raw data, each step in the process is recorded and displayed in the Applied Steps pane. When a data modification does not return an expected or desired result, that step can easily be removed from within the Applied Steps pane.

Using the applied Steps Pane.

◊ Select the step in the Applied steps pane.
◊ Click the [X] button to delete the step.
◊ Step can be deleted from any point within the list.
**Action 2.7 - Applying Data Types and Using the Applied Steps Pane**

**Instructions:**

1. Select the *YearlySalary* column
2. On the *Home Tab*, locate the [Data Type] button in the Transform Group.
3. Click the button drop-down and choose *Currency* from the menu.
4. Select the *SSN* column.
5. Click the [Data Type] button drop-down and choose *Whole Number* from the menu.
6. Look at the Query Settings pane and locate the list of applied steps in the transformation.
7. Select the *Added Custom 1* step.
8. Select the last step and click the X to the left of the step.
9. Re-select the *YearlySalary* column and apply the correct data type.
10. Leave the file as is.

**Results/ Comments:**

Notice the header of the column has a text/number icon to the left of the name.

Currently the data type is set to *Any*.

The icon to the left of the column header is now a dollar sign.

This column is currently set as text.

The column now displays an error for the entire column. This is because the SSN uses dashes as separators, which numbers can’t have.

Any step listed after are not in play in the data. This allows you to easily find the last step which was correct.

That step is removed from the list and undone from the data. Unfortunately it also removed the data type change from the *YearlySalary* column.

Apply the *Currency* data type.

Do not exit the *Power Query Editor*.
Once the data has been transformed and it is ready to be brought into Excel, you can choose how the data will be placed into the workbook.

**Close & Load**
- On the *Home Tab*.
- Click the [Close & Load] button.

◊ The data is placed on a new worksheet as a table.

**Close & Load To...**
- On the *Home Tab*.
- Click the [Close & Load] button drop-down.

◊ From the menu, choose Close & Load To...
◊ The Import Data dialog opens.

◊ Choose what form the imported data will take and where the data is to be loaded.

◊ Click the [OK] button to complete the importation.
Action 2.8 - Loading the Transformed Data

**Instructions:**

1. On the **Home Tab**, locate the [Close & Load] button.

2. Clicking the drop-down of this button will allow you to choose **Close & Load** or **Close & Load To**....

3. Choose **Close & Load** if using the drop-down or simply click the top half of the button.

4. Save the file and leave it open.

**Results/ Comments:**

This is the first button on the **Home Tab**.

These function the exact same way the Load and Load To... work in the Navigator dialog.

The data is loaded as a Table to a new worksheet.

[Ctrl + S].

---

Excel 2019: Data Analysis, Rel. 1.0, 5/6/2020
Lesson 2: Power Query, Page 87
Lesson 2: Power Query

Editing a Query

When the data has been imported into Excel, you will work with it as any other data. As the workbook now has data connected to an outside source the Queries & Connections pane is displayed to the right of the interface. Should this pane be in the way, it can be closed. To bring the Queries & Connections pane back into view, click the [Queries & Connections] button in the Queries & Connections Group on the Data Tab.

The Queries & Connections pane lists any and all external sources the current workbook is using. Hovering over an existing connection will bring up a preview of the sources data along with connections details and options.

Clicking the [Edit] at the bottom of the preview pane will take the data back into the Power Query Editor. All applied steps are still listed in the Applied Steps pane and you are able to continued transforming the data as needed. When finished editing, click the [Close & Load] button as before.

To refresh data can be done on either the Data or Query Tabs.

◊ On the Query Tab the [Refresh] button is in the Load Group.

◊ On the Data Tab the [Refresh] button is in the Queries & Connections Group.
Saving and Running A Query

Once the query has been created, you may want or need to save it to use again in other files.

The **Query Tools Query Tab** is a contextual tab, if you are working inside the imported data, the tab is available, if not in the data set the tab is not displayed on the ribbon.

**Export Connection File**

◊ Select any cell within the imported data set.
◊ Activate the **Query Tab**.
◊ Click the [Export Connection File] button.

◊ The **File Save** dialog opens.
◊ Name the file.
◊ Do not change the location where this is being saved.

**Running a Query**

◊ On the **Data Tab**, click the [Existing Connections] button in the **Get & Transform Data Group**.
◊ The **Existing Connections** dialog opens, allowing you to search for the saved queries.
◊ If your query is not in the list, click the [Browse for More...] button.
### Instructions:

1. The **DataImports.xlsx** file should still be open.

2. The **Queries & Connections** pane should be open, if not go to the **Data Tab** and click the **[Queries & Connections]** button.

3. Hover over the **EmployeeList** connection.

4. Click away from the **Queries and Connections** pane.

5. Activate the **Queries Tab**.

6. Click the **[Refresh]** button in the **Load Group**.

7. On the **Query Tab**, locate and click the **[Export Connection File]** button.

8. Give it a meaningful name and click the **[Save]** button.

9. Save and close the file.

### Results/ Comments:

If not, re-open it.

When data has been imported into a workbook, this pane should be active. This pane shows all imported data connections.

A preview panel opens, showing some details about the connection, and connection tools.

The preview disappears.

The data is refreshed. If you hover over the **EmployeeList** connection again the **Last Refreshed** detail will show when you ran the refresh command. The **Data Tab** also has a **[Refresh]** button available.

This is the last button on the tab. Clicking it opens a **File Save** dialog.

Do not change the location of where it is being saved. This makes finding it later easier.

**[Ctrl + S]** and **[Ctrl + W]**.
Action 2.11 - Running Queries

Instructions:

1. Create a new blank workbook.

2. On the Data Tab, click the [Existing Connections] button in the Get & Transform Group.

3. Select the query you just saved and click the [Open] button.

4. Leave the settings as they are in the Import Data dialog and click the [OK] button.

5. Close the file without saving.

Results/ Comments:

[Ctrl + N].

The Existing Connections dialog opens.

The Import Data dialog opens.

The data is imported as a table to a new worksheet.

[Ctrl + W].

Excel 2019: Data Analysis, Rel. 1.0, 5/6/2020
Lesson 2: Power Query, Page 91
Lesson Overview

You will cover the following concepts in this chapter:

◊ Database Functions
◊ Basic Syntax of D-Functions
◊ Creating a D-Function Formula
◊ Expanding D-Functions
◊ Adding Drop-Down Menu’s
When there are large amounts of data within your datasets the D-Functions can make searching for specific information faster. While simple functions are used in many instances there will be times where calculations need to be made based on a set of criteria. The D-Functions allow you to query the dataset based on a defined set of specified criteria to control what is being calculated by modifying the formula’s criteria. Using database functions is similar to advanced filtering; you must establish a criteria range before the function itself.

There are many D-Functions in Excel designed to help you extract subsets of data from within large datasets. The D-Functions include:

- **DAVERAGE**: Calculates the average of values in a field of a list or database, that satisfy specified conditions
- **DCOUNT**: Returns the number of cells containing numbers in a field of a list or database that satisfy specified conditions
- **DCOUNTA**: Returns the number of non-blank cells in a field of a list or database, that satisfy specified conditions
- **DGET**: Returns a single value from a field of a list or database, that satisfy specified conditions
- **DMAX**: Returns the maximum value from a field of a list or database, that satisfy specified conditions
- **DMIN**: Returns the minimum value from a field of a list or database, that satisfy specified conditions
- **DPRODUCT**: Calculates the product of values in a field of a list or database, that satisfy specified conditions
- **DSTDEV**: Calculates the standard deviation (based on a sample of a population) of values in a field of a list or database, that satisfy specified conditions
- **DSTDEVP**: Calculates the standard deviation (based on an entire population) of values in a field of a list or database, that satisfy specified conditions
- **DSUM**: Calculates the sum of values in a field of a list or database, that satisfy specified conditions.
Database Functions, continued

- **DVAR**: Calculates the variance (based on a sample of a population) of values in a field of a list or database, that satisfy specified conditions

- **DVARP**: Calculates the variance (based on an entire population) of values in a field of a list or database, that satisfy specified conditions
Basic Syntax of D-Functions

While each type of D-Function will return different values, they all share the same arguments. So the component which changes will be the function name itself as the argument structure remains consistent.

Here is the base syntax of the D-Function formula.

=DFunction(Database,Field,Criteria)

The Arguments breakdown as follows:

- **Database**: The range of cells containing the data being searched.
- **Field**: This is the column being calculated on in the function.
  - If the column header has text then be sure that the text you enter here is wrapped within quotation marks.
  - Numeric values do not require quotations.
  - If using number to represent columns then enter a 1 for the first column, 2 for the second column, and so on.
- **Criteria**: A cell range containing the conditions that must be met in order to be included in the final calculation.
  - Any range of cells can be the criteria argument, it must include at least one column label and a cell below the column label that defines the condition to be considered in the calculation.

Some common and useful database functions are:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DAVERAGE</td>
<td>Used to average values in a field based on specified criteria</td>
</tr>
<tr>
<td>DSUM</td>
<td>Sums the values in a field that meet the entered criteria</td>
</tr>
<tr>
<td>DCOUNT</td>
<td>Counts the cells that contain numbers that meet the specified criteria</td>
</tr>
<tr>
<td>DMAX and DMIN</td>
<td>Return the largest and smallest values respectively from records that meet the specified conditions.</td>
</tr>
<tr>
<td>DPRODUCT</td>
<td>Multiplies values in a field according to specific conditions</td>
</tr>
<tr>
<td>DGET</td>
<td>Returns a single record value from a record that meets the specified conditions.</td>
</tr>
</tbody>
</table>
Creating a D-Function Formula

Standard database functions include those built-in functions that are in the Database category found in the function library of the Insert Function dialog.

Using the Insert Function Dialog

◊ Set up a criteria range outside of the database range of cells.

◊ Use field headings from the database that you want the information to be filtered and calculated by.

◊ The heading must match the headings in the database exactly. Consider copying and pasting these headings.

◊ In the row under the field headings, type the criteria you want your calculation to be based on.

◊ Choose a cell to place the function in.

◊ Click the [Insert Function] button on the Formula Bar or the [Insert Function] on the Formulas Tab.

◊ In the Insert Function dialog, choose Database from the Or select a category: drop-down list.

◊ Select the database function you wish to use from the Select a function: field, then click the [OK] button.
Creating a D-Function Formula, continued

- The Function Arguments dialog is displayed.

- In the Database field; type your cell range, database name, or click into the text field and select the Database data set on the spreadsheet.

- In the Field field; type the name of the column heading field that will be searched to extract your desired data, or click on the field name in the spreadsheet.

- In the Criteria field; select the entire criteria range you made earlier.

- Click the [OK] button to finish the formula.

Entering the Function Manually

Select the cell where the result is to be placed and entered the function directly into the cell or formula bar using the Autocomplete list. Adding a "D" to several standard functions will convert the function to a database function, which allows you to specify criteria to control and limit the results returned.

- Define the Criteria range of cells, as before.
- Select the result cell.
- Begin typing the function;
  - =DSum(
  - Define the Database range of cells or enter the Name if the range has been named.
  - Comma.
  - Enter the field heading, exactly as written in the database range. (If the Field name is text, it must be within quotation marks.)
  - Comma.
  - Enter the criteria range of cells that was defined at the beginning of this process.
  - Close the Parenthesis then tap the Enter key.
**Action 4.1 - Using a D-Sum function**

### Instructions:

1. Open the `Class_List.xlsx` workbook.

2. Save the file as `My_Class_List`.


4. Copy the selected cells.

5. Select cell P1 and paste the cells.

6. Select cell P5 and type in; 
   `< # of Students >`.

7. Select cell P6 and type in; 
   `< # of Classes >`.

8. Select cell P7 and type in; 
   `<Average # of Students>`.

9. Select cell P8 and type in; 
   `<Total Earnings>`.

10. Select cell R2, type in; 
    `<2010>`.

11. Select cell S2, type in; 
    `<Level 2>`.

12. Select cell Z2, type in; 
    `< >5 >`.

13. Select cell Q5.

### Results/ Comments:

- The file is in the lesson folder.

- Save the file in the lessons folder.

- The selection covers all the column headers in the data set.

- Right click and choose Copy or use the shortcut of `[Ctrl]+[C]`.

- Right click and choose Paste or use the shortcut of `[Ctrl]+[V]`. You are beginning to establish the criteria range for the D-Function.

- These cells represent the desired information to be extracted from the raw data set.

- You will be looking for any 2010 entries in the Version column of data.

- You will be looking for any Level 2 entries in the Class column of data.

- You will be looking for any number of students greater than five within the Number of Student column of data.

- This is where the DSUM formula will be entered.
**Action 4.1 - Using a D-Sum function, continued**

**Instructions:**

14. Click the [Insert function] button on the Formula bar.

15. In the Insert Formula dialog, select the following:
   - **Category:** Database
   - **Function:** DSum
   and click [OK].

16. In the Function Arguments dialog, input the following:
   - **Database:** A1:N267
   - **Field:** Z1
   - **Set Criteria:** P1:AC2
   and click [OK] to apply the formula.

17. Cell Q5 now lets you know how many students took a 2010 Level 2 class, but only if there more than five student in the class.

18. Select cell Z2 and delete the current contents.

19. Notice that the value in cell Q5 changes.

20. Save the file.

**Results/ Comments:**

The Insert Function dialog opens.

You have chosen the type of function to insert and the Function Arguments dialog opens.

The Database field refers to the data set being queried.
The Field field refers to which column of data will be summed.
The Criteria field refers to the search parameters.

This removes the specific parameter of more the five students in the class from the search criteria.

The value in the cell now show the full total of students who took 2010 Level 2 classes.

[Ctrl+S].
### Action 4.2 - Using a D-Count function

**Instructions:**

1. The *My_Class_List.xlsx* file should still be open.

2. Select cell Q6.

3. Enter the following formula
   
   \[
   =DCOUNT(A1:N267,T1,P1:AC2)
   \]

4. Select cell T2, type in;
   
   \[
   >6-30-2016
   \]

5. Notice the changes in cells Q5 and Q6.

6. Select cell T2, type in;
   
   \[
   <6-30-2016
   \]

7. Clear the contents in cell T2.

8. Save the file.

**Results/ Comments:**

- If not, re-open the file from the lessons folder.

- In this cell you want to know how many times the 2010 Level 2 class has been run.

- The formula has counted every instance of a 2010 Level 2 class within the dataset.

- By adding a new criteria to the search parameters, the search results are narrowed to only classes run after June 30th, 2016.

- The results in both cells are updated to reflect the additional search parameter added to the criteria range.

- The formulas now return only 2010 Level 2 classes run before June 30th, 2016.

- The search no longer is limited by any date constraints.

- [Ctrl+S].

---

**Excel 2019: Data Analysis, Rel. 1.0, 5/6/2020**

**Lesson 3: Database Functions, Page 102**
### Action 4.3 - Using a D-Average function

<table>
<thead>
<tr>
<th>Instructions:</th>
<th>Results/ Comments:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. The <strong>My_Class_List.xlsx</strong> file should still be open.</td>
<td>If not, re-open the file from the lessons folder.</td>
</tr>
<tr>
<td>2. Select cell Q7.</td>
<td>In this cell you want to know the average number of students who attended 2010</td>
</tr>
<tr>
<td></td>
<td>level 2 classes.</td>
</tr>
<tr>
<td>3. Enter the following formula&lt;br&gt;(&lt; =\text{DAVERAGE}(A1:N267,Z1,P1:AC2) &gt;.)&gt;</td>
<td>The formula returns the average number of students that attended 2010 Level 2 classes. Although, it is showing the results with decimals.</td>
</tr>
<tr>
<td>4. Double click into cell Q7.</td>
<td>By double clicking a cell, you editing the cell contents and in this case able to modify the formula.</td>
</tr>
<tr>
<td>5. Edit the formula to this: (&lt; =\text{ROUND}(\text{DAVERAGE}(A1:N267,Z1,P1:AC2),0) &gt;.)&gt;</td>
<td>By wrapping the D-Average formula inside a ROUND function and specifying the number of decimals as 0, forces the results of the original formula to be rounded to a whole value. You could have also decreased the number of decimals by click the [Decrease Decimals] button in the <strong>Number Group</strong> on the <strong>Home Tab</strong>.</td>
</tr>
<tr>
<td>6. Add another DSUM formula in cell Q8 to calculate the earnings from the 2010 Level 2 classes.</td>
<td>The formula should be (=\text{DSUM}(A1:N267,AC1,P1:AC2)).</td>
</tr>
<tr>
<td>7. Right click cell Q8 and click the [$$] button in the Mini Toolbar.</td>
<td>The cell now has the Accounting formatting applied.</td>
</tr>
<tr>
<td>8. Save the file.</td>
<td>[Ctrl+S].</td>
</tr>
</tbody>
</table>
Expanding D-Functions

So far, you have successfully been using the D-functions to find information in the dataset by searching for a single item within each column of the dataset. When you need to find data based on more than one data point within a column, it becomes necessary to add more rows within the criteria range in the formula. Each additional row allows you to expand the search parameters used in the formula.

When adding search criteria along a single row in the formula, you have been looking for all the criteria to be met in order to get a result. As you add new search criteria in the same column of the criteria range, the formula searches for all matching data points within the column.

Below are some examples of how the criteria can be arranged to search for specific information.

<table>
<thead>
<tr>
<th>Version</th>
<th>Class</th>
</tr>
</thead>
<tbody>
<tr>
<td>2016</td>
<td>level 2</td>
</tr>
</tbody>
</table>

Looking only for version 2016 Level 2 classes

<table>
<thead>
<tr>
<th>Version</th>
<th>Class</th>
<th>Version</th>
<th>Class</th>
</tr>
</thead>
<tbody>
<tr>
<td>2016</td>
<td></td>
<td>2016</td>
<td></td>
</tr>
<tr>
<td>2013</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Looking only for versions 2013 and 2016, any classes

<table>
<thead>
<tr>
<th>Version</th>
<th>Class</th>
</tr>
</thead>
<tbody>
<tr>
<td>2016</td>
<td>level 2</td>
</tr>
</tbody>
</table>

Looking for all version 2016 and all Level 2 classes

<table>
<thead>
<tr>
<th>Version</th>
<th>Class</th>
<th>Version</th>
<th>Class</th>
</tr>
</thead>
<tbody>
<tr>
<td>2016</td>
<td></td>
<td>2016</td>
<td></td>
</tr>
<tr>
<td>2013</td>
<td>level 2</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Looking for all version 2016 and only version 2013 Level 2 classes
### Action 4.5 - Expanding the Criteria Range

**Instructions:**

1. The My_Class_List.xlsx file should still be open.

2. Change the criteria ranges from P1:AC2 to P1:AC3 in cells Q5:Q8.

3. Select cell R3, type in; `< 2013 >`.

4. Notice that all the values in cells Q5:Q8 have been updated.

5. Select cell R3 and press the [Delete] key.

6. Select cell T2, type in; `< >6-30-2016 >`.

7. Select cell T3, type in; `< <10-1-2016 >`.

8. Notice the values in cells Q5:Q8 are updated.

9. Save the file.

**Results/ Comments:**

If not, then re-open the file.

You are adding another row each the criteria range to allow for multiple parameters to be searched for within the formulas.

You are now searching for all records of 2010 Level 2 and any 2013 version classes.

The values now reflect the expanded search criteria.

The cell contents are removed.

You are again search for classes run after June 30th 2016.

You are now also limiting the search to classes run before October 1st 2016. In this manner you are able to search for classes run within a specific time period.

[Ctrl+S].

---

Excel 2019: Data Analysis, Rel. [Decrease Decimals] , 5/6/2020
Lesson 3: Database Functions, Page 105
Adding Drop-Down Menu's

To continue the simplification of data retrieval from large datasets using the D-FunctionS, you will now use the Data Validation tool to add drop-down menus within the criteria range.

The first set in this process will be to extract unique values from columns within the dataset using the Advanced Filter tool used earlier. Once you have extracted the unique values from each column you can move on to the next step in the process.

Data Validation Lists

To create the drop-down menu use a Data Validation List. Select the cell where to drop-down list needs to be placed. To access the Data Validation tool; go to the Data Tab and click the [Data Validation] button in the Data Tools Group.

The Data Validation dialog opens

◊ In the Allow field, choose List from the available options.
Adding Drop-Down Menu's, continued

◊ Click into the Source field,
◊ You can type your list in manually here. If you are typing the list in yourself, use a comma to separate each list entry.

-OR-
◊ Refer to a cell range that contains the list entries by highlighting the desired cells.

◊ You could add Input and Error Messages by clicking the appropriate tab in the dialog.

◊ Click the [OK] button.

The active cell now has a drop-down arrow when selected. Click the arrow allows users to choose any item from the list you created.
### Instructions:

1. The My ClassList.xlsx file should still be open.
2. Select cells C1 and D1.
3. Copy the cells and paste them into cells P10 and Q10.
4. Select cell I1
5. Copy the cells and paste them into cell R10.
6. Select cell L1
7. Copy the cells and paste them into cell S10.
8. On the Data Tab, in the Sort & Filter Group, click the [Advanced] button.
9. Click the Copy to another location radio button.
11. Click into the Criteria range: field and type in: <P10>.
12. Click into the Copy to: field and type in; <P10:P11>.
13. Check the Unique records only checkbox.

### Results/ Comments:

If not, then re-open the file.

These are two of the columns that you will extract unique values from.

This is where the filtered data will be placed.

This is another of the columns that you will extract unique values from.

This is where the filtered data will be placed.

This is another of the columns that you will extract unique values from.

This is where the filtered data will be placed.

The Advanced Filter dialog opens.

The returned values will now be copied to another location in the spreadsheet.

This is the dataset that contains the source data.

This is the field within the data set to be searched.

This is where the data will be placed, if you don't include the column header the filter will return all columns from the dataset.

As implied by the name, only unique values will be returned by the filter.
**Action 4.6 - Extracting Lists from the Dataset, continued**

**Instructions:**

14. Click the [OK] button.

15. Click the [Yes] button.

16. Repeat steps 8 through 15 for each of the remaining columns of required data.

**Results/ Comments:**

The dialog closes and the warning dialog appears. This dialog asks if you want to extend the copy location range to include all the found records.

The data is placed.

Make the necessary adjustments to the filtering for each column of data.
**Action 4.7 - Using Data Validation to Create Drop-downs**

**Instructions:**

1. The My_Class_List.xlsx file should still be open.

2. Select cell R2.

3. Click the **Data Tab**, then click the [Data Validation] Button in the **Data Tools Group**.

4. On the **Setting Tab** in the Data Validation dialog, choose **List** from the **Allow**: field drop-down.

5. Click into the **Source**: field.


7. Click the [OK] button.

8. Use the Autofill handle to pull down to cell R3.

9. Repeat steps 2 through 8 to add drop-down list for cells S2:S3, X2:X3, and AA2:AA3 respectively.

10. Clear any values currently within the Criteria range.

11. Try using the new drop-downs to modify the data being returned by the D-Function formulas.

12. Save and close the file.

**Results/ Comments:**

- If not, then re-open it.

- This is the first cell where you will place the drop-down menu for users to choose items.

- The Data Validation dialog opens.

- This is the type of input setting the Data Validation tool inserts.

- This is where you can define the list manually or enter a cell range containing the values to be used as the list.

- These cells contain the list entries.

- The Data Validation dialog closes and a drop-down arrow is displayed in cell R2.

- Cell R3 now is also setup.

- Each section of the criteria range used in the D-Function formulas now has drop-down to make user input flawless. Make sure you refer to the correct source rang of cell in each Data Validation.

- The D_FUNCTION formulas should all read 0.

- Depending on the choices made using the drop-downs, the formula values change.

- [Ctrl+S] and [Ctrl+W].
Lesson 4: Data Modeling

Lesson Overview

You will cover the following concepts in this chapter:

- Data Modeling
- Understanding Relationships
- Preparing the Tables
- Creating Relationships
- Managing the Data Model
- Creating PivotTables
- Working with a PivotTable
- Adding a Calculated Column
Excel has added data modeling as a new feature, so you no longer have to add the plug-in as in the previous version. This tool allows you to connect tables of data, creating a relational data structure within Excel. These related tables are used in Pivot Tables, Pivot Charts, and Power View reports, greatly extending their functionality. The data used can be in the Excel file or can be imported by using the Get External Data tools.

If the **Power Pivot Tab** is not displayed in the ribbon, you may need to enable Power Pivot from the **Excel Options** dialog.

### Adding the Power Pivot Tab

- Click the **File Tab**.
- Click the **Options** option.
- The **Excel Options** dialog opens.
- Click the **Customize Ribbon** category on the left side of the dialog.
- Check the **Power Pivot** checkbox.

- Click the **[OK]** button.
Lesson 4: Data Modeling

Data Modeling, continued

◊ The **Power Pivot Tab** should now be displayed on the ribbon.

![Power Pivot Tab in Excel](image)

Data modeling tools are also found in the Data Tools Group on the Data Tab.

Although you can easily build huge data models in Excel, there are some considerations to keep in mind when working with Data Models.

◊ Large models containing many tables and columns are overkill for most analyses.

◊ Excel has a file size limit of 10MB, and having lots of large tables of data will reach the limit quickly.

◊ As the file size grows, it will negatively affecting other applications and reports sharing the same system resources due to high demands of system memory.

◊ Avoid calculated columns, since they will need regular updating to keep current data in the Data Model. (Draws more system resources)

◊ Ensure that the data has a Primary key column of data to create relationship between the data tables.

◊ It is recommended to use a 64 bit version of the program with a minimum of 8GB of RAM, 16GB preferred.
Data Modeling, continued

Other Limitations

The table below lists other constraints within a Data Model.

<table>
<thead>
<tr>
<th>Object</th>
<th>Maximum Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Characters in a table or column name</td>
<td>100 characters</td>
</tr>
<tr>
<td>Number of tables in a model</td>
<td>2,147,483,647</td>
</tr>
<tr>
<td>Number of columns and calculated columns in a table</td>
<td>2,147,483,647</td>
</tr>
<tr>
<td>Concurrent requests per workbook</td>
<td>6</td>
</tr>
<tr>
<td>Number of connections</td>
<td>5</td>
</tr>
<tr>
<td>Number of distinct values in a column</td>
<td>1,999,999,997</td>
</tr>
<tr>
<td>Number of rows in a table</td>
<td>1,999,999,997</td>
</tr>
</tbody>
</table>
To create a **Data Model**, it is necessary to understand how *Excel* interprets data and values that contribute to the **Data Model** itself. We will begin by examining the **Relational Database** concepts to gain a better understanding of **Data Models’** foundational structure.

**Relational Databases**

A relational database’s structure inherently recognizes relationships among the data. These relationships let you quickly search and retrieve specific information, view the same dataset in multiple ways and reduce data errors and redundancy.

To avoid repeating all the master information in every detailed table, you create relationships using one unique field, then let *Excel* do the rest.

There are two basic types of relationships that will be established between **Tables**:

- One to one relationship - for every record in the master table, there is one matching record in the detail table.
- One to many relationship - for every record in the master table, there can be many records in the detail table that link back to the master table.

For example, you may have an Employee Table with ID numbers. In the Employee Table, the Employee ID Number is unique for each individual employee. This is considered a **Primary Key**. No two employees can have the same Employee ID Number.

In a related table, you may have accounts to which each employee is assigned. Because the field Employee ID Number appears in both tables, these tables can be related. However, in the second table with the accounts, each employee may be assigned multiple accounts. Therefore, this is a one to many relationship from the Employee Table to the Accounts Table. These tables are related because the Employee ID Number field appera in both tables, which makes this a **Relational Database**. The Employee ID Number in the Accounts Table is called a **Foreign Key** because it is not a unique identifier and, therefore, cannot be used as a **Primary Key**.
Structuring the Data
First, you need to determine if the information can and should be related. When you have data in two or more Tables, it may be more efficient to combine the information from the Tables to draw a conclusion or extract more accurate data. If this is the case, don’t waste time trying to physically combine the data on one spreadsheet, use Excel’s Data Modelling tools to extract the information as needed.

Convert the Data to a Table
- Select any cell in the dataset.
- On the Home Tab, in the Style Group click the Format as Table button.
- Choose any of the available formatting options.
- In the Format as Table dialog, check to ensure all the connected data are included in the Where is your table: field
- Click the [OK] button.
- Repeat these steps for each dataset to be used in the Data Model.

Rename the Table
Once you have created the tables, you should rename the tables to make the process much simpler. While this is not necessary, it is extremely helpful.
- On the Table Tools Design Tab, click into the Table Name: field in the Properties Group.
- Type a new name for your Table.
- Tap the [Enter] key to apply the name.
- If the [Enter] key is not used and you click away from the field the name is not applied.

Note: By default tables are named numerically as they are created.

Note: Table name can not include blank spaces or special characters.
### Instructions:

1. Open the **DataModel.xlsx** file.
2. Save the file as **ExcelClassAnalysis.xlsx**.
3. Activate the **Classes** worksheet.
4. Click into any cell containing a value.
5. On the **Home Tab**, in the **Styles Group**, click the **[Format as Table]** button.
6. Choose the first table option from the menu.
7. Check the **Where is the data for your Table:** field to see that it reads; **=$A$1:$G$980**
8. Check the **My table has headers** checkbox.
9. Click the **[OK]** button.
10. Click the **Table Tools Design Tab**.
11. In the **Properties Group**, click into the **Table Name:** field and type in: **< Classes >** then tap the **[Enter]** key to apply the name to the table.
12. Format the data on each of the other sheets as tables and name each table with the same name as the worksheet.
13. Save the file and leave it open.

### Results/ Comments:

It is located in the lessons folder.

[**F12**].

The table styles are displayed.

The **Format As Table** dialog opens.

All the connected data should be listed as the data to be converted into a table.

This will set the row 1 as the header row of the table.

The formatting is applied to the data range and the **Table Tools Design Tab** is added to the ribbon.

The table tools are displayed.

You must tap the **[Enter]** key after entering a name in order for it to be applied. If you forget, the name will not be applied.

Repeat steps 4 through 11 on each worksheet. When naming tables you can not have blank spaces, so add underscores or camel case the names.

[**Ctrl+S**].
Creating Relationships

Find the Related Data

Look at the data in the Tables you have created and determine which Fields can be used to connect one table to another. These matching fields are what are used to create the relationships.

As mentioned earlier, if the two tables both have a column with the same type of data, that column can be used to connect the tables. An Emp_ID column in the employee data table uniquely identifies each employee and that data can connect to the Emp_ID column in the sales data tables.

Creating Relationships

- Choose any table.
- On the Data Tab, click the [Relationships] button in the Data Tools Group.
- The Manage Relationships dialog opens.

- Since there are no existing relationships, the dialog is empty.
- Click the [New] button to open the Create Relationship dialog.
Creating Relationships, continued

◊ In the Create Relationship dialog,
  ◊ The Table: field drop-down, allows you to choose from any existing tables. This would be the many side of a one-to-many relationship. This table has many items that relate back to a single item in the other table.
  ◊ The Column (Foreign): field drop-down, allows you to choose which column or field of data in the selected table will be used to connect to another table. This column may contain duplicate values.
  ◊ The Related Table: field drop-down, allows you to choose what table will be connected to the selected table in the Table: field. This is the one side in a one-to-many relationship.
  ◊ The Related Column (Primary): field drop-down, allows you to select which column will connect to the Column (Foreign) field. This column should contain unique values only.

◊ Click the [OK] button to establish the relationship.

◊ The relationship is now displayed in the Manage Relationships dialog.

◊ Continue creating all the necessary relationships.

◊ Click the [Close] button once all relationships have been made.
Action 5.2 - Creating Relationships

Instructions:

1. Click the [Relationships] button in the Data Tools Group on the Data Tab.

2. Click the [New] button.

3. In the Table: field choose Companies from the drop-down, then from the Column (Foreign): field drop-down choose Sales_Reps.

4. In the Related Table: field choose Sales_Reps from the drop-down, then from the Related Column (Primary): field drop-down choose Emp-ID.

5. Click the [OK] button.

6. Click the [New] button.

7. In the Table: field choose Clients from the drop-down, then from the Column (Foreign): field drop-down choose Company_ID.

8. In the Related Table: field choose Companies from the drop-down, then from the Related Column (Primary): field drop-down choose Company_ID.

9. Click the [OK] button.

10. Click the [New] button.

11. In the Table: field choose Classes from the drop-down, then from the Column (Foreign): field drop-down choose Client_ID.

Results/ Comments:

The Manage Relationships dialog opens.

The Create Relationship dialog opens.

In this case you are setting Sales_Reps column in the Companies table as the data that will connect to another table. This is the many side of the one-to-many relationship.

You are now setting Emp-ID as the column as the unique primary key in the Sales_Reps table, this will be the one side of the one-to-many relationship between the Sales_Reps and Companies tables.

The relationship is added in the Manage Relationships dialog.

The Create Relationship dialog opens.

The many side in the relationship to the companies table, many clients work for the same company.

The one side in the relationship.

The relationship is added in the Manage Relationships dialog.

The Create Relationship dialog opens.
Action 5.2 - Creating Relationships, continued

Instructions:

12. In the Related Table: field choose Clients from the drop-down, then from the Related Column (Primary): field drop-down choose Client_ID.

13. Click the [OK] button.

14. Click the [New] button.

15. In the Table: field choose Classes from the drop-down, then from the Column (Foreign): field drop-down choose Course_ID.

16. In the Related Table: field choose Courses from the drop-down, then from the Related Column (Primary): field drop-down choose Course_ID.

17. Click the [OK] button.

18. Once all the relationships have been created, click the [Close] button.

19. Save the file and leave it open.

Results/ Comments:

The relationship is added in the Manage Relationships dialog.

The Create Relationship dialog opens.

The relationship is added in the Manage Relationships dialog.

The Manage Relationships dialog is closed.

[Ctrl+S].
Managing the Data Model

Once relationships are established you may need or want to manage the data model. When managing a data model, Excel will open the Power Pivot for Excel-(File name) window from within this environment you are able to see, edit, and create new relations.

To Open Excel’s Power Pivot window

◇ On the Data Tab, click the [Manage Data Model] button in the Data Tools Group.

◇ On the Power Pivot Tab, click the [Manage] button in the Data Model Group.

◇ The Power Pivot for Excel opens.

Note
This window will only show existing relations not just raw data tables.

Note
Tables do not have to be on separate worksheets to build data models.
Managing the Data Model, continued

Power Pivot Views

The initial view is of the tabular data, where any related tables are displayed in a similar fashion as worksheets in a workbook. You can change to a diagram view, which displays the tables as small boxes with the fields and lines to show the connections from one table to another.

The Data View

Using the tools available on the Home Tab you are able to apply formatting, sort and filter the data, add new columns to a table, add in formulas, and get external data from outside of Excel.

The Design and Advanced Tabs offer other tools for functions, calculations, freezing, examining and creating relations, properties, as well as more features.

Note: Table names can be changed by right clicking the table tab and choosing Rename or by double clicking the tab name. Remember to tap the [Enter] key when done to apply the change.
Managing the Data Model, continued

The Diagram View

While the ribbon tabs are available and offer the same functionality is in the Data View, they would be much more difficult to see the changes being made in the Diagram View.

◊ In the View Group, click the [Diagram View] button.

◊ A diagram of the data relations replaces the Data View.

◊ In this view you are able to see all the data tables in the file as well as the connections between the tables.

◊ To move the tables, click and drag the Title Bar of the table.

◊ As you move the tables around the connection lines are maintained, so you are able to see the connections

◊ To resize the table, use the double headed arrow cursor that appears as you hover over the table border.
Adding a New Connection
You are able to create the connections from within the Diagram View.

◊ Select the first table of the connection.
◊ Click the field that can be used to relate to another table.
◊ Drag the field over the related field of the other table field.

◊ As you drag the connection, a line appears that shows which two field are being used for the connection.
◊ When the connection is made the connection line is displayed between the tables.
Action 5.3 - Managing the Data Model

Instructions:

1. Click the [Manage data Model] button in the Data Tools Group on the Data Tab.

2. Click the [Diagram View] button in the View Group on the Home Tab.

3. Arrange the tables in so you can see them all and the connection lines.

4. Resize each table to see all the fields.

5. Notice all the tables are shown with their relations.


Results/ Comments:

The Power Pivot for Excel-ExcelClassAnalysis.xlsx window opens. This window has a ribbon with tabs like the regular Excel window.

The diagram view of the existing named tables and the connections added is displayed.

Click and drag the Title Bar of the table to reposition it. You may also need to zoom out to see all the tables. If so, use the Zoom Slider in the lower right corner of the window.

Hover over the bottom of the table, when the double-headed arrow cursor appears, click and drag to resize the table.

Click the close button in the upper right corner of the window and [Ctrl+S].
Creating PivotTables

Once the Data Model is complete, it is time to put it to use. The best way to visualize the data is by using a PivotTable or PivotChart. This is done from within Excel or the Power Pivot for Excel window.

Creating PivotTables

In the Power Pivot for Excel window

◊ Click the [PivotTable] button on the Home Tab.
  ◊ Clicking the drop-down arrow of the button offers more choices.
  ◊ Creating multiple PivotTables and Charts from this view allows each PivotTable and Chart to work independently from the other.
  ◊ The Create PivotTable dialog opens.

◊ In this dialog, you are able to set where the new PivotTable will be placed within the workbook.
  ◊ Choose where the new PivotTable will be placed and click the [OK] button.
  ◊ A blank PivotTable is added to a New Worksheet or on the existing worksheet you chose.

Note: It is easier to visualize the Pivot Table data in its own worksheet than in an existing worksheet.
Creating PivotTables, continued

In Excel

If the Power Pivot for Excel window was closed and you are back in an Excel window, it is still possible to create a PivotTable from the established Data Model.

◊ Select any table of data included within the Data Model.
◊ Click the [PivotTable] button in the Tables Group on the Insert Tab.
◊ The Create PivotTables dialog opens.

◊ In the dialog, you are able to determine source of the PivotTable data, where the PivotTable will be added, and whether or not to add this to the Data Model.
◊ If the Add this data to the Data Model checkbox is checked: all the related tables in the Data Model are displayed in the PivotTable Fields pane.
◊ If the Add this data to the Data Model checkbox is not checked: only the selected table fields are displayed in the PivotTable Fields pane. Although, you are still able to access the other tables from within the PivotTable Fields pane.
◊ Click the [OK] button when finished defining the PivotTable attributes.
◊ A blank PivotTable is added to a New Worksheet or on the existing worksheet you chose.
Once the PivotTable is created, it will be empty of content until fields are added. The blank table is located on the worksheet and the PivotTable Field pane is displayed on the right side of the Excel window.

If all the Tables are not displayed in the PivotTable Field pane, click the [All] button at the top of the pane.

Should the **Add this data to the Data Model** checkbox not have been checked, a [More Tables] button is shown below the list of fields in the current table. Clicking that button will open a dialog asking if you want to create a new PivotTable. You must click the [Yes] button to continue.
Adding Data to a PivotTable

Once all the tables are listed in the PivotTable Fields pane, you can expand any given table by clicking the [Expand/Collapse] buttons to the left of the table name.

◊ Expand the table fields.
◊ Select the field to include in the PivotTable and drag it into the appropriate PivotTable area at the bottom of the PivotTable Fields pane.

◊ **Filters** area: allows you to filter, based on one or more fields that would isolate the focus of the PivotTable.

◊ **Columns** area: set the fields to use as column headings.

◊ **Rows** area: set the fields to use as the rows of data in the PivotTable. Typically this area has at least one field, although it’s possible to have no fields.

◊ **Values** area: is used to calculate and/or count data that you want to measure.
The power of a PivotTable is that you can rearrange the fields to see your data from different perspectives. With the Filter, Columns, and Rows areas field, it is easy to filter the data to look at specific subsets that would otherwise be difficult to see within the raw data sets.

After dragging a field to an area, it's data is added to the PivotTable.
**Action 5.4 - Creating the PivotTable**

**Instructions:**

1. The ExcelClassAnalysis.xlsx file should still be open.

2. On the **Data Tab**, in the **Data Tools Group**, click the [Data Model] button.

3. In the **Power Pivot for Excel** window, on the **Home Tab**, click the [PivotTable] button.

4. In the **Create PivotTable** dialog, choose **New Worksheet** option and click the [OK] button.

5. Examine the **PivotTable Field** pane.

6. Click the [Expand] arrow button to the left of the **Sales_Reps** table.

7. Drag the **Last Name** field down into the **Filters** field at the bottom of the **PivotTable Field** pane.

8. Click the [Collapse] arrow button for the **Sales_Reps** table.

9. Click the [Expand] arrow button to the left of the **Classes** table.

10. Drag the **Date** field down into the **Rows** field.

11. Right click any date in the worksheet and choose **Group** from the menu.

**Results/ Comments:**

- If not, reopen it.

- The **Power Pivot for Excel** window opens.

- The **Create PivotTable** dialog opens.

- **New Worksheet** is the default choice, so simply ensure that is the active option.

- All the tables in the data model should be listed in the upper field of the **PivotTable Filed** pane.

- The list of fields (these are the columns in that table) in this table are displayed.

- The **Last Name** field is added to the **Filters** field. You will be able to filter the data based on individual sales reps.

- The table's fields are collapsed. Since this is the only field needed in the PivotTable from the **Sales_Reps** table, there is no need to leave the table field list expanded.

- The list of fields in this table are displayed.

- The dates are added in the **Rows** field and displayed in the PivotTable. Every date is listed.

- The **Grouping** dialog opens. You can choose how to group the dates by a single or multiple choice.
Instructions:

12. Select Months from the list and click the [OK] button.

13. Right click any Month on the worksheet and from the Expand/Collapse options choose Expand Entire Field.

14. In the Rows field of the PivotTable field, drag the Dates field out.

15. Drag the Name field down below the Date(Month) field in the Rows field.

16. Drag the Version field down below the Name field in the Rows field.

17. Drag the Client_ID field down into the Values field.

18. Collapse the Classes table field list.

19. Save the file.

20. Expand the Courses table.

21. Drag the Price field to the Values field.

22. Drag the Price field out of the Values field.

23. Save the file.

Results/ Comments:

The dates are now grouped by months that can be expanded as needed to see a more detailed view of the data. A new Date(Month) field is added to the field list and the Rows field.

All the dates within the months are shown.

The individual dates are removed from the PivotTable while the Months are still displayed.

Now all the Names of the classes taught that month are displayed. If not then repeat step 13 to display the data.

The Version of the class is added to the PivotTable.

A count of the clients who took that given class is added in the second column of the PivotTable.

In the PivotTable field pane click the [Collapse] button beside the Classes table.

[Ctrl+S].

The list of fields in the Course table is displayed.

The Price field is added as a new column in the PivotTable. The data is not coming in correctly, you will need to add a new calculated column in the Data Model.

The data is removed from the PivotTable.

[Ctrl+S].
Adding a Calculated Column

In a regular PivotTable, you are able to add calculated field or items. When working in a Power Pivot PivotTable this feature is not available. In the exercise you just completed, the price column of data did not have a robust enough connection to allow you to see a total for each class taught based on the number of students. While the tables do have a connection, the information does not come across as needed. In cases such as these, it may be necessary to add a calculated column into the Data Model itself to combine the data from two tables.

Since the connection exists between the tables in the model, Excel is able to use functions to generate desired data from the separate table.

Inserting a Function column

In this example: the price for each class in the Courses Table needs to be added to the Classes Table. The Related function will enter the price based on the connection of the Course_ID fields.

- Open the Power Pivot for Excel window by click the [Data Model] button on the Data Tab.
- In the Data View, select the table that requires the new column of data.
- Activate the Design Tab.
- Click into the empty cell below the Add Column header in the table.
- Click the [Insert Function] button in the Calculations Group.

Columns added in the data model do not show in the normal view of the table on worksheets.
Adding a Calculated Column, continued

The Insert Function dialog opens.

Use the **Select a category:** field drop-down to narrow the list of functions listed in the **Select a function:** field.

Select **All** from the **Select a category:** field.

Select **Related** in the **Select a function:** field.

Click the [OK] button.

The **Insert Function** dialog closes and the function is added in the formula Bar.

Select the table that contains the data to find.

In this case, select the **Courses** table.

Click the Column header containing the required data.

In this case, **Price** is the necessary column.

Excel will compare the data in the related column (**Course_ID**) to determine the correct price to attribute to the records in the **Classes** table.

Tap the [Enter] key to apply the function.

Close the **Power Pivot for Excel** window.

The new column can be used within the PivotTable.
**Action 5.5 - Adding a Calculated Column to a Table**

<table>
<thead>
<tr>
<th>Instructions:</th>
<th>Results/ Comments:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. The ExcelClassAnalysis.xlsx file should still be open.</td>
<td>If not, reopen it.</td>
</tr>
<tr>
<td>2. On the <strong>Data Tab</strong>, in the <strong>Data Tools Group</strong>, click the [Data Model] button.</td>
<td>The <em>Power Pivot for Excel</em> window opens to the Data View.</td>
</tr>
<tr>
<td>3. Select the <strong>Classes Table</strong> tab.</td>
<td>The table tabs are listed at the lower left of the window.</td>
</tr>
<tr>
<td>4. Click into the blank cell below the <strong>Add Column</strong> header.</td>
<td>This will add a new column as you enter data or in this case a calculated column.</td>
</tr>
<tr>
<td>5. Activate the <strong>Design Tab</strong>.</td>
<td>Click the <strong>Design Tab</strong> in the ribbon.</td>
</tr>
<tr>
<td>6. Click the [Insert Function] button in the <strong>Calculations Group</strong>.</td>
<td>The <em>Insert Function</em> dialog opens.</td>
</tr>
<tr>
<td>7. Leave the <strong>Select a category</strong>: field set to <strong>All</strong>.</td>
<td>All available functions are listed in the <strong>Select a Function</strong>: field.</td>
</tr>
<tr>
<td>8. From the <strong>Select a Function</strong>: field list choose <strong>Related</strong> and click [OK].</td>
<td>The <em>Insert Function</em> dialog closes and the function is added in the Formula Bar.</td>
</tr>
<tr>
<td>9. Select the <strong>Course Tab</strong>, then select the <strong>Price</strong> column header and tap the [Enter] key.</td>
<td>Since these tables have a connection based on the <strong>Course_ID</strong>, the <strong>Classes</strong> table will now compare the <strong>Course_ID</strong> columns and return the price of each class. The data can now be used to see how much revenue was earned from each class in the PivotTable.</td>
</tr>
<tr>
<td>10. Double click the column header and type in;</td>
<td>To apply a name to the column.</td>
</tr>
<tr>
<td><code>&lt; Cost_Per &gt;</code></td>
<td>Click the [Close] button in the upper right corner of the window. The <em>Power Pivot for Excel</em> window closes and you are back in the PivotTable worksheet.</td>
</tr>
<tr>
<td>and tap the [Enter] key.</td>
<td></td>
</tr>
<tr>
<td>11. Close the <strong>Power Pivot for Excel</strong> window.</td>
<td></td>
</tr>
</tbody>
</table>
### Instructions:

12. Expand the **Classes** table in the *PivotTable Field* pane list.

13. Drag the new **Cost_Per** field into the **Values** field.

14. Save and close the file.

### Results/ Comments:

Click the **[Expand]** button beside the **Classes** table. All the fields in the table are displayed, including the newly added column.

The price data is calculated and displayed in the PivotTable.

**[Ctrl+S]** and **[Ctrl+W]**.
Appendix A: Excel 2013 Adding the Power Pivot Add-in

Lesson Overview

You will cover the following concepts in this chapter:

◊ Adding the Add-In
Adding the Add-In

Adding the Power Pivot Add-ins

If you are running Excel 2013 and the Power Pivot Tab is not displayed in the ribbon, you will need to add it to the program. This can be done from either the Excel Options Window or from the Developer Tab.

From the Options Window

◇ Click the File Tab and then the Options link.

◇ When in the Options window, choose the Add-Ins category from the list on the left side of the screen.

◇ At the bottom of the screen, click the Manage: field drop-down and choose COM Add-ins from the list.

◇ Click the [Go] button to open the COM Add-ins dialog.
Adding the Add-In, continued

◊ Check the Microsoft Power Pivot for Excel checkbox and click the [OK] button.

◊ The Power Pivot Tab is added to the ribbon.

From the Developer Tab

The Developer Tab has to have been activated in the program in order to use this method.

◊ Activate the Developer Tab.

◊ In the Add-ins Group, click the [COM Add-ins] button.

◊ The COM Add-ins dialog opens.

◊ Check the Microsoft Power Pivot for Excel checkbox and click the [OK] button.

◊ The Power Pivot Tab is added to the ribbon.
### Instructions:

1. Click the *File Tab*.

2. From the list of categories on the left of the backstage, choose *Options*.

3. In the *Options Window*, choose the *Add-ins* category.

4. Click the drop-down arrow of the *Manage* field and choose *COM Add-ins*.

5. Click the *[GO]* button.

6. Check the *Microsoft Power Pivot for Excel* checkbox and click the *[OK]* button.

### Results/ Comments:

The backstage is displayed. *[Alt-F-T]*

The *Options Window* opens.

The *Excel Add-ins* controls are displayed in the *Options Window*.

This field allows you to choose which set of Add-ins to search through.

The *COM Add-ins* dialog opens, showing a list of checkbox options.

The *Power Pivot Tab* is now available on the ribbon.
### Instructions:

1. Activate the Developer Tab

2. In the Add-ins Group, click the [COM Add-ins] button.

3. Check the *Microsoft Power Pivot for Excel* checkbox and click the [OK] button.

### Results/ Comments:

If the tab is not displayed on the ribbon, you will need to turn it on from within the Options Window/ Customize Ribbon.

The COM Add-ins dialog opens.

The *Power Pivot Tab* is now available on the ribbon.
## Import data into workbooks

<table>
<thead>
<tr>
<th>Task</th>
<th>Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import data from .txt file</td>
<td>DA</td>
</tr>
<tr>
<td>Import data from .csv files</td>
<td>DA</td>
</tr>
</tbody>
</table>

## Navigate within workbooks

<table>
<thead>
<tr>
<th>Task</th>
<th>Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search for data within a workbook</td>
<td>L-1</td>
</tr>
<tr>
<td>Navigate to named cells, ranges, or workbook elements</td>
<td>L-2</td>
</tr>
<tr>
<td>Insert and remove hyperlinks</td>
<td>L-3</td>
</tr>
</tbody>
</table>

## Format worksheets and workbooks

<table>
<thead>
<tr>
<th>Task</th>
<th>Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modify page setup</td>
<td>L-1</td>
</tr>
<tr>
<td>Adjust row height and column width</td>
<td>L-1</td>
</tr>
<tr>
<td>Customize headers and footers</td>
<td>L-1</td>
</tr>
</tbody>
</table>

## Customize options and views

<table>
<thead>
<tr>
<th>Task</th>
<th>Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customize the Quick Access toolbar</td>
<td>L-1</td>
</tr>
<tr>
<td>Display and modify workbook content in different views</td>
<td>L-2</td>
</tr>
<tr>
<td>Freeze worksheet rows and columns</td>
<td>L-2</td>
</tr>
<tr>
<td>Change window views</td>
<td>L-2</td>
</tr>
<tr>
<td>Modify basic workbook properties</td>
<td>L-2</td>
</tr>
<tr>
<td>Display formulas</td>
<td>L-1</td>
</tr>
</tbody>
</table>

## Configure content for collaboration

<table>
<thead>
<tr>
<th>Task</th>
<th>Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set a print area</td>
<td>L-1</td>
</tr>
<tr>
<td>Save workbooks in alternative file formats</td>
<td>L-1</td>
</tr>
<tr>
<td>Configure print settings</td>
<td>L-1</td>
</tr>
<tr>
<td>Inspect workbooks for issues</td>
<td>L-1</td>
</tr>
</tbody>
</table>
### Manipulate data in worksheets

<table>
<thead>
<tr>
<th>Action</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste data by using special paste options</td>
<td>L-1</td>
</tr>
<tr>
<td>Fill cells by using Auto Fill</td>
<td>L-1</td>
</tr>
<tr>
<td>Insert and delete multiple columns or rows</td>
<td>L-1</td>
</tr>
<tr>
<td>Insert and delete cells</td>
<td>L-1</td>
</tr>
</tbody>
</table>

### Format cells and ranges

<table>
<thead>
<tr>
<th>Action</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Merge and unmerge cells</td>
<td>L-1</td>
</tr>
<tr>
<td>Modify cell alignment, orientation, and indentation</td>
<td>L-1</td>
</tr>
<tr>
<td>Format cells by using Format Painter</td>
<td>L-1</td>
</tr>
<tr>
<td>Wrap text within cells</td>
<td>L-1</td>
</tr>
<tr>
<td>Apply number formats</td>
<td>L-1</td>
</tr>
<tr>
<td>Apply cell formats from the Format Cells dialog box</td>
<td>L-1</td>
</tr>
<tr>
<td>Apply cell styles</td>
<td>L-1</td>
</tr>
<tr>
<td>Clear cell formatting</td>
<td>L-1</td>
</tr>
</tbody>
</table>

### Define and reference named ranges

<table>
<thead>
<tr>
<th>Action</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define a named range</td>
<td>L-2/FM</td>
</tr>
<tr>
<td>Name a table</td>
<td>DA</td>
</tr>
</tbody>
</table>

### Summarize data visually

<table>
<thead>
<tr>
<th>Action</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Sparklines</td>
<td>L-2</td>
</tr>
<tr>
<td>Apply built-in conditional formatting</td>
<td>L-2</td>
</tr>
<tr>
<td>Remove conditional formatting</td>
<td>L-2</td>
</tr>
</tbody>
</table>

### Create and format tables

<table>
<thead>
<tr>
<th>Action</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create Excel tables from cell ranges</td>
<td>L-2</td>
</tr>
<tr>
<td>Apply table styles</td>
<td>L-2</td>
</tr>
<tr>
<td>Convert tables to cell ranges</td>
<td>L-2</td>
</tr>
</tbody>
</table>

### Modify tables

<table>
<thead>
<tr>
<th>Action</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add or remove table rows and columns</td>
<td>L-2</td>
</tr>
<tr>
<td>Configure table style options</td>
<td>L-2</td>
</tr>
<tr>
<td>Insert and configure total rows</td>
<td>L-2</td>
</tr>
</tbody>
</table>
## Filter and sort table data

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter records</td>
<td>L-2</td>
</tr>
<tr>
<td>Sort data by multiple columns</td>
<td>L-2</td>
</tr>
</tbody>
</table>

## Insert references

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert relative, absolute, and mixed references</td>
<td>L-1</td>
</tr>
<tr>
<td>Reference named ranges and named tables in formulas</td>
<td>L-2</td>
</tr>
</tbody>
</table>

## Calculate and transform datas

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Perform calculations by using the AVERAGE(), MAX(), MIN(), and SUM() functions</td>
<td>L-1</td>
</tr>
<tr>
<td>Count cells by using the COUNT(), COUNTA(), and COUNTBLANK() functions</td>
<td>DA</td>
</tr>
<tr>
<td>Perform conditional operations by using the IF() function</td>
<td>FM</td>
</tr>
</tbody>
</table>

## Format and modify text

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format text by using RIGHT(), LEFT(), and MID() functions</td>
<td>DA</td>
</tr>
<tr>
<td>Format text by using UPPER(), LOWER(), and LEN() functions</td>
<td>DA</td>
</tr>
<tr>
<td>Format text by using the CONCAT() and TEXTJOIN() functions</td>
<td>DA</td>
</tr>
</tbody>
</table>

## Create charts

<table>
<thead>
<tr>
<th>Task</th>
<th>Level / Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create charts</td>
<td>L-2 / CH</td>
</tr>
<tr>
<td>Create chart sheets</td>
<td>L-2 / CH</td>
</tr>
</tbody>
</table>

## Modify charts

<table>
<thead>
<tr>
<th>Task</th>
<th>Level / Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add data series to charts</td>
<td>L-2 / CH</td>
</tr>
<tr>
<td>Switch between rows and columns in source data</td>
<td>L-2 / CH</td>
</tr>
<tr>
<td>Add and modify chart elements</td>
<td>L-2 / CH</td>
</tr>
</tbody>
</table>
## MICROSOFT OFFICE EXCEL EXPERT EXAM MO-201

### Manage workbooks

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy macros between workbooks</td>
<td>L-3</td>
</tr>
<tr>
<td>Reference data in other workbooks</td>
<td>L-3</td>
</tr>
<tr>
<td>Enable macros in a workbook</td>
<td>L-3</td>
</tr>
<tr>
<td>Manage workbook versions</td>
<td>L-2</td>
</tr>
</tbody>
</table>

### Prepare workbooks for collaboration

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restrict editing</td>
<td>L-2</td>
</tr>
<tr>
<td>Protect worksheets and cell ranges</td>
<td>L-2</td>
</tr>
<tr>
<td>Protect workbook structure</td>
<td>L-2</td>
</tr>
<tr>
<td>Configure formula calculation options</td>
<td>FM</td>
</tr>
<tr>
<td>Manage comments</td>
<td>L-2</td>
</tr>
</tbody>
</table>

### Use and configure language options

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure editing and display languages</td>
<td>L-1</td>
</tr>
<tr>
<td>Use language-specific features</td>
<td>L-1</td>
</tr>
</tbody>
</table>

### Fill cells based on existing data

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fill cells by using Flash Fill</td>
<td>L-1</td>
</tr>
<tr>
<td>Fill cells by using advanced Fill Series options</td>
<td>L-2</td>
</tr>
</tbody>
</table>

### Format and validate data

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create custom number formats</td>
<td>L-1</td>
</tr>
<tr>
<td>Configure data validation</td>
<td>L-3 / FM</td>
</tr>
<tr>
<td>Group and ungroup data</td>
<td>L-3</td>
</tr>
<tr>
<td>Calculate data by inserting subtotals and totals</td>
<td>L-3</td>
</tr>
<tr>
<td>Remove duplicate records</td>
<td>DA</td>
</tr>
</tbody>
</table>
### Apply advanced conditional formatting and filtering

<table>
<thead>
<tr>
<th>Operation</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create custom conditional formatting rules</td>
<td>L-2</td>
</tr>
<tr>
<td>Create conditional formatting rules that use formulas</td>
<td>L-2</td>
</tr>
<tr>
<td>Manage conditional formatting rules</td>
<td>L-2</td>
</tr>
</tbody>
</table>

### Perform logical operations in formulas

<table>
<thead>
<tr>
<th>Logical Operations</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Perform logical operations by using nested functions including the IF(), IFS(), SWITCH(), SUMIF(), AVERAGEIF(), COUNTIF(), SUMIFS(), AVERAGEIFS(), COUNTIFS(), MAXIFS(), MINIFS(), AND(), OR(), and NOT() functions</td>
<td>FM</td>
</tr>
</tbody>
</table>

### Look up data by using functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Look up data by using the VLOOKUP(), HLOOKUP(), MATCH(), and INDEX() functions</td>
<td>FM</td>
</tr>
</tbody>
</table>

### Use advanced date and time functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference date and time by using the NOW() and TODAY() functions</td>
<td>FM</td>
</tr>
<tr>
<td>Calculate dates by using the WEEKDAY() and WORKDAY() functions</td>
<td>FM</td>
</tr>
</tbody>
</table>

### Perform data analysis

<table>
<thead>
<tr>
<th>Analysis</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Summarize data from multiple ranges by using the Consolidate feature</td>
<td>L-3</td>
</tr>
<tr>
<td>Perform what-if analysis by using Goal Seek and Scenario Manager</td>
<td>L-3</td>
</tr>
<tr>
<td>Forecast data by using the AND(), IF(), and NPER() functions</td>
<td>FM</td>
</tr>
<tr>
<td>Calculate financial data by using the PMT() function</td>
<td>FM</td>
</tr>
</tbody>
</table>
### Troubleshoot formulas

<table>
<thead>
<tr>
<th>Activity</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trace precedence and dependence</td>
<td>FM</td>
</tr>
<tr>
<td>Monitor cells and formulas by using the Watch Window</td>
<td>FM</td>
</tr>
<tr>
<td>Validate formulas by using error checking rules</td>
<td>FM</td>
</tr>
<tr>
<td>Evaluate formulas</td>
<td>FM</td>
</tr>
</tbody>
</table>

### Create and modify simple macros

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record simple macros</td>
<td>L-3</td>
</tr>
<tr>
<td>Name simple macros</td>
<td>L-3</td>
</tr>
<tr>
<td>Edit simple macros</td>
<td>L-3</td>
</tr>
</tbody>
</table>

### Create and modify advanced charts

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create and modify dual axis charts</td>
<td>CH</td>
</tr>
<tr>
<td>Create and modify charts including Box &amp; Whisker, Combo, Funnel, Histogram, Map, Sunburst, and Waterfall charts</td>
<td>CH</td>
</tr>
</tbody>
</table>

### Create and modify PivotTables

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create PivotTables</td>
<td>PT</td>
</tr>
<tr>
<td>Modify field selections and options</td>
<td>PT</td>
</tr>
<tr>
<td>Create slicers</td>
<td>PT</td>
</tr>
<tr>
<td>Group PivotTable data</td>
<td>PT</td>
</tr>
<tr>
<td>Add calculated fields</td>
<td>PT</td>
</tr>
<tr>
<td>Format data</td>
<td>PT</td>
</tr>
</tbody>
</table>

### Create and modify PivotCharts

<table>
<thead>
<tr>
<th>Task</th>
<th>Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create PivotCharts</td>
<td>PT</td>
</tr>
<tr>
<td>Manipulate options in existing PivotCharts</td>
<td>PT</td>
</tr>
<tr>
<td>Apply styles to PivotCharts</td>
<td>PT</td>
</tr>
<tr>
<td>Drill down into PivotChart details</td>
<td>PPT</td>
</tr>
</tbody>
</table>