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Welcome to the Excel 2019 Pivot Tables course. This manual and 
the data files are designed to be used for learning, review and 
reference after the class.  The data files can be downloaded any 
time from The Computer Workshop website: 

http:\\www.tcworkshop.com
There is no login or password required to access these files.  You 
will also find handouts and supplementary materials on the 
website in the Download section.

To Download Data Files

Once on The Computer Workshop website, locate and click the 
Student Resources link in the top navigation bar.  When on the 
Student Resources page, click the Data Files button.  

1. Data Files page displays a list of general application types. 
2. Click once on the Microsoft Office Courses link.
3. Click once on the software related to the course.
4. Click once on the version related to the course.
5. If there are multiple folders, click on the TCW folder.
6. Click on the course name to download the data files.

You can choose to open or save the zipped folders content to 
your computer.  

While on the Student Resources page, you can also access 
handouts by clicking the Handouts button.  Handouts are in 
PDF format and also available to you without login or password.  
Simply open the PDF and either print or save to your computer.

Using this 
Manual
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Conventions Used in this Manual

The hands-on exercises (Actions) are written in a two-column 
format. The left column (“Instructions”) gives numbered 
instructions, such as what to type, keys to press, commands 
to choose from menus, etc.  The right column (“Results/
Comments”), contains comments describing results of, reasons 
for, quick keys, etc. for the instructions listed on the left.

 � Key names and Functions are bold and enclosed in 
square brackets:

  [Enter], [Tab], [F5], [F10]

 � Keys you press simultaneously are separated by a plus 
(+) sign, typed in bold and enclosed in square brackets. 
You do not press the plus.

  [Shift + F5]

 � Keys you press in sequence are separated by a space, 
bold and enclosed in square brackets.

  [Home] [Down Arrow]

 � Ribbon tab names are in bold and italic:  Example:  
Home 

 � Group names are in bold:  Example:  Font

 � Dialog box names are in italic:  Example: Save As

 � Button names are bold and enclosed in square brackets:  
Example:  [Sort]

 � Information you are to type will be in bold. Example:

This is the first day of the rest of your life.

 � Information that you need to supply will be indicated 
with pointed brackets.   Example: Type:  <your name>.

 

Conventions
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Lesson Overview

You will cover the following concepts in this 
chapter:

Excel 2019: PivotTable Features
Rel. 1.0, 02/21/2020

Lesson 1: Creating and 
Modifying PivotTables

 � PivotTables

 � Creating PivotTables

 � PivotTable Elements

 � Adjusting PivotTable Layouts

 � Formatting PivotTables and Fields

 � Expanding & Collapsing Fields

 � Refreshing PivotTables



Lesson Notes
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Lesson 1: Creating and Modifying PivotTables

PivotTables A PivotTable is a powerful tool for exploring and analyzing 
information. They can help organize and manipulate the raw 
data in a spreadsheet, revealing patterns or relationships which 
may not be obvious at first glance. PivotTables also give you the 
power to view your data in a different context without changing 
the original content or structure of the source data. 

A PivotTable can be based on data in your current workbook or 
drawn from an external data source. 

With a PivotTable, it is easy to drag and drop fields (columns) 
of data into different areas of the table, exposing relationships 
or trends not readily obvious in traditional Excel tables or 
databases. 

In short, PivotTables allow you to organize data in meaningful 
ways without doing a lot of tedious work. You could say that a 
PivotTable is like several data tables rolled into one.

Below is a sample of a typical PivotTable.

Guidelines for Data in a PivotTable
 � The data should be in a tabular format.

 � The source data should have a row of unique column 
headings.

 � There should be no gaps in the data, no blank columns 
or rows.  Excel treats groups of data as a database.  
Gaps indicate a break in the data and are considered 
the end of the data.  
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Creating 
PivotTables

Creating a PivotTable
 � Click into the range of data the PivotTable will be 

based on. 

 � Select the Insert Tab, in the Tables Group click the 
[PivotTable] button.

 � The Create PivotTable dialog opens.

 � Within the Choose the data that you want to analyze 
group are three choices:

 � Select a table or range:  allowing data from the 
current workbook to be used as the data source.  By 
setting the cell range in the Select range: field. 
-This field should automatically select all connected 
cells based on the active cell. 
-If the range that appears is incorrect, you may type 
it in or select it with your mouse.  Make sure that 
the column headings are included in the selection.

Ideally, source data 
for a PivotTable 
should be structured 

like a traditional Excel 
table or database. See the 
guidelines on page 3.

Note
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Lesson 1: Creating and Modifying PivotTables

Creating  
PivotTables,
continued

 � Use an external data source: allows the PivotTable 
to be based on data outside of the current 
workbook (such as in another workbook or an 
external database).  
-Clicking the [Choose Connection] button opens 
the Existing Connections dialog, which displays a list 
of existing connections.  

-Typical existing connections may included 
Microsoft Queries or previously connections to 
Access databases. 
- Clicking the [Browse for More] button allows 
new connections to be made.

 � Use this workbook's Data Model:  can be used when 
tables of data are related to each other. These tables 
can be data converted into a table or imported tables.

Once the source of data has been selected and defined, you can 
set where the PivotTable will be placed in the workbook. 

 � Select whether to locate your PivotTable in an Existing 
Worksheet or a New Worksheet. 

 � If you choose the New Worksheet option, a new 
worksheet is added to the workbook with the 
PivotTable located in cell A1.

 � If you choose Existing Worksheet, you can specify  
the cell location and on which worksheet the 
PivotTable will be added. Enter the cell address 
directly into the Location: field, as a cell reference, 
or by clicking the target cell with your mouse. 

 � Click the [OK] button to create your PivotTable. 

The data model 
feature is available  
with Excel 2016+

Note

Cell A1 will contain 
the Report Filter and 
the data will begin 

in cell A3 when choosing 
New Worksheet.

Note
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Creating  
PivotTables,
continued

Using Recommended PivotTables
 � Select any cell within the data range the PivotTable is 

to be based on.

 � Select the Insert Tab, in the Tables Group and click the 
[Recommended PivotTable] button.

 � The Recommended PivotTables dialog opens.

 � Excel offers a series of possibilities based on the data. 

 � Scroll through the list of options on the left, when 
you select one on the left, a large copy is previewed 
on the right.

 � When one fitting your needs is actively selected, click 
the [OK] button .

 � A new worksheet is added with the PivotTable in 
place.

 � If none of the recommendations are suitable, click the 
[Blank PivotTable] button to start from scratch.

 � A new worksheet is added with a blank PivotTable 
in place.

Excel automatically 
extends the selection 
to include all 

connected data.

Note
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Lesson 1: Creating and Modifying PivotTables

Creating  
PivotTables,
continued

Using the Quick Analysis Tag
When the data is selected, a smart tag is displayed in the lower 
right corner of the selection.  This smart tag offers quick access to  
Formatting, Charting, Sparkline, Totaling, and Table options.

 � Select all the data needed in the PivotTable.

 � Look to the lower right corner of the selection to find 
the Quick Analysis tag.

 � Click the tag to view the available options.

 � Click the Tables option, hover over the PivotTable ? 
options to see recommendations.

 � Clicking the one which best fits your needs will insert a 
PivotTable into a new worksheet. 

 � If none seem appropriate then choose the More ? 
option to open the Recommended PivotTable dialog. 

Select any cell of 
connected data and 
tap the [Ctrl A] key 

command to select all 
connected data.

Note
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PivotTable 
Elements

Adding Fields
After creating a blank PivotTable the PivotTable is located in the 
worksheet on the left (or where defined) and the PivotTable Fields 
pane on the right.

In the PivotTables Fields pane is the list of all available fields from 
the data (column headers). If the data source is a Data Model, 
then the list will display all related tables which are expandable 
to show all the fields in the tables.

PivotTable Fields Pane
In the top half of the pane, all the available fields from the data 
source or sources are displayed.  In the lower half of the pane 
are four areas. Fields are added to these areas by dragging from 
above and dropping into the appropriate area. 

When using a 
Recommended 
PivotTable, the fields 

are already in place 
upon creation. It is still 
possible to edit and 
rearrange the fields are 
needed.

Note
PivotTable Fields PanePivotTable

Filters: Fields 
added here are 
top-level report 
filters and are 
shown above 
the PivotTable.

Columns: Fields 
added here are 
displayed in 
columns in the 
PivotTable.

Values: 
Numeric data 
fields are added 
here; these are 
summarized in 
the PivotTable.

Rows: Fields 
added here 
are displayed 
in rows in the 
PivotTable.
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Lesson 1: Creating and Modifying PivotTables

PivotTable 
Elements,
continued

PivotTable Tools Tabs
When working in a PivotTable, Excel automatically displays the 
PivotTable Tools Tabs- Analyze and Design.

The Analyze Tab offers controls for active fields, filtering, 
grouping, refreshing or changing data, performing calculations, 
showing or hiding elements, and PivotTable options.

The Design Tab offers controls for basic layout and formatting of 
the PivotTable.

Analyze Tab

Design Tab



 2019:  PivotTable Features, Rel. 1.0, 02/21/2020
Lesson 1:  Creating and Modifying PivotTables, Page  10

Instructions: Results/ Comments:

Action 1.1 - Creating a Blank PivotTable

Notice the first row are the column 
headings, with one heading for each 
column. (The data set does not contain 
any empty cells.)

Use the File Tab then Save As or the [F12] 
key.

The Create PivotTable dialog is displayed. 
Notice when viewing the Insert Tab you 
are able to access the [Recommended 
PivotTables] button from within this 
group.

The Table/Range: field should read 
Invoices!$A$1:$K$2156.

A new sheet is added to the workbook 
with a blank PivotTable. You will see a 
PivotTable Area and a Field List appear 
in a new worksheet. Notice the column 
headings (fields) available in the PivotTable 
Field List which can now be added to the 
table.

[Ctrl S].

1. Open the workbook named Shipping.
xlsx from the lessons folder.

2. Save the file as MyShipping.xlsx. 

3. Click anywhere in the data on the 
Invoices sheet.

4. Select the Insert Tab and click the 
[PivotTable] button. 

5. Verify that the Select a table or range 
option is chosen and the correct range is 
entered in the Table/Range field.

6. Make sure that the New Worksheet 
option button is selected.

7. Click the [OK] button to create the 
PivotTable. 

8. Save the file and leave it open.
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Instructions: Results/ Comments:

Action 1.2 - Creating a Recommended PivotTable

1. MyShipping.xlsx  should still be open.

2. Switch back the Invoices sheet.

3. Select any cell with a value and use the 
[Ctrl A] keyboard shortcut to select all 
connected data.

4. Click the Quick Analysis Tag.

5. Click the Tables heading and hover over 
the Recommended PivotTables icons.

6. Choose the fourth option.

7. Save the file and leave it open.

If not, re-open it.

Click the Invoice sheet tab or use the [Ctrl 
Page-Down] keys.

All the data is highlighted and the Quick 
Analysis Tag is displayed in the lower right 
corner of the selection.

The list of Quick Analysis options are 
displayed.

The Table and PivotTable options are 
displayed. As you hover over the icons an 
example is shown of that option.

A new sheet is added to the workbook 
with a populated PivotTable.

[Ctrl S].
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Instructions: Results/ Comments:

Action 1.3 - Adding data to the PivotTable

1. MyShipping.xlsx  should still be open.

2. Switch back the Sheet1 sheet.

3. Click into any cell in the PivotTable 
placeholder on the spreadsheet.

4. Drag the Country field from the field list 
to the Filters area of the PivotTable Fields 
pane.

5. Drag the Company Name field from 
the field list to the Rows area of the 
PivotTable Fields pane.

6. Drag the Product Name field from the 
field list to the Columns area of the 
PivotTable Fields pane.  

7. Drag the Sale field from the field list to 
the Values area of the PivotTable Fields 
panes:

8. Drag the Company Name field out of the 
Rows area of the PivotTable Field pane.

9. Drag the Salesperson field from the field 
list to the Rows area of the PivotTable 
Fields pane.

10. Save the file and leave it open.

If not, re-open it.

Click the Sheet1 sheet tab or use the [Ctrl 
Page-Down] keys.

All PivotTable tools are displayed: 
PivotTable Tabs and PivotTable Filed pane.

A Country drop-down is added in cell A1.

The list of Clients are added beginning 
in cell A4.  A Row Labels  header with a 
drop-down is added in the cell A3.

The list of Products is added, one product 
name per column beginning in cell B4. The 
Column Labels header with a drop-down 
is added in cell B3. The Row Label header 
is moved down to cell A4.

The value of each product purchased by 
each client is displayed on the Pivot Table.

The list of clients are removed from the 
PivotTable, all the other data remains in 
place. You now know how much was 
earned in sales of each product.

The value of each product sold by each 
salesperson is now displayed on the Pivot 
Table. 

[Ctrl S].
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Lesson 1: Creating and Modifying PivotTables

Using the PivotTable Options Dialog
In this dialog you are able to set general options in one place.  
Users can still modify these choices one by one from the 
PivotTable tabs.

 � Click on any cell in the PivotTable to display the 
Analyze Tab in the Ribbon. 

 � On the left side of the Analyze Tab, in the PivotTable 
group, click the [Options] button to display the 
PivotTable Options dialog.

 � On the Layout and Format tab, make sure the Preserve 
cell formatting on update box is checked. This will 
ensure that any formatting you apply will be retained 
if the table is modified or refreshed.

 � On the Totals and Filters tab, specify if grand totals 
for rows or columns will be shown.

 � On the Display tab, select whether filter drop-downs, 
field captions, expand/collapse buttons, and contextual 
tool tips will be shown.

 � On the Printing tab: determine what optional elements 
should print. 

 � On the Data tab, specify PivotTable Data options, 
such as having the table refreshed when the workbook 
opens.

 � Click [OK] when you are finished with the PivotTable 
Options dialog.

Adjusting 
PivotTable 
Layouts

Remember to 
always click into the 
PivotTable to see the 

related contextual tabs 
on the Ribbon.

Note

If the PivotTable 
is large, checking 
the Set print titles 

checkbox is a good idea 
since headers will be 
repeated on each page of 
the printout.

Note
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Using the Design Tab 
 � On the left side of the PivotTable Design Tab is the 

Layout Group.

 � The [Subtotals] drop-down allows you to turn on or 
off the subtotal information.  When they are on, they 
can be shown at either the top or bottom of each group.

 � The [Grand Totals] drop-down allows you to turn on 
or off grand totals, for both rows and /or columns.

 � The [Report Layout] drop-down allows you to change 
between three layouts: Compact, Outline, or Tabular 
views.  When in Outline or Tabular views, you are able 
to repeat all item labels or not.

 � The [Blank Rows] drop-down allows you to add or 
remove blank rows after grouped items.

Adjusting 
PivotTable 
Layouts,
continued

Item Labels Not Repeating Item Labels Repeating
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Lesson 1: Creating and Modifying PivotTables

Adjusting 
PivotTable 
Layouts,
continued

Setting the Default Layout.
Excel now offers the ability of modify the default layout of 
PivotTables.  As new PivotTables are created, they will already 
have basic layout choices in place.

 � Click the File Tab to access the Backstage.

 � Select Options from the list of categories on the left of 
the Backstage.

- OR -
 � Use the sequential keyboard shortcut, Alt F T.

 � In the Options, select the Data category.

 � Click the [Edit Default Layout] button.

 � The dialog offers controls for Subtotals, Grand 
Totals, Report Layouts, and Blank Rows. (Similar to  
using the Design Tab tools)

 � Use the [Import] button to save changes made 
in a current or an existing PivotTable as the new 
default.  
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Instructions: Results/ Comments:
1. MyShipping.xlsx should still be open.

2. Activate Sheet1 and select any cell in the 
PivotTable, scroll all the way over to the 
right side and select cell BZ5.

3. Activate the Analyze Tab.

4. In the PivotTable Group, click the 
[Options] button.

5. On the Layout & Format tab, check 
the Preserve cell formatting on update 
checkbox is checked.

6. On the Totals & Filters tab, uncheck the 
Show grand totals for rows checkbox.

7. Examine the options on each of the other 
tabs. 

8. On the Alt Text tab click into the Title: 
field and type:  
Sales Data PivotTable  
click into the Description: field and enter 
a description of the table.

9. Click the [OK] button.

10. Activate the Design Tab.

11. In the Layout Group, click the [Grand 
Totals] button drop-down and choose 
On for Rows and Columns.

12. Drag the Company Name field into the 
Rows area below the Salesperson.

If not, re-open it.

The PivotTable Options dialog open.

Examine the available options. 

The Grand Totals will be removed.

Alt Text is text read aloud by screen 
reading software for the visually impaired 
community, this helps in making 
documents accessible.

The PivotTable Options dialog closes and 
the data in column CA, the Grand Totals is 
removed.

The Grand Total in column CA is added 
back to the PivotTable.

The companies each salesperson works 
with are displayed below the salesperson's 
name.

Action 1.4 - Adjusting PivotTable Layout
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Instructions: Results/ Comments:

Action 1.4 - Adjusting PivotTable Layout, continued

13. Select cell A5.

14. In the Layout Group, click the [Report 
Layout] button drop-down and try each 
of the layouts.

15. Choose Show in Tabular Form from the 
[Report Layout] button drop-down.

16. Then choose Do Not The Repeat Item Labels 
from the [Report Layout] button drop-
down.

17. Save the file and leave it open.

18. Click the File Tab and select Options from 
the list of categories.

19. Select the Data category and click the 
[Edit Layout] button.

20. Examine the options available in this 
dialog.

21. Click the [PivotTable Options...] button.

22. Examine and close the dialog.

23. Click into the Layout Import field and 
select a cell in the PivotTable then click 
the [Import] button. 

24. Click the [OK] button.

25. Click the [OK] button.

26. Save the file and leave it open.

To see the row and columns labels.

The data structure changes for each.  When 
Repeat All Item Labels is active in the 
outline or tabular views, the salesperson's 
name fills all empty cells. 

The PivotTable changes to the Tabular 
layout. 

[Ctrl S].

The Excel Options dialog opens.

The Edit Default Layout dialog opens.

The dialog offers the same controls found 
in the Layout Group on the Design Tab.

The PivotTable Options dialog opens.

It is the same dialog accessed earlier.

By entering any cell address from the 
current PivotTable, you are defining 
the layout to by imported.  Clicking the 
[Import] button sets the layout Excel uses 
when creating PivotTables in the future.

The dialog closes.

The Excel Options dialog closes.

[Ctrl S].
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Formatting 
PivotTables and 
Fields

Using the Design Tab 
 � On the Design Tab, you can select one of the preset 

styles from the PivotTable Styles Gallery, quickly 
applying a preset format to the table. 

 � There are also checkboxes in the PivotTable Style 
Options group of the ribbon that will let you turn 
on or off banded columns or rows, row headers, or 
column headers. 

 � On the left side of the ribbon, there are controls used 
to view or hide subtotals and grand totals as well as to 
specify a PivotTable Report Layout.

General Formatting Options
To format text or cells in a given cell or cell range use the 
formatting tools found on the Home Tab or right-click in the 
selected cell or range and use the Mini Toolbar or choose Format 
Cells... from the menu 

In the Format Cells dialog you can access and set number formats, 
alignment choices, font styles, borders, fills and protection 
options.

When right-
clicking a selection 
in a PivotTable, the 

Format Cells... option is 
found at the top of the 
menu.

Note
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Formatting 
PivotTables and 
Fields,
continued

Value Filed Settings
As values are added to the PivotTable, you may want to change 
how those values are summarized or formatted. This is done 
from within the Value Field Setting dialog. This dialog is accessed 
in one of three ways: from the ribbon, from within the PivotTable 
Field pane, or right-clicking.  

Opening the Value Field Settings Dialog
 � Select a cell containing a value. On the Analyze Tab 

in the Active Field Group, click the [Field Settings] 
button.

- OR -
 � Click drop-down arrow on of the field in the Values 

field in the PivotTables Fields Pane and choose Value 
Field Settings... from the menu.

- OR - 
 � Right-click any cell with a value and choose Value Field 

Settings... from the menu.

 � The Value Field Settings dialog opens.

 � Summarize Values By tab: 
allows you to change how the data is 
summarized.

 � Show Values As tab: allows the 
data to be displayed as percentages of 
totals, running totals, or differences. 
When using the percentage options, 
formatting is automatically applied.

 � Use the [Number Format] button to open the 
Format Cells dialog. Applying formatting  in this 
manner will apply it to the entire field and not just 
an individual cell.
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Showing More Than One Value Calculation
If you want to show both the sum and the average of the values 
in the PivotTable at the same time, do the following:

 � Add a second instance of the field containing your 
values to the Values area of the PivotTable.

 � Open the Value Field Settings using any of the methods 
mentioned earlier.  

 � From the Value Field Settings dialog, choose the Average 
function. 

 � Click [OK].

Now you have the values both being summed and averaged 
simultaneously.  This can be revised in the Value Field Settings 
dialog to any function or combination of functions needed.

Formatting 
PivotTables and 
Fields,
continued
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Instructions: Results/ Comments:

Action 1.5 - Formatting PivotTable Data

If not, re-open it.

The Value Field Settings dialog opens.

This will now be name for this instance of 
the data.

The Format Cells dialog opens. 

The column label in cell A3 is renamed and 
the values are formatted.

The column label in A3 is moved to C5 and 
two new columns titled Sum Of Sales# are 
added to the PivotTable.

The Value Field Settings dialog opens.

Choose the function before changing the 
name. 

This will now be name for this instance of 
the data.

The Format Cells dialog opens.

The column label in cell D5 is renamed and 
the values are formatted.

The Value Field Settings dialog opens.

1. MyPivotTable.xlsx should still be open.

2. Activate Sheet1, if necessary.

3. Right-click any cell with a value and 
choose Value Field Settings from the menu.

4. In the Custom Name: field enter 
Sales .

5. Click on the [Number Format] button, in 
the bottom left corner of the dialog.

6. Choose the Accounting format option 
from the list on the left and click the 
[OK] button in each dialog.

7. Drag another two instances of the Sale 
field into the Values area of the PivotTable 
Fields pane.

8. Right-click any cell in the second column 
of values and choose Value Field Settings 
from the menu.

9. Choose Average from the Summarize 
value field by: formula list.

10. In the Custom Name: field enter 
Average Sale .

11. Click on the [Number Format] button, in 
the bottom left corner of the dialog.

12. Choose the Accounting format option 
from the list on the left and click the 
[OK] button in each dialog.

13. Right-click any cell in the third value 
column and choose Value Field Settings 
from the menu.
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Instructions: Results/ Comments:

Action 1.5 - Formatting PivotTable data, continued

To name the field header.

The third column of value now shows how 
much each sale represents from the overall 
total.

The structure of the PivotTables is 
rearranged, revealing a much more 
detailed view and greater understanding 
of the existing data.

[Ctrl+S].

14. Activate the Show Values As tab in the 
Value Field Setting dialog.

15. Choose % of Grand Total from the drop-
down list for Show values as: field.

16. In the Custom Name: field enter 
Percent of Sales .

17. Click [OK].  

18. In the PivotTable Fields pane, drag the 
Products field from the Columns area 
below the Salesperson field in the Rows 
area.

19. Save your file.
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Expanding & 
Collapsing Fields

As more data is added into a PivotTable it may become 
necessary to collapse fields to make the big picture is easier to see 
and understand.  When a more granular view of all or a small 
subset of data is needed, it is possible to expand the entire field 
or any given collapsed set.  As fields are added into the same 
PivotTable area, data is nested in the field above. Expand and 
Collapse buttons are displayed next to each field entry;  

 
A Plus when collapsed  
 
 
A Minus when expanded.

It is also possible to access the Collapse and Expand commands 
in the Active Field Group on the Analyze Tab. These buttons 
will expand or collapse the entire field at once.

Right-clicking on the field in the PivotTable, you are able to 
access the Expand/Collapse submenu. From this menu you can 
expand or collapse a subset of data or the entire field.  Choosing 
Expand, Collapse, Expand "Field name", or Collapse "Field 
name" will expand or collapse the selected subset of data only. 

Expand entire Field button

Collapse entire Field button
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Instructions: Results/ Comments:

Action 1.6 - Expanding  & Collapsing Fields

1. MyPivotTable.xlsx should still be open.

2. Activate Sheet1, if necessary.

3. Select cell A4. 

4. Click the [Minus] button in the cell.

5. Activate the Analyze Tab.

6. Click the [Collapse Field] button in the 
Active Field Group.

7. Click the [Expand Field] button in the 
Active Field Group.

8. Right-click cell A4, scroll down to the 
Expand/Collapse.

9. Choose Collapse Entire Field from the fly-
out menu.

10. Click the [Plus] button in cell A6.

11. Right-click cell A4, scroll down to the 
Expand/Collapse.

12. Choose Expand Entire Field from the fly-
out menu.

13. Save the File.

If not, re-open it.

The details of that salesperson are 
collapsed out of view.

All the details are collapsed at once. 

All the details are expanded at once. 

A fly-out menu is displayed showing 
options for expanding/collapsing this 
record or field.

All the details are collapsed at once. 

The salesperson's record is expanded to 
show it's details.

All the details are re-displayed.

[Ctrl+S].
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The data in a PivotTable is not linked directly to the source table 
or range.  Instead, PivotTables are based on a hidden copy of 
the source data that is kept in memory by Excel. This is called the 
PivotTable Cache.  Meaning, changes to the original source or 
database will not be automatically updated in the PivotTable. 
If you make changes in the source data, you must Refresh the 
PivotTable to update it.

Refreshing a PivotTable
 � Select any cell within the PivotTable.

 � Activate the Data Tab, then click the [Refresh All] 
button in the Queries & Connections Group. 

-OR -
 � Activate the PivotTable Analyze Tab, then click the 

[Refresh] button in the Data Group. 

-OR-

 � Right-click a cell in the PivotTable, then choose Refresh 
from the menu. 

Redefining the PivotTable Data Range
As new records are added to the data set the PivotTable, simply 
refreshing the data will only pull data from the same range of 
cells to update the PivotTable.  As the data set increases in size, 
it  will become necessary to redefine the cell range being used by 
the PivotTable. 

Refreshing 
PivotTables

[Alt + F5] refreshes 
the PivotTable.

Note
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 � Activate the Analyze Tab, in the Data Group, then 
click the [Change Data Source] button.

 � The Change PivotTable Data Source dialog opens and 
you are taken back to the sheet containing the source 
data.

 � If you are adding to the data set on the sheet then 
click into the Table/Range field and edit the range 
accordingly.

 � If changing and external source of data, click the 
Use an external data source radio button. Then, 
click the [Choose Connection] button and follow 
the dialogs to connect to a new source or make 
other modifications to an existing source.

Refreshing 
PivotTables,
continued
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Instructions: Results/ Comments:

Action 1.7 - Refreshing the PivotTables

1. MyPivotTable.xlsx should still be open.

2. Activate Invoices.

3. Select cell J2 and change the value to  
< 50 >.

4. Activate the Sheet1 sheet.

5. Select cell A4 and collapse the entire field 
to display the sales people's names and 
their values.

6. Note the values for Nancy Davolio.

7. Activate the Analyze Tab, if necessary.

8. In the Data Group, click the [Refresh] 
button.

9. Save the file.

If not, re-open it.

Click the Invoices sheet tab.

To correct or modify the data. Changes 
to the original data will not automatically 
affect the PivotTable data.

Click the Sheet1 sheet tab.

Use any method from the previous 
exercise.

The current value for the Sales should be 
$202,143.71.

The updated value should be $204,068.71.

[Ctrl+S].
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Lesson Overview

You will cover the following concepts in this 
chapter:

Excel 2019: PivotTable Features
Rel. 1.0, 02/21/2020

Lesson 2: Filtering 
PivotTables

 � Filtering Data

 � Sorting a PivotTable

 � Basic PivotTable Filtering

 � Advanced Filtering

 � Report Filters

 � Filtering With Search Box

 � Adding to Filters

 � Conditional Formatting in a PivotTable

 � Grouping Data

 � Using the Slicer
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One of the main features of a PivotTable is that you have the 
ability to present the data in a dynamic format that allows you 
to show exactly what you need and change it when you need 
to.  For example, if you have a PivotTable that shows Sales 
by Region for each Salesperson, you may want to show only 
specific Salespersons or specific Regions.  PivotTables allow 
the flexibility to show each Region and/or Salesperson and to 
change which Salesperson or which Region shows at any time. 

Data in a PivotTable can be filtered based on the Rows, 
Columns, and the Filters. As fields are added to the PivotTable 
areas in the PivotTable Fields pane, their labels are shown with 
drop-down arrows. If the those Field Headers are not being 
displayed, check that the [Field Header] button is active in the 
Show Group on the Analysis Tab.

Row and column filtering drop-
downs offer a wide variety of options 
based on the data type.  Sorting tools, 
filtering based on Labels or Values, 
and the ability to search the field 
items.

The Filter filtering drop-down simply 
offers the ability to search, a checkbox 
list, and the ability to “select multiple 
items”.

Filtering Data

A Value filter 
allows you to apply 
a filter to numerical 

data.  A Label filter 
allows you to apply 
a filter to textual data 
referred to in row or 
column labels.

Note
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Basic Sorting
It is possible that the data in a field may not be sorted in the 
order you need, but this is an easily resolved issue. Clicking the 
Filter drop-down, you will be able to sort the field ascending, 
descending, manually, or based on a custom list or conditional 
format. There are also the standard methods of sorting data 
from the ribbon on both the Home and Data Tabs, as well as 
right-clicking a cell to access the sort commands found in the 
contextual menu.

Applying A Sort
 � Select the Field Filter drop-down. 

 � The sort options are found at the top of the list.

 � To sort Ascending or Descending, use the top two 
options in the menu.

 � Choosing the [More Sort Options...] button will open 
the Sort Options (Field Name) dialog.

 � Choosing either the Ascending or Descending radio 
buttons allows you to chose any other available 
fields from the drop-down.

 � Choosing the Manual radio button allows you to 
select cells within the field and move them into any 
desired order.

 � Click the [OK] button to apply the sort.

Sorting a 
PivotTable
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Sorting a 
PivotTable,
continued

Applying An Advanced Sort
 � Select the field filter drop-down. 

 � Choose the [More Sort Options...] button will open the 
Sort Options (Field Name) dialog.

 � Clicking the [More Options...] button opens the 
More Sort Options (Field Name) dialog.

 � Unchecking the Sort automatically every time the 
report is updated checkbox allows you access to the 
First key sort order field. Clicking the drop-down 
allows you to use custom lists to set the sort order.

 � Click the [OK] button to apply the sort.

The Sort By set of 
options are active 
if the field uses the 

Show Values As instead 
of the Summarize Values 
By field setting

Note
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Instructions: Results/ Comments:

Action 2.1 - Sorting 

1. MyShipping.xlsx should still be open.

2. Click the drop-down arrow in cell A3.

3. Choose Sort Z to A from the menu.

4. Right-click any cell in the first column 
of values, hover over the Sort option to 
expand, choose Sort Smallest to Largest.

5. Activate the Design Tab, in the Layout 
Group click the [Report Layout] drop-
down button and choose Tabular Layout 
from the menu.

6. Right-click on a Salesperson’s name, 
hover over the Expand/Collapse option 
and choose Expand Entire Field from the 
menu.

7. Click the Product Name filter drop-down 
in cell C3 and choose Sort Z to A.

8. Right-click the first name in the 
Salesperson column, hover over the 
Expand/Collapse option and choose 
Collapse Entire Field.

9. Save the file.

If not, reopen it.

The Sorting and Filtering menu is 
displayed.

The list of salespeople is now sort in a 
descending order.

The data is now sorted based on the values 
instead of the names.

If necessary.  The PivotTable is now 
displayed in a Tabular mode.

All the data is displayed.

The Product column is sorted.  Notice 
that the overall PivotTable is still sorted 
primarily by the Salespeople.

The data is collapsed back to show the 
salespeople and three value columns.

[Ctrl S]. 
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Basic Filtering
Once fields are added to a PivotTable, it is possible to filter that 
data set down to view only specific individuals or groups from 
within the field. Excel displays a drop-down on the field labels by 
default, but if the labels are not visible, then it will be necessary 
to show the labels by clicking the [Field Headers] button in the 
Show Group on the Analyze Tab.

Using the drop-downs on the field labels offers access to the 
filtering tools.

When a field is placed into either the row or column area, it is 
very quick and easy to see how an individual or subset group 
is doing by using the filtering drop-downs.  When there is only 
a small data set in the field it can be a simple as unchecking 
the Select All checkbox checking the desired checkboxes and 
clicking the [OK] button.  Only data pertaining to the selection is 
displayed.

Basic PivotTable 
Filtering
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Filtering a PivotTable
 � Click the drop-down arrow next to any row or column 

field name in the PivotTable.

 � The menu offering Sorting and Filtering options are 
displayed.

 � Uncheck the Select All checkbox

 � Check only the checkboxes for the desired data. 

 � Click the [OK] button.

 � The data in the PivotTable reflects the choices made in 
the Filtering options.

- OR -
 � In the PivotTable Fields pane, click on the drop-down 

arrow next to a field name.

 � Use the Filtering tools as described above.

The PivotTable reflects the filtering choices made.  A funnel icon 
will appear with the drop-down of the filtered column or row 
header as well as in the PivotTable Field pane. 

Filtering in the Report Filter
The fields in the Filter area of the PivotTable Field pane do not 
offer as many filtering options as rows and columns do,  you are 
basically able to filter individual items.  In the report filter drop-
down is a Select Multiple Items checkbox that when checked 
places a Select All option and check boxes next to each item.  You 
will also find a search field within the drop-down.

Basic PivotTable 
Filtering,
continued

When using the 
filtering tools from 
within the PivotTable 

Field list, use only the 
fields that are in the 
PivotTable.  If the field is 
not in use, filtering will 
have no affect.

Note

Filtered header 
drop-down Filtered Field in the PivotTable Field Pane
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Clearing a Filter
Clearing applied filters from a PivotTable will return all data 
which was hidden by the filter.  This can be done all at once if 
multiple filters have been applied or individually as needed.

Clearing Single Filters
 � Click the Sort & Filter drop-down arrows with the 

funnel icon.

 � Check the Select All checkbox.

- OR -

 � Choose Clear filter for (Field Name) from the menu.

 � Click the [OK] button.

Clearing All Filters
 � On the Analyze Tab, in the Actions Group click the 

[Clear] button drop-down and choose Clear Filters.

- OR -
 � On the Data Tab in the Sort & Filter Group, click the 

[Clear] button

Basic PivotTable 
Filtering,
continued
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Instructions: Results/ Comments:

Action 2.2 - Applying a Basic Filter

1. MyShipping.xlsx should still be open.

2. On the Analyze Tab in the Show Group, 
click the [Field Headers] button.

3. In the PivotTable Field pane field list, 
hover over  the Salesperson field.

4. Click the drop-down arrow of the 
highlighted field.

5. Uncheck the Select All checkbox.  Check 
the checkboxes for Anne Dodsworth and 
Margaret Peacock.  Click the [OK] button.

6. On the Analyze Tab in the Show Group, 
click the [Field Headers] button.

7. Right-click on Anne Dodsworth’s name 
and Expand Entire Field.

8. Click the drop-down arrow in the 
Country filter header.

9. Click on Denmark and then click the [OK] 
button.  

10. Save the file and leave it open.

If not, reopen it.

The Row and Column headers are 
removed from the PivotTable along with 
the filtering drop-downs.

The Salesperson field is highlighted and a 
drop-down arrow is displayed.

The Sorting & Filtering menu is displayed.

Only data pertaining to the two selected 
salespeople is displayed in the PivotTable.

The Row and Column header are 
redisplayed.

The list companies each salesperson works 
with is displayed.

The list of Countries is displayed.

Since Anne Dodsworth had no dealings 
in Denmark, her information has been 
removed from the PivotTable.

[Ctrl S].
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Advanced 
Filtering

Label and Value Filters
Rows and columns may contain any of the three data types: 
Dates, Numbers, or Text.  Excel determines the data type offers 
the appropriate filtering tools.  When basic filtering capabilities 
in the field drop-down are not sufficient to filter data to a more 
narrow view consider using the Label and Value filtering tools.

Using the Label filters allow you to easily search through a long 
list of items in the field with a wide variety of options related to 
the data type.  You can choose an option from the menu to open 
the Label Filter dialog.   

From within the dialog, you are able to choose any of the 
available options in the menu from the Show items for which 
the label field drop-down.  Then enter the desired parameter for 
the filter in the open field of the dialog.

Applying a Label Filter
 � Click on the drop-down arrow next to any column or 

row field name in the PivotTable.

Excel has determined the data type and displays the 
appropriate filtering tool set.

 � Select the Filter type you would like to use from the 
Label Filter drop-down.

 � Complete the information in the Filter dialog.
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Applying a Value Filter
No matter the data type, when choosing the Value Filter option, 
the same set of options are available.  Once the choice of Value 
Filter has been made the Value Filter dialog opens.  This dialog 
allows you to specify parameters as needed.  The available fields 
in the Value Filter dialog will change in relation to the type of 
filter being applied.

Accessing the Value Filter dialog is done by clicking the row or 
column filter drop-down and choosing a value filter.

Using the Top or Bottom 10
Sometimes you would like to see the top 10 purchasers of your 
product or the top 10 salespeople in your organization.  You can 
use the Top 10 filter in the Values Filters to see these results.

To Filter the Top 10
 � Click on the drop-down arrow next to any field name 

in the PivotTable.

 � Click on Value Filters to display the drop-down list.

 � Select Top 10... from the submenu. The Top 10 Filter 
dialog opens.

 � In the Top 10 Filter dialog, select whether or not you 
wish to show the Top or Bottom 10 by clicking on 
the drop-down arrow.

 � If needed, change the number of items being shown 
by using the arrows of the value field to change the 
number or by selecting the number and typing it in.

 � Finally, select whether you wish to see the Top/
Bottom 10 items, Top/Bottom 10 percent, or Top/
Bottom 10 Sum.   

Advanced 
Filtering,
continued

Select Sum to 
display what 
contributed to the 

top number you selected.

Note
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Instructions: Results/ Comments:
1. MyShipping.xlsx should still be open.

2. Click the Country filter drop-down and 
choose (All) from the menu and click 
[OK].

3. Click the Salesperson drop-down and 
check the Select All checkbox and click 
the [OK] button.

4. Click the Salesperson drop-down, click 
the Label Filter option and choose Begins 
With ... from the list.

5. Click into the blank text field and type 
in: 
 a  
click the [OK] button.

6. Expand the entire Salesperson field

7. Click the Product Name field drop-down, 
click the Value Filter option and choose 
Greater Than ... from the list 

8. Choose Sales from the first field drop-
down,  choose is greater than from the 
operator field,  and in the blank text field 
and type: 
1000 
click the [OK] button.

9. Save the file, and leave it open.

If not, reopen it.

Data from all the countries is re-displayed.

All the salepeople are re-displayed.

The Label Filter dialog opens.

The search is for any names which begin 
with the letter a; the results will show 
the data from Andrew Fuller and Anne 
Dodsworth.

If necessary.

The Value Filter dialog opens.

Only sales of more than $1000 are 
displayed.

[Ctrl S].

Action 2.3 - Label and Value Filtering a PivotTable
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Report Filters Using Multiple Report Filters
The Report Filter will give you a high level summary of the data 
and can include multiple fields.  To filter by more than one field, 
you add other fields to the Filter area in the PivotTable Field pane. 

Adding Multiple Fields to the Filter
 � In the PivotTable Filed pane, drag the desired fields to 

the Filter area.  

 � Place them in the order you wish them to appear in the 
PivotTable.

 � You can now filter by each field independently and 
combine filters.

Using Multiple Filter
By default, Excel removes a filter on a field when another filter 
is applied.  To maintain your filters while you create additional 
filters you need to turn on Allow multiple filters per field:

 � Right-click any cell in your PivotTable. 

 � Select PivotTable Options.

 � The PivotTable Options dialog opens.

 � Click the Totals and Filters tab in the dialog.  

 � Click the checkbox for Allow multiple filters per field.

 � Click the [OK] button. 
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Using the Search Box to Apply a Filter
 � First, from any of the Filter drop-down buttons; 

(Report Filter, Row, or Column).

 � If using a Report Filter- select the Multiple Items 
check box, which will activate the checkbox for each 
selection.

 � Click into the Search field located above the field item 
list.

 � Type in the search term.  

 � Check the checkboxes that contain or are part of the 
desired results.

 � Click the [OK] button.

Using Wildcards
When you can only specify a portion of what you are filtering 
for, wildcards can be used  to replace missing text.  For example, 
if you wish to search for all names that begin with an M and end 
with a T, you can enter M*T.  The asterisk represents any number 
of characters in that position.  The following wildcards may be 
used in your filter

Character Definition Example

*

Used to represent any 
number of characters 
in that position, 
including zero 
characters.

M*T will return Matt, mint, 
malt, mutt, most.

?
Represents one 
character in that 
position.

M?T will return mat or met.

~
Searches for wildcard 
characters. Computer~Workshop will 

return Computer*Workshop.

Filtering With 
Search Box

Wildcards can 
be used in any 

Filter dialog or the 
Search field in the 
field filter drop-
down.

Note
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Adding Criteria to an Existing Filter
 � Click on a filtered field button in the PivotTable.  

(Filtered fields have a Funnel icon with the drop-down 
arrow)

 � In the Search Box, type a second search criteria.  All 
matching items list.

 � Click on the [Add current selection to filter] checkbox to 
append the existing filtering.

 � If this checkbox is unchecked when clicking the 
[OK] button, all previous filtering is replaced not 
amended.

 � If working in a report filter field make sure the 
Select Multiple Items checkbox is checked.

 � Click [OK]. 

 � The additional search results are added to the existing 
results.

Using Multiple Column and Row Filters
Sometimes, you will want to filter by multiple fields within your 
rows.  By adding multiple fields to the Rows section of your 
PivotTable Field pane, you will be able to apply multiple filters at 
the same time.

Adding to Filters
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Instructions: Results/ Comments:
1. MyShipping.xlsx should still be open.

2. On the Analyze Tab in the Actions 
Group, click the [Clear] button drop 
down and choose Clear Filters.

3. Drag Company Name and Required 
Date to the Filters area of the PivotTable 
Field pane.

4. Click the [Filter] button next to Country 
field and select Ireland, then click [OK].

5. Click the [Filter] button next to 
Company Name field and in the Search 
field type in: 
n 
do not click the [OK] button yet.

6. Add an  *  to after the N.

7. Place the  *  before the N.  

8. Check the Select Multiple Items checkbox 
and click the [OK] button to apply the 
filter.

9. Click the [Filter] button next to Country 
field and select All, then click [OK].

10. Click the [Filter] button next to 
Company Name field and in the Search 
field type in: 
 b* 
do not click the [OK] button yet

If not, reopen it.

All filter have been removed and the 
PivotTable has been reset.

This will add Company Name  and 
Required Date to the top of the 
PivotTable.

Only sales made in Ireland are displayed.

Any Company Names with an N 
anywhere in the name are listed.

Only companies beginning with the letter 
N are shown.

Only Company Names ending with the 
letter N are shown.

No results match these filtering criteria, so 
there is no information in the PivotTable.

Now data matches the filter criteria of the 
Company Name filter and is displayed in 
the PivotTable.

Notice the results shown in the Filter box.

Action 2.4 - Multiple Report Filters
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Instructions: Results/ Comments:
11. Click the checkbox for Add to current 

selection and click [OK].

12. On the Analyze Tab in the Actions 
Group, click the [Clear] button drop 
down and choose Clear Filters.

13. Save the file but leave it open.

Now data which matches both aspects of 
the searches are displayed.

All filters are removed and all data is 
redisplayed.

[Ctrl S].

Action 2.4 - Multiple Report Filters, continued
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Conditional 
Formatting in a 
PivotTable

Automatically applying cell formatting, which is based on the 
cell contents or vales, is referred to as Conditional Formatting.  
This is a great way to emphasize or draw attention to data 
of particular interest.  For example you can highlight in red 
any budget items that are  greater than 20% over budget.  The 
technique to apply Conditional Formatting is similar to the 
technique used in a spreadsheet.

Using Conditional Formatting
 � Select a value within the field to be formatted.

 � Click on the [Conditional Formatting] button located 
on the Home Tab.  A menu of conditional formatting 
options will be displayed.

 � Choose one of the following:

 � Highlight Cells Rules — 
will highlight cells that 
are greater than, less than, 
between or equal to values 
that you specify.

 � Top/Bottom Rules — will 
allow you to highlight the 
highest or lowest numbers 
or percent in the selected 
cells.

 � Data Bars — will display 
colored bars that compare 
the value in the cell to the 
other cells in the range.

 � Color Scales — will use 
different shades of color to 
represent different values 
from low to high.

 � Icon Sets — will use sets of similar icons that will 
visually indicate a cell's value relative to a set 
threshold.

 There are also options for creating a new rule, for 
clearing rules, and for managing rules.  
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 � When selecting any of the top five menu options, a 
submenu appears with additional selections. 

 � For the Highlight Cells Rules and Top/Bottom 
Rules you will get an additional dialog to enter a 
value and color choice. 

 � As you point to the DataBars, Color Scales, and Icon 
Sets options the submenus are live preview galleries.  

 � For the Highlight Cells and Top/Bottom Rules 
options, you will not see the preview until you 
have selected the specific rule or submenu.

 � To implement the conditional formatting, just click the 
submenu option of your choice.  

 � Once the Conditional Formatting is applied, it will be 
applied to the selected cell only.  A Smart Tag appears 
next to the cell; clicking it will allow the formatting to 
be extended to the entire field.

 � If the New Rule choice is selected, you are able to 
apply the formatting to field as the rule is created.

Conditional 
Formatting in a 
PivotTable, 
continued

Selecting the second 
option from the 

Smart Tag list will let 
you switch Row labels 
if needed because the 
formatting is applied to 
the values, not the field.

Note
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Clearing Conditional Formats
 � To clear the formatting, select a cell within the field.

 � Click on the [Conditional Formatting] button.

 � Select Clear Rules from the menu.

 � Then, select Clear Rules from This PivotTable from the 
submenu.

 

Conditional 
Formatting, 
continued

If the PivotTable 
isn’t active when the 
Clear Rule option 

is selected, the Clear 
from PivotTable will not 
available.

Note
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Instructions: Results/ Comments:

Action 2.5 - Applying Conditional Formatting

1. MyShipping.xlsx should still be open.

2. Select cell C6.

3. On the Home Tab in the Styles Group, 
click the [Conditional Formatting] 
button drop-down and choose New Rule.

4. In the Select a Rule Type area of the 
dialog, choose Format all cells based on 
their values.

5. In the Edit the Rule Description area, 
choose Icon Set from the Format Style 
drop-down.

6. Choose the top icon set from the Icon 
Style drop-down.

7. For the Green icon set the fields as: 
Operator:  >= 
Value:  4000 
Type:  Number

8. For the Yellow icon set the fields as: 
Operator:  >= 
Value:  1000 
Type:  Number

9. Click the [OK] button.

10. On the Home Tab in the Styles Group, 
click the [Conditional Formatting] 
button drop-down and choose Manage 
Rules.

11. Select the Icon Set rule and click the [Edit 
Rule...] button.

If not, reopen it.

The first cell with a value.

The New Formatting Rule dialog opens.

The top choice from the list.

The Icon Sets controls are displayed in the 
Edit the Rule Description area.

The Traffic Light set.

This sets the upper parameters of the rule.

This sets the mid range parameters of the 
rule.

Only the selected cell is affected by the 
rule.

The Conditional Formatting Rules Manager 
dialog opens.

This is the only rule listed and clicking 
the [Edit Rule] button opens the Edit 
Formatting Rule dialog
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Instructions: Results/ Comments:

Action 2.5 - Applying Conditional Formatting, continued

12. In the Apply Rule To: area select the All 
cells showing “Sales” values for “Product 
Name” radio button.

13. Click the [OK] button.

14. Click the [Apply] button then the [OK] 
button.

15. Select an empty cell.

16. On the Home Tab in the Styles Group, 
click the [Conditional Formatting] 
button drop-down and examine Clear 
Rules options.

17. Select any cell in the PivotTable.

18. On the Home Tab in the Styles Group, 
click the [Conditional Formatting] 
button drop-down and choose Clear 
Rules options and select Clear Rules From 
This PivotTable.

19. Save the file but leave it open.

20. Right-click cell A6 and choose Collapse 
Entire Field from the menu.

21. Select cell C6, on the Home Tab in the 
Styles Group, click the [Conditional 
Formatting] button drop-down Greater 
Than from the Highlight Cell Rules 
group.

22. Click into the first field of the Greater 
Than dialog and enter 
150000.

This will expand the selection where the 
rule will be applied.

The edit is made.

The edit is applied then the dialog closes.

The PivotTable and it’s options are no 
longer active.

The Clear Conditional Formatting 
options apply only to the cell or sheet, the 
PivotTable options are greyed out since the 
PivotTable isn’t active.

The PivotTable options are reactivated.

Since the PivotTable is active the Clear 
Rules From This PivotTable option is 
available. Choosing this option removes 
the conditional formatting from the entire 
table.

[Ctrl S].

Only the Salesperson’s names and data is 
displayed.

The Greater Than dialog opens.

To set the desired target value.
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Instructions: Results/ Comments:

Action 2.5 - Applying Conditional Formatting, continued

23. Click the [OK] button.

24. Click on the Formatting Options Smart 
Tag. 

25. Choose the last radio button.

26. On the Home Tab in the Styles Group, 
click the [Conditional Formatting] 
button drop-down and choose Clear 
Rules options and select Clear Rules From 
This PivotTable.

27. Save the file but leave it open.

The conditional formatting is applied 
to that cell only.  A Smart Tag is shown 
beside the cell.

A list of options on how to extend the 
conditional formatting is displayed.

The conditional formatting is applied for 
the rest of the column.

All conditional formatting is removed.

[Ctrl S].
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When the PivotTable data is presented in its smallest value, you 
frequently end up with detailed information that would be better 
represented by being grouped.  Excel will automatically apply 
grouping when date data is added to the rows or columns area 
of the PivotTable.  As data is added, you will see a Month field 
added along side the days.  If data being added to the rows area 
contains numeric information, it is not automatically grouped, 
but grouping can be applied.  Grouping allows you to see data 
in larger sets that can be expanded to reveal more granular and 
detailed views of specific data.

Grouping Data in a PivotTable
 � Drag a date field from the list of PivotTable fields into 

the Rows area in the PivotTable Field pane.

 � The data should be displayed in both Month and Date 
fields.

 � If the automatic grouping did not occur or you 
want to modify the grouping:

 � On the Analyze Tab in the Group Group, click the 
[Group Selection] button.

- OR -
 � Right-click a date in the PivotTable and choose 

Group from the menu.

Grouping Data
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 � Depending on the type of data being grouped 
(Date or Numeric), the Group dialog offers the 
appropriate controls.

 � Apply the desired grouping structure and click the 
[OK] button.

Sorting by Fiscal Year
 � In the PivotTable Field pane, add date field in the Rows 

area.

 � If Automatic grouping is turned on, the dates should 
appear in two columns- Months and Date.

 � Right-click either of these columns and choose Group 
from the menu  

- OR –
 � On the Analyze Tab in the Group Group, click the 

[Group Selection] button

 � Check the Quarters checkbox and click the [OK] button.

 � Open the Find & Replace dialog by using the [Ctrl H] 
shortcut

- OR –
 � On the Home Tab in the Editing Group, click the [Find 

& Select] drop-down and choose Replace from the 
menu.

Grouping Data,
continued

Number Grouping

Date Grouping
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 � In the Find field, type in-  Qtr3  (to start the fiscal year 
in July)

 � In the Replace field, type in –  Quarter1  (or however 
you want the name displayed)

 � Tap the [Replace All] button. 

 � Repeat for each of the remaining quarters 
accordingly.

 � Once all the quarters have been renamed:

 � Use the Sort options from the field drop-down to 
sort the quarter automatically.

 � Select each quarter cell: hover over the border until 
the cursor changes to the move cursor and drag 
into correct position to sort them manually.  Repeat 
to arrange the quarters correctly.

Grouping Data,
continued



Excel 2019:  PivotTable Features, Rel. 1.0, 02/21/2020
Lesson 2:  Filtering PivotTables, Page  56

Instructions: Results/ Comments:

Action 2.6 - Grouping Data

1. MyShipping.xlsx should still be open.

2. In the PivotTable Field pane, drag both the 
Salesperson and Product Name out of 
the Rows area.

3. Drag the Quantity field into the Rows 
area.

4. On the Analyze Tab in the Group 
Group, click the [Group Selection] 
button.

5. In the Grouping dialog; 
-Uncheck the Ending at: checkbox and 
set the value to  250 , 
-In the by: field set the value to   50 , 
-Click the [OK] button.

6. In the PivotTable Field pane, drag  the 
Quantity field out of the Rows area

7. Drag Order Date from the field list into 
the Rows area.

8. Click the [Plus] button to expand any 
month.

9. Click the [Minus] button to collapse the 
month.

10. On the Analyze Tab in the Group 
Group, click the [Group Selection] 
button.

11. Check the Quarters checkbox and click 
the [OK] button.

If not, reopen it.

These fields are removed from the 
PivotTable.

The quantities are added to the 
PivotTable.

The Grouping dialog opens.

The Quantities field is grouped by 50’s.

The field is removed from the PivotTable.

The Rows are grouped by month. If the 
fields are collapsed then you will also see 
the Order Date column.

Any days that month where an order was 
made are displayed.

The Grouping dialog opens.  You could also 
right-click any cell in either the Month or 
Order Date field and choose Group from 
the menu. 

A Quarters column is added to the 
PivotTable.
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Instructions: Results/ Comments:

Action 2.6 - Grouping Data, continued

12. Expand and collapse the fields in the 
PivotTable so that the Quarters are 
expanded but the Months are collapsed.

13. Save the file but leave it open.

14. On the Home Tab in the Editing Group 
,click the [Find & Select] drop-down and 
choose Replace from the menu.

15. In the Find field type in: 
 Qtr3 , 
-In the Replace field type in: 
 Quarter 1  
-click the [Replace All] button.

16. Repeat to change each of the remaining 
quarters accordingly.

17. Click the Quarter field drop-down and 
choose Sort Oldest to Newest

18. Save the file but leave it open.

[Ctrl S].

The Find & Replace dialog opens. 
[Ctrl H]  is the replace key command.

The first quarter of the fiscal year is 
named.

Each of the fiscal year quarters are named.

The month are sort in accordance to fiscal 
year.

[Ctrl S].
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Using the Slicer Slicers are used to easily filter of data in the PivotTable or 
PivotChart.  To add slicers to either PivotTable or PivotCharts 
look in the Filter Group on the Analyze Tab.  Excel now also 
offers Timeline slicers for date data.  

A slicer can be used to filter data by fields which are not 
currently used in the PivotTable. This allows a new level of 
flexibility.  They can also be connected to multiple PivotTables 
and/or PivotCharts by using the [Filter Connections] button.  All 
connected objects are filtered at once. To display information that 
pertains only to a specific item or combination of items, click on 
that option in one of the available slicers.

 Generating Slicers 
 � On the Analyze Tab in the Filter Group, click the 

[Insert Slicer] button.  

 � The Insert Slicers dialog is displayed.

 � All data fields are lists in the dialog.

 � Check the fields which will be used to filter the data.

 � Click [OK].

If you use the 
[Insert Timeline] 
button, then the field 

list will only include 
date fields in the list of 
options.

Note
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When the dialog closes, a slicer for each of the checked fields is 
added to the worksheet.  When one is selected, the bounding box 
controls and Slicer Tools Options Tab are displayed.

This tab will allow you to change the title, format, connections, 
size and position of the Slicers. 

Using Slicers
 � Clicking a button in the Slicer will apply a filter to 

display only that item.  To add to the filter you can 
hold the 

 � [Shift] key to select consecutively

- OR -
 � [Ctrl] key for non-consecutive selections

 � Or click the [Multi-Select] button at the top of the 
Slicer.

The PivotTable automatically shows only the information related 
to the selected item(s).  If you have a PivotChart created based 
on the same PivotTable, the PivotChart will also display the 
selection(s).

Using a Filter Versus Using a Slicer
Is it better to use a Filter or a Slicer?   Prior to 2010, Slicers were 
not available for use in a PivotTable.  Slicers make it easier to see 
the current filtering state when you filter on multiple items.  
Making it easier to understand what exactly is being shown in a 
filtered PivotTable.  Additionally, Slicers offer the ability to use 
one Slicer for multiple tables.  

Using the Slicer 
continued

Clear Filter button

Multi-Select button
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Using the Slicer 
continued

Clearing a Slicer Filter
 � Click on the [Clear Filter] button in the top right 

corner of the Slicer.

Closing or Deleting a Slicer
 � Select the Slicer.

 � Press the [Delete] key.

- OR -
 � Right-click on the Slicer and select Remove <Slicer 

Name> from the shortcut list.

Formating a Slicer
 � Select the Slicer you would like to format.

 � When the Slicer Tools Options Tab appears.

 � In the Slicer Group you are able to:

 � Change the Slicer Caption to a more descriptive 
name. 

 � Access the Slicer Setting dialog by clicking the 
[Slicer Settings] button.

 � Modify the connections of the slicer by clicking the  
[Report Connections] button.

 � Choose a Slicer style from the Slicer Styles Gallery by 
selecting an option from the gallery.  

 � The Buttons group allows you to set number of button 
columns in the slicer as well as their size.

 � The Size group allows set  the size of the Slicer.
Be careful when 
changing the height 

and width of the slicer 
buttons.  Use the Height 
and Width settings in 
the Button group.

Note
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Using the Slicer Settings Dialog
The following options are available in the Slicer Settings dialog 
which are accessed by clicking the [Slicer Settings] button on the 
Slicer Tools Options Tab or right-clicking on the Slicer Title Bar 
and choosing Slicer Settings from the menu.

 � Name:  This is to identify the object on the spreadsheet.  
The default name is usually displayed, but can be 
changed to a more appropriate title.

 � The Display Header checkbox will turn the Header on 
the Slicer off and on.  Consider turning the header off 
when it is unnecessary or you are trying to fit the slicer 
into a small area.

 � The Item Sorting and Filtering section is to determine 
how the values appear in the slicers.

 � Visually indicate items with no data, means that even 
if there is no data, the button for that category/item 
will still appear in the slicer.  You may see this when 
you connect your slicer to multiple PivotTables.  The 
button will simply be grayed out if there is no data 
associated with it.

 � Show items with no data last, will put that button 
at the bottom of the slicer. The buttons will be re-
arranged to show those with data first, going from left-
to-right, top-to-bottom.

 � Similarly, Show items deleted from the data source 
will still show a button in the Slicer for items that have 
been deleted, as long as items deleted from the data 
source are being retained in the PivotTable Options.

Show items with no 
data last cascades 

underneath Visually 
indicate items with 
no data because it is 
dependent on whether 
Visually indicate items 
with no data is checked 
or not.

Using the Slicer 
continued

Note
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Slicer Connections
When a slicer is created in relation to a PivotTable, it is used 
to filter that PivotTable.  It is possible to connect multiple 
PivotTables to a single slicer, as long as the data source is the 
same and on the same worksheet.  When multiple PivotTables 
are connected to a single slicer, that slicer is able to filter all 
connected tables at once. The data source must be exact, if rows 
or columns are added or removed from the data source, then 
the source is no longer the same and the connections will not 
be possible.  The Slicers would have to be recreated and re-
connected.

Adding Connections
 � Once the PivotTables have been created.

 � On the Analyze Tab in the Filter Group, click the 
[Insert Slicer] button.

 � On the Slicer Options Tab in the Slicer Group, click 
the [Report Connections] button.

 � The Report Connections (Field Name) dialog opens. 

 � Any PivotTables based on the exact same data 
source will be listed in the dialog.

 � Check all the PivotTable checkboxes to be controlled 
by this slicer and click [OK].

Using the Slicer 
continued
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Instructions: Results/ Comments:

Action 2.7 - Adding Slicers 

1. MyShipping.xlsx should still be open.

2. Duplicate Sheet1.

3. Drag all the fields out of the Rows area in 
the Pivottable Field pane.

4. Drag Country and Company name fields 
into the Rows area.

5. On the Analyze Tab in the PivotTable 
Group, type 
SecondTable  in the PivotTable Name 
field.

6. Switch back to Sheet1 and click into the 
PivotTable.

7. On the Analyze Tab in the Filter Group, 
click the [Insert Slicer] button.

8. From the list of available fields, check the 
Salesperson checkbox and click the [OK] 
button.

9. Examine the Slicer Options Tab.

10. Hover over the border of the slicer, the 
cursor will change to a four sided move 
cursor.  Drag the slicer into column H of 
the worksheet.

If not, reopen it.

On the Sheet1 tab, hold the [Ctrl] key as 
you right-click and drag over so that the 
small black triangle is to the right of the 
Sheet1 tab, let go of the mouse to duplicate 
the entire worksheet.

To name the PivotTable.

The Insert Slicer dialog opens, showing 
a list of all data fields in the data set the 
PivotTable is based on.

While you are able to choose more than 
one field from the list, we will use only 
one at this time.  The Salesperson Slicer is 
added.

This is a contextual tab, only available 
when the slicer is actively selected.

While the slicer is selected the bounding 
box controls are visible, allowing for easy 
resizing of the slicer.
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Instructions: Results/ Comments:

Action 2.8 - Using and Formatting the Slicer, continued 

11. Using the bounding box controls, resize 
the Slicer to show only three buttons 
vertically.  Then make the slicer twice as 
wide.

12. On the Slicer Options Tab in the Buttons 
Group, change the number of columns  
in the Columns field from 1 to 2.

13. On the Slicer Options Tab in the Slicer   
Styles Group, click the more button and 
choose any style from the gallery.

14. On the Slicer Options Tab in the Slicer 
Group, click the [Report Connections] 
button.

15. Check the SecondTable checkbox and click 
[OK].

16. Click the [Andrew Fuller] button in the 
Slicer.

17. Hold the [Shift] key and click the [Laura 
Callahan] button.

18. Click the [Clear Filter] button.

19. Click the [Multi-Select] button.

20. Click the [Andrew Fuller] button in the 
Slicer.

As you hover over the controls (small 
white circles) the cursor changes to a 
double headed arrow, allowing you to 
resize the width, height, or both.

The Slicer now has two columns of 
buttons.

The Slicer Style gallery is displayed and 
when you choose one, that style is applied 
to the Slicer.

The Report Connections (Salesperson) dialog 
opens, showing a list of all PivotTables 
that can be connected using this slicer.

The Slicer will now apply filtering to both 
PivotTables at the same time.

Only data pertaining to Andrew Fuller is 
displayed.

Using the [Shift] key allows for 
continuous selection, now all data 
pertaining the Andrew, Anne, Janet, and 
Laura is displayed in the PivotTable. 
Using the [Ctrl] key allows for non-
continuous selection.

The filtering is removed and all data is 
displayed.

Now when a button is clicked, that choice 
is removed from the PivotTable.

Andrew Fuller’s data is removed from the 
PivotTable.
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Instructions: Results/ Comments:

Action 2.8 - Using and Formatting the Slicer, continued 

21. Switch to Sheet1(2). 

22. Notice that the data here is also not 
showing information about Andrew 
Fuller.

23. Switch back to Sheet1 and change the 
choices in the slicer.

24. Switch to Sheet1(2). 

25. Notice that the data here reflects the 
choice made on the slicer.

26. Save and close the file.

Consider creating a new Window and 
tiling the two sheets vertical to better see 
the changes as they are made.

[Ctrl S] & [Ctrl W].



Tips and Notes



Lesson Overview

You will cover the following concepts in this 
chapter:

Lesson 3: Advanced 
Features of PivotTables

Excel 2019: PivotTable Features
Rel. 1.0, 02/21/2020

 � PivotTable and PivotChart Wizard

 � Installing PivotTable and PivotChart 
Wizard

 � Using the Wizard

 � Consolidating Multiple Workbooks Or 
Worksheets

 � Editing A Consolidated PivotTable

 � Calculated Fields and Calculated Items

 � Adding A Calculated Item

 � Adding A Calculated Field

 � Editing Calculated Items Or Fields

 � Solve Order and Displaying Formulas



Lesson Notes
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PivotTable and 
PivotChart 
Wizard

Frequently, data may be stored in multiple workbooks or 
worksheets within a single workbook needs to be consolidated 
into a PivotTable.  Excel offers the PivotTable and PivotChart 
Wizard is the tool to accomplish this type of task although you 
must add the button to the interface in either the QAT (Quick 
Access Toolbar) or a customized ribbon tab. 

Considerations for Setting Up Your Source Data
 � Your data ranges should be set up in a cross-tabular 

format with matching column names for items that 
you want to summarize together. 

 � The data being consolidated should be numeric data. 

 � Total rows or columns should not be included from 
within the source data when you are specifying the 
data range for the report.

 � Consolidations can use Page Fields that contain items 
representing one or more of the data source ranges. 

For example, if combining data from departments to 
create a company budget the Page Field can define 
each source as the department.

 � Consolidations can use Named Ranges which perform 
better when the Named Ranged are managed in the 
source files. As rows are added or removed from the 
named range the consolidated PivotTable will reflect 
those changes when refreshed.

 � Consolidations can also use formulas such as a 3D 
Reference, or the [Consolidate] command located on 
the Data Tab in the Data Tools group.
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Installing the PivotTable & PivotCharts Wizard
 � On your Quick Access Toolbar 

(QAT), located at the upper-left 
corner of your Excel screen, select 
the [Customize] button and select 
the More Commands option. 

- OR -
 � Access the Excel Options window 

from the File Tab and select the 
Quick Access Toolbar category.

 � From the Choose commands 
from: field drop-down, select 
All Commands.

 � Scroll down and select the 
[PivotTable and PivotChart 
Wizard] icon, then click the 
[Add] button to add it to the 
right-hand column. 

 � Click the [OK] button to apply the change and close 
the Options.

 � The PivotTable and PivotChart Wizard icon 
appears on your QAT and return you back to 
your Excel worksheet.

Installing 
PivotTable and 
PivotChart 
Wizard

If you don't want 
to add the button 
to the interface you 

can use the [Alt] [D] [P] 
key sequence to access 
the PivotTable PivotChart 
Wizard.

Note



Excel 2019:  PivotTable Features, Rel. 1.0, 02/21/2020 
Lesson 3:  Advanced Features of PivotTables, Page  71

Instructions: Results/ Comments:

Action 3.1 - Adding The PivotTable and PivotChart Wizard

1.  On your Quick Access Toolbar at the 
top left of your Excel workbook,  click on 
the [Customize] button and select More 
Commands from the list.

2.  In the Excel Options dialog, under Choose 
commands from:, field drop-down select  
All Commands.

3.  Scroll down and select the PivotTable 
and PivotChart Wizard then click the 
[Add] to add it to the right-hand column. 

4.  Click the [OK] button and the 
[PivotTable and PivotChart Wizard] 
button will appear on your QAT and 
return you Excel.

The Excel Options window opens. 
The [Alt] [F] [T] key sequence will also 
open the Options window. If using the 
keys you will need to choose the Quick 
Access Toolbar from the list of categories on 
the left.

This field is above the left column of 
available commands. Choosing All 
Commands now lists every command in 
Excel, including otherwise unavailable 
commands.

The list is alphabetical. Once the command 
you want is selected, doubling clicking the 
command will add it to the QAT.

The Options window closes. 
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Using the 
Wizard

Now that the [PivotTable and PivotChart Wizard] button has 
been added to the QAT  and the data sources have been opened 
and prepared, it is ready for use. Clicking the button opens the 
wizard. This wizard has three steps but the number of sub-steps 
varies depending on which data source is selected in step one.

Step 1: What Type of Consolidation do I want?
In Step 1 of the PivotTable and PivotChart Wizard, there are 
several selections to determine the type of consolidation you 
wish to produce.  Depending on the choice made here Step 2 will 
differ.

Step 2: Choosing the Data Source
1: Microsoft Excel List or Database
Choose this option when the source data is on a spreadsheet in 
an open workbook.  Excel recognizes the contiguous data and 
extends the selection to include all connected data as the source. 
Choosing this source and clicking the [Next] button opens the 
Step 2 dialog. 

Click into the Range field and then select a cell in the data set on 
the spreadsheet.  You can only add one data range when using 
this option. Once the data range has been defined, click the 
[Next] button to advance to Step3 dialog.

This is very 
similar to using 

the [PivotTable] 
button on the Insert 
Tab.

Note



Excel 2019: PivotTable Features, Rel. 1.0, 02/21/2020 Page 73

Lesson 3: Advanced Features of PivotTables

2: External Data Source
This option is used when the data source is in another workbook 
or in a database.  These would be data sources which are 
completely external to the currently active workbook.  Excel 
will generate a PivotTable from the database tables or other 
workbooks.  Clicking the [Next]  button with this option selected 
opens the Step 2 dialog. 

Here you would click the [Get Data...] button to open the 
Choose Data Source dialog where you could choose from existing 
connections or create new ones from scratch. 

Once the data source connection has been made, the Step 2 dialog 
is re-displayed with the [Next] button active. Click the [Next] 
button to advance to Step3 dialog.

3: Multiple Consolidation Ranges
Select this option when source data is stored in other workbooks 
or other worksheets within the current Excel workbook.  Source 
data from multiple locations will be consolidated into a single 
PivotTable which can be refreshed as data is updated in each 
source location. Allowing for broader views of large multi-source 
data sets.  Clicking the [Next] button opens the Step 2a dialog. 
This dialog allows you to choose whether Excel will generate a 
Page Field or you will. 

If using other 
workbooks, open 
and tile them before 

beginning this process. 
If using data from other 
worksheets, you can 
open new windows for 
each worksheet and tile 
them before beginning.

Note

Using the 
Wizard,
continued
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Once this choice is made, the next dialog allows you to choose 
the data sources and/or create page fields. 

4: Another PivotTable Report or PivotChart Report
This option is used when you want to create a new PivotTable 
based on an existing PivotTable in the current workbook.
As any source PivotTables or PivotCharts data is refreshed, this 
generated is also refreshed.  Clicking the [Next] button with this 
option is selected opens this  Step 2 dialog.
This dialog lists all PivotTable or PivotCharts in the workbook. 
(only one can be selected.) Once this step is completed the next 
dialog allows you to set the location of the PivotTable.

Step 3: Where to add PivotTable or PivotChart
After the data sources have been defined, the Step 3 dialog allows 
you to set where the new PivotTable or PivotChart is placed into 
the document.

Using the 
Wizard,
continued

Data Selection Dialog
Manual Page Field Creation

Data Selection Dialog
Auto Page Field Creation
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Consolidating 
Multiple 
Workbooks Or 
Worksheets

Before opening 
multiple files, you 
may want to collapse 

the ribbon in order to 
save screen space. This is 
done by double-clicking 
any tab in the ribbon.

Note

If combining 
data from across 
worksheets, you can 

create new windows for 
each worksheet and tile 
them before beginning.

Note

Consolidating Data From Multiple Excel Sources
Excel offers several methods to combine or compile data from 
across multiple worksheets or workbooks.  Linking the files 
through formulas or using the Consolidation tool allows you to 
aggregate data, creating data sets which provide clearer insights 
and understanding of information being gathered or tracked in 
Excel.  When you want to generate a PivotTable from this data 
but do not need to have all the individual data sets in the file or 
a single worksheet, using the PivotTable and PivotChart Wizard 
provides the best solution 

Before combining data from different workbooks, consider 
opening and tiling the source files before using the PivotTable 
Wizard  to make this process run as smoothly as possible.
In the example above, the PivotTable will be placed into the 
blank workbook.  This could also be a blank worksheet in a file 
with data being drawn from other worksheets.

Choosing Multiple Consolidation Ranges in Step 1 of the PivotTable 
and PivotChart Wizard will bring together data from across 
workbooks or worksheets.  Step 2a is where you need to 
consider an over all report filtering, the filter can be generated 
automatically by the program or you can set the number of  and 
name the page fields manually.

Sheets to be consolidated being viewed in Tiled format.
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Consolidating 
Multiple 
Workbooks Or 
Worksheets,
continued

To combine data from all your ranges and create a consolidation that does not 
contain Page Fields do the following:

The page field is 
like setting a field 
into the Filter area of 

the PivotTable Field pane.

Note

 � Create a single page field for me: this option generates 
a single page field based on the source data being 
combined.  As the sources are defined, Excel organizes 
them alphabetically by name, not in the order added.  
Each source will be given the name of Item and 
assigned a number.

 � I will create the page fields: this options allows you 
to set the number of and name the page fields.  The 
number of page fields can range from 0 to 4.  When 
naming the page field consider the data being named, 
does the data refer to a region, year or month, or some 
other commonality that can uniquely be assigned to 
the specific data being referred to.

Using The Create A Single Page Field
On Step 2b of the PivotTable and PivotChart Wizard, you will select 
and add the data ranges to be consolidated. 
 

 � Click into the Range: field, then select the worksheet 
and highlight the cell range containing the data.

 � Click the [Add] button.

 � With the selected range still highlighted in the Range: 
field, continue to select each workbook or worksheet 
and highlight the data set clicking the [Add] button 
after each.

 � Notice the ranges in the All ranges: field are listed 
in alphabetical order, no matter the order they were 
added.

When selecting the 
data range, select 
a cell within the 

range and use the [Ctrl 
A] keyboard shortcut to 
select all connected data.

Note
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Consolidating 
Multiple 
Workbooks Or 
Worksheets,
continued

Creating Your Own Page Fields
On Step 2b of the PivotTable and PivotChart Wizard, you will select 
and add the data ranges to be consolidated, as well as name and 
determine the number of page field required.

 � Click into the Range: field, then select the worksheet 
and highlight the cell range containing the data.

 � Click the [Add] button.

 � With the selected range still highlighted in the Range: 
field, continue to select each worksheet and highlight 
the data set and click the [Add] button after each. 

 � Once all the ranges have been added:

 � Select number of page fields in the How many page 
fields do you want section of the dialog.

 � Select the first range in the All ranges: field.

 � Click into the Field one: field and type in a name 
that helps define the data set.

 � Continued adding names to each Field name field 
and giving unique and descriptive names.

 � Select the next range in the All ranges: field and 
repeat naming each field. As you do this the 
existing names are available in the field name drop 
downs. There will be names that apply to more 
than one data set, this will act as a mechanism that 
groups the data in logical ways. (years, regions, 
etc..)
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Instructions: Results/ Comments:

The PivotTable and PivotChart Wizard opens.

Choosing this option will allow you to pull 
data from across all the worksheets in this 
workbook into a new PivotTable.

You will be letting Excel determine a page 
field for the PivotTable.

You will be selecting the ranges you want 
to consolidate.

This represent the first range of data to be 
consolidated.

The range is added into the All ranges: 
field.

To continue adding all the other data 
ranges. 

Step 3 of the wizard is opened.

The new PivotTable will be placed into it's 
own worksheet.

The list displays each option as Item#, 
which may not be very useful.

[Ctrl S].

Action 3.2 - Consolidating Multiple Data Sets Into A PivotTable

1. Open the ConsolidatedSales.xlsx 
workbook.

 
2. Click the [PivotTable and PivotChart 

Wizard] on the QAT.

3.  In Step 1 of the Wizard, select the 
[Multiple consolidation ranges] and 
PivotTable radio buttons, then click 
[Next].

4.  For Step 2a of the Wizard, select the 
Create a single page field for me radio 
button, then click [Next].

5.  In Step 2b of the wizard, click into the 
Range: field.

6. Click the Hellmen-Jan worksheet and 
select the range A3:E8.

7. Click the [Add] button.

8.  Repeat the steps 5 to 7 to add the data 
ranges from the other worksheets in the 
workbook.    
The February months cell ranges will be 
A3:E7.

9. Click [Next] to continue. 

10.  In Step 3 of the wizard, select the New 
worksheet radio button, leave the default 
cell address, and click the [Finish] 
button.

11.  In the PivotTable, click the Page 1 filter 
drop-down.

12.  Save the file.
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Editing A 
Consolidated 
PivotTable

Once you have created a PivotTable and need to modify the 
Source data or add page fields of your own design, you will 
use the PivotTable and PivotChart Wizard again.  If the active 
cell is outside of the consolidated PivotTable and you click the 
[PivotTable and PivotChart Wizard] button, you will be starting 
a new consolidation. With a cell actively selected within the 
consolidated PivotTable, you will open the wizard at Step 3 of 
the dialog, and it is possible to use the [Back] button to step back 
through the process.  

Reasons it may become necessary to modify the consolidated 
PivotTable include the addition of or deletion of rows or 
columns within data sets, or deciding that it is necessary to create 
page fields.  

Modifying a Consolidated PivotTable
 � Select any cell within the consolidated Pivottable and 

click the [PivotTable and PivotChart Wizard] button.

 � The PivotTable and PivotChart Wizard dialog opens to 
Step 3 of the process.

 � Click the [Back] button to step back to Step 2b.

 � If you need to change the ranges:

 � Select the range to be modified in the All ranges: 
field and click the [Delete] button.

 � Click into the Range: field, re-define the range and 
click the [Add] button.

 � Once all changes have been made, click the [Next] 
button to proceed to Step 3.

The keyboard 
shortcut to open 
the PivotTable and 

PivotChart Wizard is the 
key sequence of [Alt] [D] 
[P] .

Note
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 � If you want to switch from having the single page field 
created for you to I will create the page fields:

 � While still in the Step 2b of the dialog, click the 
[Back] button at go back to Step 2a.

 � In the Step 2a dialog choose the I will create the page 
fields radio button, click the [Next] button.

 � The Step 2b dialog is redisplayed, notice that all 
your previous selections are still in place, and you 
can now define the number of fields and assign 
them names.

 � Select the radio button for the number of fields to 
add. 

 � Select the first range in the All ranges: field.

 � Click into the Field one: field, and type in a name 
that helps define the data set.

 � Continued adding names to each Field name field,  
giving unique and descriptive names to each data 
range in the All ranges: field.

Editing A 
Consolidated 
PivotTable,
continued
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 � Once all the ranges have had their fields named, click 
the [Next] button to advance to Step 3 of the dialog.

 � In the Step 3 dialog, don't change anything, and click 
the [Finish] button to update the PivotTable.

Using Find&Replace to Rename Page Field Items
For the times when you simply wish to change the number items 
in the list to descriptive names without having to go back a 
create page fields, use the Find and Replace tools. 

 � Drag the Page1 field out of the Filter area in the 
PivotTable Fields pane to the Rows area.

 � The Find&Replace tool will not work if the Page1 
field is the in the Filter area.

 � On the Home Tab in the Editing Group, click the [Find 
& Select] button drop-down and choose Replace.

 � In the Find and Replace dialog:

 � In the Find what: field, type in the Item# to replace.

 � In the Replace with: field, type in what it should be 
replaced with.  

 � Click the [Replace All] button.

 � Excel notifies you that one replacement has been 
made.

 � Repeat the find and replace until all items have 
been renamed.

 � Close the Find and Replace dialog.

 � Drag the Page1 field back into the Filter area of the 
PivotTable Field pane.

Editing A 
Consolidated 
PivotTable,
continued

[Ctrl H] will also 
open the Find and 
Replace dialog.

Note

Remember the 
Items represent the 
data source names 

alphabetically.

Note
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Instructions: Results/ Comments:

Action 3.3 - Modifying A Consolidated PivotTable

If not, re-open it.

An empty cell on the sheet where the 
PivotTable is located.

The PivotTable and PivotChart Wizard dialog 
opens to Step 1.  Since you were not in 
the PivotTable, Excel assumes you want to 
create a new one.

This cell is within the PivotTable.

The PivotTable and PivotChart Wizard dialog 
opens to Step 3.  Excel now assumes you 
wish to modify the existing PivotTable 
created with this tool.

Here you can change how the page fields 
are added to the PivotTable.

You will now create the number of pages 
fields.

The Field One and Field Two fields are 
now active.

The Hellmen-Feb data range is 
highlighted.

This is the name applied in the first field 
associated with the data range.

This is the name applied in the second 
field associated with the data range.

1. The ConsolidatedSales.xlsx file should 
still be open.

2. Select cell A14 on Sheet1.

3. Click the [PivotTable and PivotChart 
Wizard] button in the QAT.

4. Click the [Cancel] button to exit the 
dialog.

5. Select cell A4 on Sheet1.

6. Click the [PivotTable and PivotChart 
Wizard] button in the QAT.

7. Click the [Back] button twice to return to 
Step 2a of the dialog.

8. Choose the I will create the page fields radio 
button and click the [Next] button

9. Click the 2 radio button in the How 
many page fields do you want? section 
of the dialog.

10. In the All ranges: field select the first 
item in the list.

11. Click into the Field One field and type 
<Hellmen >.

12. Click into the Field Two field and type 
< Feb >.
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Instructions: Results/ Comments:

Action 3.3 - Modifying A Consolidated PivotTable, continued

The Hellmen-Jan data range is highlighted.

This is the name applied in the first field 
associated with the data range.

This is the name applied in the second 
field associated with the data range.

Each data range should get names applied 
in both field to better help identify them.

Do not change the location since you 
are currently only updating the active 
PivotTable.

This drop-down offers the list of Sales 
Reps the PivotTable can be filtered by.

Rename the label according to the 
grouping offer in the drop-down list.

The field and label are added in cells A1 
and A2. 

Rename the label according to the names 
offered in the drop-down list.

Since this field contains financial data 
consider naming it Financial.

[Ctrl S].

13. In the All ranges: field select the second 
item in the list.

14. Click into the Field One field and type 
< Hellmen >.

15. Click into the Field Two field and type 
< Jan >.

16. Continued selecting the data ranges 
from the All ranges: field and applying 
appropriate named to the fields.

17. Once all data ranges have been assigned 
fields and names, click the [Next] button 
to advance to Step 3 of the dialog.

18. Click the [Finish] button to complete 
making the modifications.

19. Click the Page 1 field drop-down to 
examine the available fields to filter by.

20. Select cell A1 and type in;  
< Sales Rep >.

21. Drag the Page2 field into the Filter area of 
the PivotTable Field pane. (If Necessary)

22. Select cell A2 and type in;  
< Months >.

23. Select cell A5 and type in; 
< Week >.

24. Rename the Column Label cell with a 
descriptive name of your own choosing.

25. Save the file.
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Calculated Fields 
and Calculated 
Items

You can use summary functions in value fields from an 
underlying data source in PivotTable Reports.  If they do not 
provide the results that you want or need, you can create your 
own formulas using Calculated Fields and Calculated Items.

The difference between a Calculated Field and a Calculated Item 
is that a Calculated Field will add an additional row or column 
to your PivotTable, which then becomes a row or column from 
which other calculations can be created.  A Calculated Item, on 
the other hand, creates a calculation within a field.

For example, you might use a summary function to add up 
January, February, and March to return a First Quarter Total. 
You could then use First Quarter Total as a Calculated Field in a 
formula.

An example of a Calculated Item would be if you want to sum 
only those occurrences on certain days of the week. 

When you are working with Calculated Fields, it is important to 
remember the summary functions that are available for source 
data (with the exception of On Line Analytical Processing or 
OLAP data).

Function Summarizes
SUM Sum of the values. Default function for numeric data.
COUNT Counts the number of data values.
AVERAGE The average of the values.
MAX The largest value.
MIN The smallest value.
PRODUCT The product of the values.
COUNT 
NUMBERS

Counts the number of data values that are numerical.

StDEV Estimate of the standard deviation of a population, where 
the sample is a subset of the entire population.

StDEVP Standard deviation of a population, where the population is 
all of the data to be summarized.

VAR Estimate of the variance of a population, where the sample 
is a subset of the entire population.

VARP The variance of a population, where the population is all of 
the data to be summarized.
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In addition to these summary functions, there are other functions 
available for Custom Calculations in Value Fields. The list below 
shows some of the available options from the  Show Values As 
calculations list.

Function Result

Difference From Displays values as the difference from the value of the 
Base Item in the Base Field.

% Of Displays values as a percentage of the value of the Base 
Item in the Base Field.

% Difference 
From

Displays values as the percentage difference from the 
value of the Base Item in the Base Field

Running Total In Displays the value for successive items in the Base Field 
as a running total.

% of Row Displays the value in each row or category as a 
percentage of the total for the row or category.

% of Column Displays all of the values in each column or series as a 
percentage of the total for the column or series

% of Total Displays values as a percentage of the Grand Total of 
all of the values or data points in the report.

Index
Calculates values as follows:
((Value in Cell) x (Grand Total of Grant Totals)) / 
((Grand Row Total) x (Grand Column Total))

If Summary Functions and Custom Calculations do not provide 
the desired results, you can create your own Formulas in 
Calculated Fields and Calculated Items.

For data that comes from an external data source or from worksheet 
data, Excel uses the Sum function to calculate Value Fields that 
contain numeric data, and the Count function to calculate Value 
Fields that contain text.

You can choose a different summary function like Average, Max 
or Min to further analyze or customize the data.  

Calculated Fields 
and Calculated 
Items,
continued
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When you use Formulas in a PivotTable Report, you must be 
aware of syntax rules and formula behaviors.

 � You can use operators and expressions as you do in 
other worksheet formulas.

 � You can use constants and refer to data from the 
report, however you cannot use cell references or 
defined names.

 � Formulas for Calculated Fields operate on the sum 
of the underlying data for any fields in the formula. 
Therefore, you cannot sort a Calculated Field.

 � Formulas cannot refer to totals.

 � You can include the Field Name in a reference to an 
Item but the Item Name must be in square [ ] brackets.

 � If you refer to an Item by its position in your 
PivotTable Report as it is currently sorted and 
displayed, the Item referred to can change whenever 
the position of the Item changes or is displayed or 
hidden. Hidden Items will not be counted in an index.

 � You cannot add Calculated Items to PivotTable data 
that contains Averages.

 � You cannot add Calculated Items to data that has been 
Grouped. 

Creating a Formula in a PivotTable Report
 � Decide whether you are creating a Calculated Field or 

a Calculated Item within a field. 
 
Use a Calculated Field when you want to use the data 
from another field in your formula. 
 
Use a Calculated Item when you want something 
calculated within a field.

Calculated Fields 
and Calculated 
Items,
continued
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Adding A 
Calculated Item

Adding a Calculated Item to a Field
 � If the Items in the Field are grouped, select the Analyze 

Tab, in the Group Group select [Ungroup].

 � Select the field where you want to place the Calculated 
Item.

 � On the Analysis Tab, in the Calculations Group click 
the [Fields, Items, & Sets] button drop-down and 
choose Calculated Item from the menu. 

 � The Insert Calculated Item in "Field Name" dialog opens.

 � In the Name: field, type a name for the Calculated 
Item.

 � In the Formula: field, enter the formula for the item.

 � The Fields: field list shows all the PivotTable fields. 
The highlighted field in this list is the one having a 
Calculated Item added.

 � The Items: field lists all the items from the selected 
field.

 � To use data from an item in the formula, click the 
Item in the Items: field list, then click [Insert Item] 
button.  The items can only be used in the field that 
is having the Calculated Item added.

 � Click [Add] if you are creating more than one 
Calculated Item.  

 � Click the [OK] button to complete the process and see 
the results.

 � Select any of the new cells and examine the Formula 
Bar.

 � Regroup the items if necessary.

In Calculated Items, 
different formulas 
can be entered cell 

by cell.

Note

A field must be 
actively selected 
in order to add a 

Calculated Item.

Note
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Action 3.4 - Creating a Calculated Item

1. The ConsolidatedSales.xlsx file should 
still be open.

2. In the PivotTable Field pane, drag the 
Sales Reps and Months fields from the 
Filter area to the top of the Rows area.

3. On the Design Tab in the Layout Group, 
click the [Report Layout] button drop-
down and choose Show in Tabular Form 
from the menu.

4. On the Design Tab in the Layout Group, 
click the [Grand Totals] button drop-
down and choose On for Columns Only 
from the menu.

5. On the Design Tab in the Layout Group, 
click the [Subtotals] button drop-down 
and choose Do Not Show Subtotals from 
the menu. 

6. Select the cell with the label Sales, F5.

7. Move the cell over to column D.

8. Select cell F5.

9. On the Analyze Tab in the Calculations 
Group, click the [Fields, Item, & Sets] 
button drop-down and choose Calculated 
Item from the menu.

10. Click into the Name: field and type in- 
 Total Expenses .

If not, re-open it.

You are rearranging the structure of the 
PivotTable.

The layout changes accordingly.

The totals column is removed from the 
PivotTable.

All subtotals are removed.

A heavy board line is displayed around 
the cell.

Set the cursor over the border line of the 
selected cell, the Move Arrow is shown. As 
you click and drag the cell a thick green 
I-beam is displayed that show where the 
content is being moved to.

This cell is in the field you will be adding a 
Calculated Item to.

The Insert Calculated Item in "Financial" 
dialog opens.

This will be the name of the new item in 
the Financial field.
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11. Click into the Formula: field and type 

 =sum(  then in the Items: field select 
Operational Expenses and click the [Insert 
Item] button then type a , and 
in the Items: field select Product Cost and 
click the [Insert Item] button 
Type a  )  . 

12. Click the [OK] button.

13. Select cell H5.

14. On the Analyze Tab in the Calculations 
Group, click the [Fields, Item, & Sets] 
button drop-down and choose Calculated 
Item from the menu.

15. Click into the Name: field and type in- 
 Bonus Earned .

16. Click into the Formula: field and type 
 =if(  then in the Items: field select Income 
and click the [Insert Item] button then 
type a  >2000),  and 
in the Items: field select Income and click 
the [Insert Item] button then 
type a  *.05,0) .

17. Click the [OK] button.

18. Rename the Income and Sales column 
headers as Net Profit and Gross Sales.

19. Save the file.

This formula will add the two expense 
columns of data. 

When completed the formula should read 
=sum(Operational Expenses,Product 
Cost)

The new item is added into the Financial 
field. If you select any cell containing a 
value in the new range, you can see the 
formula in the Formula Bar.

You will be adding another item to this 
field.

The Insert Calculated Item in "Financial" 
dialog opens.

This will be the name of the new item in 
the Financial field.

This formula will determine if a bonus was 
earned and the value of that bonus.

When completed the formula should read 
=if(Income>2000,Income*.05,0)

The new item is added in the Financial 
field.

Click into each of the headers cells and 
type new names.

[Ctrl S].

Action 3.4 - Creating a Calculated Item, continued
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Adding A 
Calculated Field

Adding a Calculated Field
 � Select any cell in the PivotTable Report.

 � On the Analyze Tab in the Calculations Group, click 
on [Fields, Items, & Sets] button drop-down and 
choose Calculated Field from the menu.

 � The Insert Calculated Field dialog opens.

 � In the Name: field, type a name for the field.

 � In the Formula: field, enter the formula for the field.

 � To use data from another field in the formula, select 
the field in the Fields: field list, then click [Insert 
Field].

 � If you are creating more than one field click the 
[Add] button.

 � Click the [OK] button to complete the process and see 
the results.

 � To temporarily remove a Calculated Field from the 
PivotTable, uncheck the checkbox in the PivotTable 
Field pane.
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Instructions: Results/ Comments:

Action 3.5 - Creating a Calculated Field

1. The ConsolidatedSales.xlsx file should 
still be open.

2. Select any cell in the PivotTable.

3. On the Analyze Tab in the Calculations 
Group, click the [Fields, Item, & Sets] 
button drop-down and choose Calculated 
Field from the menu.

4. Click into the Name: field and type in- 
 Expense Reduction .

5. Click into the Formula: field and type 
 =  then in the Fields: field select Value 
and click the [Insert Field] button then 
type a  -(,  and in the Fields: field, select 
Value and click the [Insert Field] button 
and type  *.03)  .

6. Click the [OK] button.

7. Notice there is now a Sum of Expense 
Reduction for each item in the Financial 
field.

8. Click the Financial field filter drop-down 
and uncheck every item in the list except 
Operational Expenses.

9. Right-click any cell with a value in the 
Sum of Value column and choose Value 
Field Settings... from the menu.

10. Click into the Custom Name: field and 
type 
 Current Expenses .

11. Click the [Number Formats] button. 

If not, re-open it.

To add a Calculated Field you just need to 
be in the PivotTable.

The Insert Calculated Field dialog opens.

This will be the name of the new field.

This formula will calculate what the desire 
expense value will be.

When completed the formula should read 
=Value-(Value*.03)

The new field is added to the PivotTable.

This filed runs the calculation on each item 
in the field.

Limiting the data being displayed in the 
PivotTable.

The Value Field Settings dialog opens.

This will be the name given to this column 
of data. 

The Format Cells dialog opens.
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Action 3.5 - Creating a Calculated Field, continued

12. Choose the Currency category and click 
the [OK] button twice.

13. Right-click any cell with a value in the 
Sum of Expense Reduction column 
and choose Vale Field Settings... from the 
menu.

14. Click into the Custom Name: field and 
type 
 Target Expenses .

15. Click the [Number Formats] button. 

16. Choose the Currency category and click 
the [OK] button twice.

17. Examine the PivotTable data.

18. In the PivotTable Field pane, uncheck the 
Expense Reduction field.

19. Click the Financial field filter drop-down 
and check the (Select All) checkbox.

20. Save the file.

The currency format and name are applied 
to the column. 

The Value Field Settings dialog opens.

This will be the name given to this column 
of data. 

The Format Cells dialog opens.

The currency format and name are applied 
to the column.

You are seeing a very specific subset of 
information based on a mix of original and 
calculated data. 

The Target Expenses field is removed from 
the PivotTable.

All the items in the Financial field are re-
displayed.

[Ctrl S].



Excel 2019: PivotTable Features, Rel. 1.0, 02/21/2020 Page 93

Lesson 3: Advanced Features of PivotTables

Editing 
Calculated Items 
Or Fields

Calculated Items and Fields may need to be modified or 
corrected. This is done by opening the Calculated Items or Fields 
dialog and choosing the calculation to be edited.

Editing Calculated Items
 � Select the a field , any field will work since you can 

choose the field in the dialog.

 � On the Analyze Tab in the Calculations Group, click 
the [Fields, Items, & Sets] button drop-down and 
choose Calculated Item... from the menu.

 � The Insert Calculated Items in "Field Name" dialog opens.

 � Click the Name: field drop-down and choose the item 
to be edited.

 � Click into the Formula: field and edit the formula as 
needed.

 � Click the [OK] button to apply the edit.

Deleting Calculated Items
 � Select a field.  Any field will work since you can choose 

the field in the dialog.

 � On the Analyze Tab in the Calculations Group, click 
the [Fields, Items, & Sets] button drop-down and 
choose Calculated Item... from the menu.

 � The Insert Calculated Items in "Field Name" dialog opens.

 � Click the Name: field drop-down and choose the item 
to be deleted, then click the [Delete] button.

 � Click the [OK] button to apply.
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Editing 
Calculated Items 
Or Fields,
continued

Editing Calculated Fields
 � With any cell in the PivotTable actively selected.

 � On the Analyze Tab in the Calculations Group, click 
the [Fields, Items, & Sets] button drop-down and 
choose Calculated Field... from the menu.

 � The Insert Calculated Field  dialog opens.

 � Click the Name: field drop-down and choose the item 
to be edited.

 � Click into the Formula: field and edit the formula as 
needed.

 � Click the [OK] button to apply the edit.

Deleting Calculated Items
 � Set the a field.  Any field will work since you can 

choose the field in the dialog.

 � On the Analyze Tab in the Calculations Group, click 
the [Fields, Items, & Sets] button drop-down and 
choose Calculated Item... from the menu.

 � The Insert Calculated Items in "Field Name" dialog opens.

 � Click the Name: field drop-down and choose the item 
to be deleted, then click the [Delete] button.

 � Click the [OK] button to apply.
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Instructions: Results/ Comments:

Action 3.6 - Editing Calculations

1. The ConsolidatedSales.xlsx file should 
still be open.

2. Select any column field header cell in the 
PivotTable.

3. On the Analyze Tab in the Calculations 
Group, click the [Fields, Item, & Sets] 
button drop-down and choose Calculated 
Item... from the menu.

4. Click the drop-down of the Name: field 
and select Bonus Earned from the list.

5. Click into the Formula: field and change 
the value of 2000 to 1500.

6. Click the [OK] button.

7. Select any cell in the PivotTable.

8. On the Analyze Tab in the Calculations 
Group, click the [Fields, Item, & Sets] 
button drop-down and choose Calculated 
Field... from the menu.

9. Click the drop-down of the Name: field 
and select Expense Reduction from the list.

10. Click the [Delete] button.

11. Click the [OK] button.

12. Save the file.

If not, re-open it.

To edit a Calculated Item you must first 
have a field actively selected; Gross Sales, 
Net Profit , Operational Expenses, or 
Product Cost.

The Insert Calculated Item in "Field Name" 
dialog opens.

The list of all existing field calculations are 
shown in the list. Choosing one of these 
will show the name and formula in the 
appropriate fields of the dialog.

To lower the threshold to earn a bonus.

The edit is applied to the item.

When editing Calculated Fields, any cell 
in the PivotTable can be selected.

The Insert Calculated Field dialog opens.

The field details area displayed in the 
dialog.  At this point the field can be edited 
or deleted.

The field is removed.

The field is no longer listed in the 
PivotTable Field pane.

[Ctrl S].
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Changing the Order
If you are not getting the results that you expected, you can 
change the order in which the calculations are performed for your 
Multiple Calculated Items. 

 � Click on a cell inside your PivotTable.

 � On the Analyze Tab in the Calculations Group, click 
the [Fields, Items, & Sets] button drop-down and 
choose Solve Order.

 � Select a formula from the list, click on the [Move Up] 
or [Move Down] button to change the calculation 
order.

Displaying Formulas
To display or view all the formulas that you are using in your 
PivotTable do the following:

 � On the Analyze Tab in the Calculations Group, click 
the [Fields, Items, & Sets] button drop-down and 
choose List Formulas.

 � A new worksheet listing the Solve Order and 
Calculations used in the current PivotTable is created.

Solve Order 
and Displaying 
Formulas
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Instructions: Results/ Comments:

Action 3.7 - Solver Order and Viewing The Calculations

1. The ConsolidatedSales.xlsx file should 
still be open.

2. Select any field cell in the PivotTable.

3. On the Analyze Tab in the Calculations 
Group, click the [Fields, Item, & Sets] 
button drop-down and choose Solve 
Order... from the menu.

4. Select the second formula in the Solve 
Order: field list.

5. Notice that the [Move Up] button is now 
active.

6. Click the [Close] button without making 
any changes to the current order.

7. On the Analyze Tab in the Calculations 
Group, click the [Fields, Item, & Sets] 
button drop-down and choose List 
Formulas from the menu.

8. Examine the new worksheet.

9. Save the file.

If not, re-open it.

The Calculated Item Solve Order dialog 
opens.  This dialog shows all calculated 
items used in the PivotTable.

Choosing one of the formulas in the  list 
will activate the [Move Up] or [Move 
Down] buttons.  Rearranging the order 
of the formulas can change results if the 
items are used in other formulas.

The dialog closes, there was no need to 
change anything in this instance.  

A new worksheet is added to the 
workbook with detailed information about 
the solve order and formulas in use.

[Ctrl S].
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Lesson Overview

You will cover the following concepts in this 
chapter:

Excel 2016: PivotTable Features
Rel. 1.0, 12/21/2020

Lesson 4: Creating and 
Modifying PivotCharts

 � PivotCharts

 � Inserting PivotCharts

 � Filtering PivotCharts

 � Formatting PivotCharts



Lesson Notes
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Lesson 4: Creating and Modifying PivotCharts

Once you have created the PivotTable, you can create a 
PivotChart to help better visualize the data.  PivotCharts are 
always based on PivotTables, in other words it is possible to 
have a PivotTable without a PivotChart but not a PivotChart 
without a PivotTable.  

Creating a PivotChart can be done straight from the source data 
using the charting tools, PivotTable and PivotChart Wizard, or it 
can be created once the PivotTable has been setup.  If you filter 
either of these related objects the changes are reflected in the 
other.

A PivotChart is not unlike a regular chart, in that you have 
access to the Chart Design and Formatting Tabs, chart control 
buttons in the chart (minus the [Filtering] button), as well as 
the chart elements formatting pane.  Although, since it is a 
PivotChart you will also have an Analyze Tab and similar filter 
tools as the PivotTable.  

 

PivotCharts

When you create 
a PivotChart from 

scratch, a corresponding 
PivotTable is 
automatically created.

Note

Value Field Name Legend (Columns) Field  
Filter Drop-down

Chart Element and 
Format tools

Axis (Row) Field  
Filter Drop-downs

Expand & Collapse Fields Buttons
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Creating a PivotChart from the Source data
 � Select any cell in a structured data set. (Just like the 

data set used to create a PivotTable) 

 � On the Insert Tab in the Charts Group click the 
[PivotChart] button.

 � The Insert PivotChart dialog opens.

 � This dialog is the same as the dialog when inserting  
PivotTables using the [Insert PivotTable] button.

 � You will define the data range the PivotTable and 
PivotChart will be based on.

 � You will also decide where the PivotTable and 
PivotChart will be placed within the workbook.

 � When the [OK] button is clicked a blank PivotTable 
and PivotChart are placed.

 � Now you will use the PivotTable Field pane to move 
the fields into the PivotTable and subsequently the 
PivotChart also.

Inserting 
PivotCharts
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Lesson 4: Creating and Modifying PivotCharts

Inserting 
PivotCharts,
continued

Creating a Chart Based on an Existing PivotTable

 � Select a cell in the PivotTable. 

 � On the Analyze Tab  in the Tools Group click the 
[PivotChart] button. 

 � The Insert Chart dialog opens.

 � Choose the type of chart most suited to your data 
and click [OK]. 

 � The new PivotChart is placed onto the same worksheet 
as the PivotTable that it is based on. 

Chart Types Not Support as PivotChart

X Y Scatter Map Stock
Treemap Radar Sunburst

Histogram Box & Whisker Waterfall 
Funnel

The [F11] key will 
still create a new 
chart on its' own 

worksheet, since the 
source is a PivotTable 
the new chart will be a 
PivotChart. This will use 
the default chart type 
and formatting.

Note



Excel 2016:  PivotTable Features, Rel. 1.0, 12/21/2020
Lesson 4:  Creating and Modifying PivotCharts, Page  104

Instructions: Results/ Comments:
From the data files folder.

The Create PivotChart dialog opens.

Excel has expanded the range to include all 
connected data.

This ensures the new PivotTable 
and PivotChart will be on a separate 
worksheet.  (Remember it is not possible to 
have a PivotChart without a PivotTable.

The new worksheet is added and the are 
both, a blank PivotTable and PivotChart 
with all the pivoting tools active.

Notice the tabs and tools available to 
manipulate it, a mix of the charting and 
pivoting tools

As the fields are placed into pivot areas 
both the table and chart reflect the 
changes.

Whatever changes are made to the chart 
are reflected in the table.

Whatever changes are made to the table 
are reflected in the chart.

[Ctrl S] and [Ctrl W].

Action 4.1 - Creating a PivotChart From Source data

1. Open the ShippingPivotChart.xslx file.

2. Select any cell within the data set.

3. On the Insert Tab in the Charts Group, 
click the [PivotChart] button.

4. In the Rang/Table: field, the range 
should read Invoices!$A$1:$K$2156.

5. The New Worksheet radio button should 
also be selected. 

6. Click the [OK] button.

7. Activate the PivotChart by clicking into 
the chart area.

8. In the PivotTable Field pane, drag- 
Country into Filter 
Salesperson into Axis (Categories) 
Quantity and Sales into Values

9. In the PivotChart, click the Country filter 
drop-down and select any country from 
the list.  Click the [OK] button to apply 
the filter.

10. In the PivotTable, click the Country filter 
drop-down and choose All.  Click the 
[OK] button to apply the filter.

11. Save and Close the file.



Excel 2016:  PivotTable Features, Rel. 1.0, 12/21/2020 
Lesson 4:  Creating and Modifying PivotCharts, Page  105

Instructions: Results/ Comments:

Action 4.2 - Creating a PivotChart From a PivotTable

1. The ConsolidatedSales.xlsx file should 
still be open.

2. Select any cell in the PivotTable on 
Sheet1.

3. On the Analyze Tab in the Tools Group, 
click the [PivotChart] button.

4. In the Insert Chart dialog choose the 
Column category and click the [OK] 
button.

5. Select the PivotChart and notice the tabs 
and tools available to manipulate it.

6. On the Analyze Tab in the Actions 
Group, click the [Move Chart] button.

7. Choose the New sheet: radio button and 
click the [OK] button.

8. Save the file.

If not, re-open it.  Use the 
ConsolidatedSalesCompleted.xlsx 
workbook if the other has been closed 
without saving.

The Insert PivotChart dialog opens. 

Take a moment to look at the charts types 
that can be used. When done the chart 
is placed on the same worksheet as the 
source.

The tools are a mix of the charting and 
pivoting tools.  The same relation between 
the table and chart exists as in the pervious 
exercise.

The Move Chart dialog opens.  Notice there 
are many of the same tools as the Analyze 
Tab in a PivotTable.

A new worksheet named Chart1 is added 
with a full size chart.  It is also removed 
from the original location.  

[Ctrl S].
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Filtering 
PivotCharts

Once the PivotChart has been created, it is time to take 
advantage of its filtering capabilities to better understand 
trends in the data.   Filtering in a PivotChart offers the same 
functionality as in a PivotTable: value and label filters, sorting, 
and slicers are available.  

Using Field Filter Drop-downs
 � Select the PivotChart.

 � In the PivotChart Field pane drag the field into the 
PivotChart areas.

 � Notice the names of the areas have changed- 
Rows are now referred to as Axis 
Columns are now referred to as Legend

 � The field filter buttons are added to the PivotChart.

 � If you do not see the buttons added to the chart, 
they are currently hidden.

 � To unhide them, go to the Analyze Tab and click 
the [Field Buttons] drop-down and uncheck Hide 

all.

 � From this drop-down, you are able to turn on and 
off specific field filter buttons.  This allows you 
more control over how the data is filtered.
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Lesson 4: Creating and Modifying PivotCharts

Filtering 
PivotCharts,
continued

Adding Slicers and Timelines
Both the slicer and timeline slicer work as they do in a 
PivotTable, so this will be very familiar.  These elements offer 
another way to control what level of access users will have in 
modifying the PivotChart.  It is important to note that slicers can 
only be added when the PivotChart is on the same worksheet as 
the PivotTable.

 � Select the PivotChart on the same sheet as the 
PivotTable.

 � On the Analyze Tab in the Filter Group, click the 
[Insert Slicer] button.

 � The Insert Slicer dialog opens.

 � Chose the field you want to add  and click the [OK] 
button.

 � The slicers are added and the Slicer Tools Options 
Tab is accessible on the ribbon.  Allowing you to apply 
formatting to the slicer. 

When you have added a slicer object to a PivotChart you will 
be able to see what the they are connected to with the Filter 
Connections.

 � On the Analyze Tab in the Filters Group click the 
[Filter Connections] button.

 � The Filter Connections dialog opens.

 � Unchecking a connection disables the slicer object but 
does not remove it from the worksheet. 

If the majority of 
tools are not active 
on the PivotChart 

Analyze Tab, the 
PivotChart is on its own 
worksheet.

Note
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Instructions: Results/ Comments:

Action 4.3 - Adding a Slicer

1. The ConsolidatedSales.xlsx file should 
still be open.

2. Click into the PivotChart on the Chart1 
worksheet.

3. Examine the Analyze Tab.

4. Right click the tab and choose Delete 
from menu.

5. In the Delete Worksheet dialog, click the 
[Yes] button.

6. Select any cell in the PivotTable on 
Sheet1.

7. On the Analyze Tab in the Tools Group, 
click the [PivotChart] button.

8. In the Insert Chart dialog choose the 
Column category and click the [OK] 
button.

9. Examine the Filter Group in the Analyze 
Tab.

10. On the Analyze Tab in the Filter Group, 
click the [Insert Slicer] button.

11. Choose Sales Reps and click [OK].

12. Choose one to the salespeople buttons in 
the slicer.

13. Click into the chart.

If not, re-open it.

All of the Filter Group tools are greyed 
out.  The tools are not available since the 
PivotChart is not on the same worksheet 
as the PivotTable.

The Delete Worksheet dialog opens.

The Chart1 worksheet is deleted.

The PivotTable Tabs are now active.

The Insert Chart dialog opens.  

A chart is added to the existing worksheet 
with the PivotTable.

Since this chart is on the same worksheet as 
the PivotTable, the Filter Group tools are 
available.

The Insert Slicer dialog opens, showing the 
list of all available fields.

The Sales Rep slicer is added to the 
worksheet.

Both the chart and table reflect the filtering 
choice.

The Chart Tabs are now available.
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Instructions: Results/ Comments:

Action 4.3 - Adding a Slicer, continued

14. On the Analyze Tab in the Actions 
Group, click the [Move Chart] button. 

15. In the Move Chart dialog select the New 
Worksheet radio button and name the 
worksheet; 
Chart2  
and click the [OK] button.

16. On the View Tab in the Windows Group, 
click the [New Window] button.

17. On the View Tab in the Windows Group, 
click the [Arrange Windows] button.

18. Choose Tiled and click the [OK] button.

19. Activate Sheet 1 and zoom out to make 
the slicer and table visible.

20. Click a different salesperson button in 
the slicer.

21. Save the file.

The Move Chart dialog opens.

The chart is moved to it's own worksheet.

A new window of the workbook is created.

The Arrange Windows dialog opens.

There are two windows of the workbook 
displayed side by side.

Now both worksheets are visible.

As the slicer is modified, both the 
PivotTable and PivotChart are still 
modified.  This is because the chart was 
first created on the same worksheet as the 
PivotTable.

[Ctrl S].
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Formatting 
PivotCharts

As with regular charts, when the chart is active the  PivotChart 
Design and Format Tabs are available along with the Analyze 
Tab. 

Both the Design and Format Tabs are consistent with regular  
chart tools.  The Analyze Tab offers the same tools as in the 
PivotTable.  

When the PivotChart is actively selected, you will have access to 
the [Chart Elements] and [Chart Styles] button at the upper left 
corner of the chart.  Since this is a PivotChart the [Chart Filter] 
button is not available.

Design Tab

Analyze Tab

Design Tab

Chart Elements

Chart Styles
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Lesson 4: Creating and Modifying PivotCharts

Formatting 
PivotCharts,
continued

Using the Format Shape Dialog Box
An alternative to using the tools on the Format Tab, is to use 
the Format Selection pane.  Right-clicking a chart element and 
choosing Format (Element Name) from the menu will open the 
Format Selection pane on the right side of the interface. The 
Format pane can also be accessed by clicking on the [Format 
Selection] button on the Format Tab.  The options in the Format 
Selection pane will change based on the selected element in 
the PivotChart.  You can use the words at the top, or the icons 
below those, or the index below the icons to select the different 
elements you wish to affect.

While this Format Selection pane is open, other elements in the 
PivotChart can be formatted as they are selected.  You may keep 
the Format Selection pane open and simply click on an element 
to format, make changes, then select the next element to format.  
When all the elements have been formatted, you can close the 
pane since all formatting has been completed.

This drop-down allows you to choose 
what element is being formatted

These are the type of formatting tools: Fills 
& Lines, Effect, Size & Properties

This is the formatting control area, these 
change according the active formatting tools.
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Instructions: Results/ Comments:
1. The ConsolidatedSales.xlsx file should 

still be open.

2. Activate the Chart2 window and click 
the [Maximize] button in the upper right 
corner of the window.

3. Right-click anywhere in the chart on the 
Chart2 worksheet.

4. Choose Format ... form the menu.

5. Locate the Element Selector drop-down 
below the Format... title and click on it.  

6. From the list of options, choose Plot Area.

7. Click the Fill & Lines icon.

8. Expand the Fill options.

9. Click the Picture or texture fill radio 
button.

10. Below the [Insert] button is the Texture 
drop-down.  Click it and choose the 
White Marble image.  

11. Once an image or texture is placed, use 
the Transparency slider to make it  semi-
opaque.

12. From the Element Selector drop-down, 
choose Vertical (Value) Axis.

If not, re-open it.

This window is now full screen.

You may see a wide variety of elements to 
format, choose any that are available.  The 
Format .... pane opens.

This lists any chart editable elements, this 
list will vary depending to the chart type.

The Plot Area formatting options are 
displayed in the Format pane.

It looks like a paint bucket.  The Fill & Line 
formatting options are displayed.

The Fill options are displayed.

Those controls are now displayed.  You 
can now add logos or other types of 
imagery

These basic textures are part of the 
program.  You can choose any of these.

Creating a very nice washed out 
background image.

The Format pane now offers all controls to 
related to the selected element.

Action 4.4 - Formatting PivotChart Elements
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Instructions: Results/ Comments:
It looks like a small three column chart.

Here, you are now able to set the axis 
scale as well as the  major & minor lines as 
needed. 

Nothing changes yet because the Minor 
Gridlines are not currently displayed.

The major gridlines are now 4000 intervals.

This is the small + located in the upper 
right corner of the chart.

The minor gridlines are now added to the 
chart, but are not very easily seen.

This button must be clicked to display 
the options and then clicked to hide the 
options.

The formatting controls of the minor 
gridlines are displayed.

Line formatting controls are displayed.

The minor lines are now more clearly 
displayed.

Repeat steps 20 to 22 in relation to the 
Major Gridlines.

You can continue to explore formatting 
other chart elements to practice further.  
[Ctrl S] and [Ctrl W].

13. Click the Axis Options icon.

14. Expand the Axis options.

15. Change the Minor units to 1000.

16. Change the Major Units to 4000.

17. Click anywhere in the chart and then 
click the [Chart Elements] button.

18. In the Gridlines fly-out menu, check the 
Primary Minor Horizontal checkbox.  

19. Click the [Chart Elements] button again 
to collapse the options.

20. In the Format pane, choose Vertical (Value) 
Axis Minor Gridlines.

21. Click the Fill & Lines icon and expand 
the Lines options.

22. Choose Black from the Color Picker and 
in the Width field, set the value to 1.25.

23. Try changing the Vertical (Value) Axis 
Major Gridlines to Black with a width of 
1.5.

24. Save the file and close all open windows.

Action 4.4 - Formatting PivotChart Elements
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You will cover the following concepts in this 
chapter:
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Lesson 5: Creating 
PivotTables from 
External Data

 � Get Data from a CSV File

 � Power Query

 � Editing a Query



Lesson Notes
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Lesson 5: Creating PivotTables from External Data

There are many instances where the required data is stored 
outside of Excel.  Beginning with Excel 2016 you can use the Get 
& Transform tools to connect to and query data sources.  These 
new tools allow you to use Power Query to bring data into Excel. 
These tools are accessed from the Data Tab in Excel.

Data source types include:
 � CSV or Text file

 � Excel tables or cell ranges

 � Other Excel files

 � Web pages where the data is stored in tables

 � SQL servers

 � ODBC (Open Database Connectivity)

 � Access Databases

 � XML files

 � Sharepoint

 � Azure

 � Oracle

 � OLE DB (Object Linking and Embedding Database)

 � JSON files

 � Analysis Services

 � Exchange

 � Active Directories

 � Facebook

 � Teradata
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One common way data is extracted from a database and given 
to users is with CSV (Comma Separated Value) files.  These CSV 
files are simple plain text documents, as such they can contain 
vast amounts of data with relatively small file sizes.  Power 
Query automatically detects delimiters and established columns 
based on those delimiters, first rows are also as headers of the 
columns. 

Connecting to CSV files

 � Activate the Data Tab in the ribbon.

 � In the Get & Transform Group, click the [From Text/
CSV] button.

 � The Import Data dialog opens, allowing you to search 
for the necessary files. 

 � Once the file has been selected and opened, the 
Navigator window opens.

Get Data from a 
CSV File
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Lesson 5: Creating PivotTables from External Data

 � The Navigator window shows a preview of the data 
to be imported.  If there are multiple sheet, pages, or 
tables in the source,  it also allows you to choose what 
table or sheet of data to connect to.

 � If the data is clean and ready to use, then you can 
click the [Load] button drop-down. 

 � Choosing Load will import the data as a table 
directly into the active cell on the active worksheet.

 � Choosing Load To from the drop-down allows you 
to decide how the data will be imported.  You can 
choose as a Table , PivotTable Report, PivotChart, 
or simply to Create the Connection. 

Get Data from a 
CSV File,
continued



Lesson 5: Creating PivotTables from External Data 

Page  120 Excel 2019: PivotTable Features, Rel. 1.0, 02/21/2020

Should the data need further editing in order to pull in only what 
is required, clicking the [Transform Data] button in the Navigator 
window will open the Power Query window.  This workspace 
allows users to remove unnecessary columns, split columns into 
more meaningful data, change data types, and basically further 
refine the dataset to you specifications.  

Using Power Query
 � While in the Navigator window, click the [Transform 

Data] button to open the data in Power Query Editor.

 � This  window can be expanded to full screen.  It uses 
the same ribbon navigation system as in Excel and the 
other Office programs. 

 � The Query Setting pane on the right side shows each 
step you take, you are able to modify any of those steps 
as needed.  You can undo, redo, modify a step, and 
even rearrange the steps order.

 � Once the data has been modifies to suit your needs, 
on the Home Tab use the  [Close & Load] button drop-
down to Load or Load To, just as in the Navigator 
window.

Power Query
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Lesson 5: Creating PivotTables from External Data

Power Query,
continued

Managing Columns

The Power Query Editor allows you to bring in only the necessary 
columns from a data source. To select columns continuously, 
select the first column and hold the Shift key as you select 
the last desired column.  For non-continuous selections, select 
the first columns then hold the Ctrl key as you select each 
subsequent column.  Once the wanted or unwanted columns 
are selected, use the [Remove Columns] button drop-down in 
the Manage Columns Group on the Home Tab.  You will also 
find tools that allow you to control rows in a similar fashion as 
columns.

Split a Column
It is not uncommon to find a single column of data needs to be 
broken into several.  The [Split Column] button offers an easy 
solution to the problem.  You are able to define how or where the 
data is to be divided: use a set number of characters,  a delimiter, 
case, or digit. 

 � Select the column to be split.

 � Click the [Split Column] button drop-down.

 � Choosing By Delimiter opens the Split Column by 
Delimiter dialog.
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Power Query,
continued

 � In the Split Column by Delimiter dialog, you can choose 
from standard delimiters or use a custom one found in 
the data.

 � Once the columns have been generated, it is a good 
idea to rename them accordingly.

 � Select the column header cell. 

 � Right-click the cell; choose Rename from the menu.

 � Type the appropriate name and tap the Enter key.

Sorting & Filtering Data
 � Select the column containing data to be sorted by or 

filtered.

 � Click the drop-down in the header cell.

 � Use the tools in the drop-down as you would in any 
table filter drop-down.
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Instructions: Results/ Comments:

5.1 - Getting Data from A CSV File

1. Open a blank new workbook.

2. Activate the Data Tab.

3. In the Get & Transfrom Group, click the 
[From Text/CSV] button.

4. Navigate to the lessons folder and choose 
the ShippingBase.csv  file, click the 
[Import] button.

5. Examine the options in the Navigator 
window.

6. Click the [Load] button drop-down and 
choose Load to.

7. Select the PivotTable Report and Existing 
worksheet radio buttons, then click the 
[OK] button.

8. In the Pivottable Fields pane set: 
Salesperson field in Rows, 
Country in Filter, 
Sales in Values.

9. Add a new worksheet.

10. Save the file as MyQuery.xlsx.

Ctrl N.

The Import Data dialog opens.

The Navigator window opens.

The second Import Data dialog opens.

A blank PivotTable is added in cell A1 of 
Sheet1.

The PivotTable now displays data.

Click the [New Worksheet] button beside 
the sheet tab.

Ctrl S.
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Instructions: Results/ Comments:

5.1 - Getting Data from A CSV File, continued

1. Activate the Data Tab.

2. In the Get & Transfrom Group, click the 
[From Text/CSV] button.

3. Navigate to the lessons folder and choose 
the ShippingBase.csv  file, click the 
[Import] button.

4. Click the [Transform Data] button.

5. Examine the interface of the Power Query 
Editor.

6. On the left side of the interface, click the 
[Expand] button below the ribbon.

7. The data is shown in a tabular format.

8. On the right side of the interface is the 
Query Settings pane.

The Import Data dialog opens.

The Navigator window opens.

The Power Query Editor window opens.

There is a tabbed navigation system in the 
ribbon.

A list of existing queries is displayed. 
Clicking the [Expand] button will now 
collapse the Queries pane.

There is a formula bar above the 
spreadsheet, as in Excel.  Each cell in the 
header row has a Sorting and Filtering 
drop-down.

This pane shows which query is active and 
any steps that have been applied to it.
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Instructions: Results/ Comments:

5.2 - Editing the Query

1. Select the Required Date and Shipped Date 
columns.

2. On the Home Tab, click the [Remove 
Columns] button drop-down and choose 
Remove Columns.

3. Select the Quantity column.

4. On the Home Tab, click the [Data Type] 
button drop-down and choose Decimal 
Number from the list.

 

5. Select the Unit Price column.

6. On the Home Tab, click the [Remove 
Columns] button drop-down and choose 
Remove Columns.

7. In the Query Setting pane, set your cursor 
over the last of the applied steps and 
click the X.

8. Select the Order Date column.

9. On the Home Tab, click the [Split 
Column] button drop-down and choose 
By Delimiter from the menu.

10. Click the Select or enter delimiter drop-
down and choose Custom.  

11. In the new blank field type in a  
/ 
set the Split at radio button to Each 
occurrence of delimiter and click [OK].

Use the Ctrl or Shift keys to select 
multiple columns.

The columns are removed from the table 
and a new step has been added in the 
APPLIED STEPS area of the Query Settings 
pane.

You will change the data type of the 
column to decimal number.

The data type is now formatted as a 
decimal number; the formatting will be 
applied and visible when imported into 
Excel.

This is a mistake and needs to be 
corrected.

The last step is removed from the list, and 
the column is put back in place.

This column needs to split into three.

The Split by delimiter dialog opens.

A new blank filed is added; you can type 
in any character to use as the delimiter.

This character separates the day, month, 
and year in the date.  Since we want a 
column for each, choosing Each occurrence 
of delimiter option allow the column to be 
broken into three in one pass.
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Instructions: Results/ Comments:
12. Right-click the first of the new column 

headers, choose Rename from the menu.

13. Type in: 
Month 
and tap the Enter key.

14. Rename the other new columns as Day 
and Year.

15. Click the filter drop-down of the 
Salesperson column header.

16. Uncheck the (Select All) checkbox, then 
check the checkboxes for first three 
names in the list.

17. On the Home Tab, click the [Close & 
Load] button drop-down and choose 
Load to.

18. Select the Table and New worksheet radio 
buttons, then click the [OK] button.

19. Save the file.

The header name is highlighted and ready 
to be changed.

The column is renamed.

Repeat steps 12 and 13 respectively.

Sorting and filtering controls are displayed 
in the menu.

Only records for these three reps will be 
imported. 

The second Import Data dialog is opened.

A new table is placed on Sheet3.  Notice 
the salesperson column only has the three 
selected names and the order date column 
is divided into the three desired columns, 
and the unit cost column is formatted with 
decimal numbers.

Ctrl S.

5.2 - Editing the Query
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Editing a Query After the data has been imported and tables or PivotTables 
created from the data, it may be necessary to go back and make 
further changes to the existing query.  This is done from the Data 
Tab in Excel.  The Queries & Connections pane lists all existing 
queries and allows you to jump to the data based on the selected 
query.

Accessing the Queries
 � Open a workbook with data based on a query.

 � Activate the Data Tab.

 � In the Queries & Connections Group click the 
[Queries & Connection] button.

 � The Queries & Connections pane opens.

 � Clicking one of the connections will jump you to where 
the data is being used in the workbook.

 � Hovering over a connection bring up a preview of the 
query and options related to the query.

Right-click the 
connection to access 
options related to the 

selected connection.

Note
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 � Choosing Edit from the bottom of the preview will 
reopen the query in Power Query Editor.

 � All the previous APPLIED STEPS are listed and 
fully editible. 

 � You have full control to continue making changes 
to the query.

 � Whatever changes are made will be reflected in 
the table or PivotTable in excel when the [Close & 
Load] button is clicked.

Editing a Query,
continued
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Instructions: Results/ Comments:

5.3 - Re-Editing the Query

1. MyQuery.xlsx should still be open.

2. Activate the Data Tab.

3. In the Queries & Connections Group, 
click the [Queries & Connections] 
button.

4. Scroll over the two connections.

5. Click the first connection.

6. Click the second connection.

7. Click the [Edit] button at the bottom 
of the preview window of the second 
connection.

8. Click the X’s to remove the last several 
steps to the point the order date column 
is no longer split.

9.  Click the [Close & Load] button.

10. Save and close the file.

If not, re-open it.

The Queries & Connections pane opens or 
closes on the right side of interface, set it 
to open.

As you hover over the connection, a 
large preview window appears.  The 
preview shows a snapshot of the data 
and connection related tools to edit, 
load, duplicate, merge, append, access 
the connection properties, or delete the 
connection.

You should be taken to the PivotTable on 
Sheet1. 

You should be taken to the table on Sheet3.

The Power Query Editor window opens.  
Notice that all the step are still listed in 
the APPLIED STEPS section of the Query 
Settings pane. Right-click the connection 
will also allow you to edit the query.

Step back to remove the Split by Delimiter 
step.

If the drop-down menu appears, choose 
Load.  The data in the table is reloaded and 
refreshed on the Excel spreadsheet.

Ctrl S and Ctrl W.
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Lesson Overview

You will cover the following concepts in this 
chapter:
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Appendix A

 � Unlocking a Slicer

 � Custom Slicer Styles

 � Creating Custom PivotTable Styles

 � Using Custom PivotTable Styles
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 Appendix A

Unlocking a Slicer in a Protected Worksheet
 � Select the slicer(s) you wish the user to be able to  

manipulate.

 � Right-click on a slicer and select Size and Properties... 
from the shortcut menu.

 � The Format Slicer pane opens on the right side of the 
screen.

 � Expand the Properties section and deselect the check 
box next to Locked.

 � Click into the worksheet to deselect the Slicer(s).

 � Click the Review Tab. In the Changes group, click on 
the [Protect Sheet] button.

 � Click on the checkbox to Allow all users of this 
worksheet to: Use PivotTable & PivotChart.

 � Click on the checkbox to Allow all users of this 
worksheet to: Select unlocked cells.

Unlocking a 
Slicer
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There are different ways to format your Slicers so that the user 
can see what values have been selected and applied.  Using 
the New Slicer Style item from the Slicer Styles Gallery on 
the Slicer Tools Options Tab, you can change the way a button 
appears when hovered over or selected.

 � Select the Slicer you would like to affect, or choose one 
and press [Ctrl + A] to select all of the Slicers.

 � Click the Options Tab. Click on the [More] button on 
the Slicer Styles  Gallery.

 � Select New Slicer Style.

 � Type in an appropriate name for your Slicer Style in 
the Name: text box.

 � In the New Slicer Style dialog, select one of the Slicer 
Elements in the list.

 � Click on the [Format] button and select the formatting 
you would like to apply to that Element.

 � Repeat the previous steps for all of the Slicer Elements 
you would like to change.

 � To reuse the Slicer Style you just created, click on it in 
the Custom section of the Slicer Style Gallery. 

Custom Slicer 
Styles
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Some of the items that can be changed in a Slicer Style are:
 � Header - This is the Field Name at the top of the 

Slicer.

 � Selected Item with Data - This is a value in the 
Slicer that is selected and has associated data in the 
PivotTable, and therefore, the PivotChart.

 � Selected Item with no Data - This is a value in the 
Slicer that is selected and does not have associated data 
in the PivotTable and PivotChart.  For example, if you 
filter the PivotTable and PivotChart to show data for 
a certain month, but there were no sales of the selected 
Product on the Slicer in that month.

 � Unselected Item with Data - This is a value in the 
Slicer which has corresponding data within the filter 
criteria, but has not yet been selected in the Slicer.

 � Unselected Item with no Data - It is helpful to format 
this element when you wish to see items that do not 
have corresponding data within the filter criteria.  
Using the example above, you may format this element 
if you would like to see which Products do not have 
sales in that month before you even select them.

 � Hovered Selected Item with Data - This is a value in 
the Slicer that has already been selected.  However, 
you may wish to also see a format change when you 
pass your mouse pointer over the value.

Custom Slicer 
Styles,
continued
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Custom Slicer 
Styles,
continued

 � Hovered Selected Item with no Data - This is a value 
that has been selected in the Slicer that does not 
have corresponding data in the PivotTable and/or 
PivotChart.  When you pass your mouse pointer over 
this value, you may want to see a change in format.

 � Hovered Unselected Item with Data - Change this 
element when you want a different format when you 
Pass your mouse pointer over a value that has not 
been selected, but does have corresponding data in the 
PivotTable and/or PivotChart.

 � Hovered Unselected Item with no Data - Change the 
format of this element when you wish to emphasize, on 
hover, buttons which do not have corresponding data 
in the PivotTable.  This way you can see which items 
will not produce a result when selected.
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Creating a Custom PivotTable Style
 � Click on any cell in the table to display the Design Tab 

on the Ribbon. 

 � In the PivotTable Styles Gallery, click on the [More] 
button.

 � At the bottom of the Styles gallery, click on New 
PivotTable Style. This will open the New PivotTable 
Style dialog box.

 � In the Name: text box, type an appropriate name for 
your PivotTable style.

 � Use the Table Element: list to select an element of the 
PivotTable, then click on the [Format] button to open 
the Format Cells dialog box.

 � In the Format Cells dialog box, click on one of the tabs 
to change the Font, Border, or Fill for that element.

 � Click the checkbox to Set as default PivotTable quick 
style for this document if you wish all PivotTables in 
the current workbook to have this style.

Notice that your changes will show in the Preview 
window of the New PivotTable Style dialog box.

 � Once you have made all of your selections, click [OK] 
to close the dialog box. 

Creating Custom 
PivotTable Styles

To rename the 
PivotTable itself, use 
the PivotTable Name 

text box in the PivotTable 
Tools Analyze Tab.

Name text 
box

Set as 
default 
checkbox

To open the 
Format dialog 
box

Preview
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Applying a Custom PivotTable Style
 � Click on any cell in the PivotTable.

 � Select your custom PivotTable Style from the Custom 
section at the top of the PivotTable Styles Gallery.

Modifying a Custom PivotTable Style
 � Click on any cell in the PivotTable.

 � Right-click on your custom PivotTable Style in the 
Custom section of the PivotTable Styles gallery.

 � Select Modify.

 � When the Modify PivotTable Style dialog box opens, 
make the appropriate changes by, once again, selecting 
the Table Element: and then clicking on the [Format] 
button.

 � Click [OK] when you have completed the 
modifications.

Creating Custom 
PivotTable 
Styles,
continued

You can set any 
PivotTable quick 
style from the 

PivotTable Styles 
Gallery as the default 
style by right-clicking 
on it and selecting Set 
As Default.

Once created, your 
custom PivotTable 
style will not be 

applied automatically. 
You must click on it in the 
gallery to apply it.
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Using Custom 
PivotTable Styles

Using a PivotTable Style in Another Workbook
 � Select the PivotTable in the originating workbook with 

the style you would like to use.

 � Copy it.

 � Paste it into the workbook where you would like to use 
the PivotTable Style.

 � Click on the PivotTable and create a New PivotTable 
Style using the New PivotTable Style menu item from 
the PivotTable Style Gallery.

 � Click the checkbox at the bottom of the New PivotTable 
Quick Style dialog box to Set as default PivotTable 
quick style for this document.

 � Delete the PivotTable from which you copied the style.
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 � Eliminating Leading and Trailing 
Spaces

 � Removing Blank Rows and Columns in 
Your Data

Lesson Overview

You will cover the following concepts in this 
chapter:
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Appendix B



Troubleshooting 
Data 

Leading and Trailing Spaces
Sometimes the data being used for your PivotTable does not 
summarize correctly.  One reason for this is that there may be 
extra spaces in the data itself.  This can happen when the data is 
imported from another database or application.  Excel treats a 
space as a character, therefore, this data is considered separate 
pieces of information even though it looks the same in the 
spreadsheet. This issue can be resolved with the Trim function.

The TRIM Function
In the datasheet, click into a blank cell or create a “dummy” 
column to create the formula.

 � Type =TRIM(reference cell)

 � Fill the formula down to the rest of the cells in the 
column.

 � Copy the cells just created.

 � Paste the values back to the original column.

 � Refresh the PivotTable.

Selecting Blank Rows/Columns for Elimination
 � Click on the Home Tab, then select the [Find & Select] 

button in the Editing group.

 � Click on Go To Special... to open the Go To Special 
dialog box

 � Select the Blanks option button and click [OK].
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Troubleshooting 
Data,
continued

 � Delete the cells using the Delete (cells) dialog box from 
the [Delete] button on the Home Tab.

Press [Ctrl + -] to 
open the Delete 

(cells) dialog box.
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Tips and Notes



You will cover the following concepts in this 
chapter:

Excel 2019: PivotTable Features
Rel. 1.0, 02/21/2020

Appendix C: Creating 
PivotTables from 
External Data - 2016

 � Importing Data from External Data 
Sources

 � Importing External Data Using the 
PivotTable Tool

 � Creating a PivotTable from an Access 
Object

 � Importing Data Using Microsoft 
Query Connection



Lesson Notes
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It is often the case that the data you need for your Excel 
PivotTable is stored in a database application or other files. 
Database applications are great for managing, maintaining, 
and retrieving large amounts of data. Database programs also 
provide features for defining relationships between data entities, 
for developing queries to extract information, and for securing 
sensitive information. For these reasons and more, organizations 
often make extensive use of databases.

Excel allows you to import data from a number of external 
sources. Moreover, the imported data can be linked to the source, 
so that any changes to the underlying source data tables can be 
refreshed and updated in your Excel worksheets.

The Microsoft Office suite provides drivers that will allow Excel 
to connect to a wide array of data sources.

Some of the data sources that you can connect to with Excel are:
 � Microsoft SQL Server

 � SQL Server Analysis Services Cube

 � Microsoft Access and Microsoft FoxPro

 � ODBC DSN

 � OLAP Services and OLAP cubes

 � dBase 

 � Oracle 

 � Paradox 

In this lesson, we will discuss three different methods of 
importing external data into a PivotTable.

 � Using the Insert PivotTable tool

 � Using the From Access Object tool

 � Using the Microsoft Query Connection

The advantages of each are discussed in their respective sections.  

Connections to external data in the current workbook can be 
viewed and refreshed with the [Connections] button in the 
Connections Group on the Data Tab.  

In a PivotTable or PivotChart, external connections can be 
refreshed using the [Refresh] button on the Analyze Tab.

Importing Data 
from External 
Data Sources

 A driver is 
software that 

helps programs 
communicate with 
each other without 
knowing the 
precise details of 
the program being 
accessed.
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Creating a PivotTable from External Data Using the 
PivotTable Tool
The advantage of creating the External Data Connection from 
the PivotTable tool is efficiency.  By using the Create PivotTable 
dialog box, you can create the connection and the PivotTable 
simultaneously.

 � Select the Insert Tab and click the down arrow on the 
[PivotTable] button.

 The Create PivotTable dialog box will be displayed.

 � Click the Use an External Data Source option button.

 � Click the [Choose Connection...] button.

 � When the Existing Connections dialog box appears, 
select an item from the list and click [Open].

- OR -
 � Select [Browse for More...] to select a database not 

yet connected.

Importing 
External Data 
Using the 
PivotTable Tool

Saved Microsoft 
Queries Area

Previously 
made connec-
tions Area
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 � Once you have selected the database, click [Open].

 � Depending on the external data source you have 
chosen, you may be asked for login credentials 
(a username and password) or other verifying 
information.  If so, enter the appropriate information 
in the fields provided and click [OK].

 � You will be returned to the Create PivotTable dialog box 
to continue making your selections.

 � When you click [OK], the PivotTable will be created.  
You will see the PivotTable area and PivotTable Field 
List Task Pane as before, but now the field headings 
in the PivotTable Field List are from the external data 
source that you have selected.

 � Once you build a PivotTable using external data, you 
can refresh the table by clicking the Refresh button 
on the Data Tab. You may also use the [Refresh] 
button on the PivotTable Tools Analyze Tab or 
the PivotChart Analyze Tab.  This will update the 
PivotTable with any changes made to pertinent data in 
the source database.

The connection you have created will be listed in the 
Existing Connections dialog box located on the Data Tab in 
the Connections Group for future use.

Importing 
External Data 
Using the 
PivotTable Tool,
continued
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Instructions: Results/ Comments:

Action 5.1 - Creating a PivotTable from External Data Using the  
PivotTable Tool

 1.  Open a blank workbook.

 2.  Select the Insert Tab.

 3.  From the Tables group, select the 
[PivotTable] button.

 4.  Select the Use an external data source 
option button.

 5.  Click [Choose Connection...].

 6.  Click the [Browse for More...] button.

 7.  From the exercise files folder, select the 
MultipleCriteria.accdb file.

 8.  Click [Open].

 9.  From the list of available tables in 
the Select Table dialog box, choose the 
Products table.

 10. Click [OK], then click [OK] again 
to close the Create PivotTable dialog 
box. 

 11. Drag CategoryID to the Rows area.

 12. Drag SupplierID to the Columns area.

 13. Click on the checkbox for 
UnitsInStock.

 14. Save the file in your Student Folder 
with the name Products PivotTable 
and close the file.

This will open an Explorer window to 
allow you to browse for the database file.

This will open the Select Table  dialog box 
which lists all of the tables and queries 
available to import. 

This will create a PivotTable frame and 
show a PivotTable Field List with fields 
from the Products table.
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PivotTables can also be created from Access database objects 
using the Data Ribbon.  Just like a linked spreadsheet, the data in 
the PivotTable is also linked to the data in the Access database.

The advantage to using this method is that Excel only looks for 
Access data, making it easier to browse for the source file.

The disadvantage to using this method is that this method does 
not add the connection to the existing connections for future use.

Using the Data Ribbon
 � Display Excel’s Data Ribbon.

 � In the Get External Data group, click the [From 
Access] button.

 � The Select Data Source dialog box will be displayed.

 � Select the Access database that will serve as the source 
of the data.

 � Click the [Open] button.

Creating a 
PivotTable from 
an Access Object

It is a good idea 
to run advanced 
queries in the 

database program and 
then connect to the 
resulting query or table.
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 � If the Access database being used has multiple tables 
or queries, the Select Table dialog box will be displayed.

 � Choose the table or query that contains your source 
data.

 � Click the [OK] button. 

 � The next step is to use the Import Data dialog box to 
select how you want to view the imported data in 
Excel. 

 � Click the [Properties] button in the Import Data dialog 
box to see the Connection Properties dialog box.

Creating a 
PivotTable 
from an Access 
Object,
continued

 If the Access 
database has only 
one table, the Select 

Table dialog box will not 
appear.

If you miss this 
step, you can 
also access the 

[Properties] button from 
the Connections group 
on the Data Tab
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 � In this box you can enable or disable settings for 
connections to external data sources, and use, reuse or 
switch connection files.

 � The Usage tab is used to control the way that the 
connection information is used in the workbook.

 � If you put a check by Refresh data when opening 
the file, the table data will be refreshed from the 
database when you open the Excel workbook. 

 � You can also specify how much time should pass 
between refreshes with the Refresh every check 
box. 

 � The Definition tab controls how the connection 
information is defined and the source of the connection 
information.

 � When everything is set the way you want, click 
[OK] to implement the changes and return to the 
Import Data dialog box.

 � When you have selected the PivotTable Report or 
PivotChart option button in the Import Data dialog 
box, click the [OK] button.

Creating a 
PivotTable 
from an Access 
Object,
continued
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Here is the original data from the Access database.

Here is a PivotTable report based on imported data from the 
database.

 � If you right click on the table you created in Excel, and 
click the Refresh option from the pop up menu that 
appears, the data in your Excel table will be updated 
with any changes made to the source data in the 
database.

Creating a 
PivotTable 
from an Access 
Object, 
continued



Excel 2019:  PivotTable Features, Rel. 1.0, 02/21/2020 
Appendix C:  Creating PivotTables from External Data - 2016, Page  C11

Instructions: Results/ Comments:

Action 5.2 - Creating a PivotTable and PivotChart from Access Data

 1.  Open a blank workbook.

 2.  Select the Data Tab.

 3.  From the Get External Data group,  
select the [From Access] button.

 4.  Select the MultipleCriteria.accdb 
database from your exercise files folder, 
click [Open].

 5.  In the Select Table dialog box, select 
Orders and click [OK].

 6.  In the Import Data dialog box, select 
[PivotChart]. 

 7.  In the Where do you want to put the data? 
area, make sure Existing Worksheet is 
selected and the range in the text box is 
[$A$1]. 

 8.  Click [OK].

 9.  The PivotChart and PivotTable frames 
will appear on the worksheet and the 
PivotChart Fields will appear on the 
right-side of the worksheet.

 10.  Click on the PivotChart frame.

 11.  In the PivotChart Fields Task Pane 
select ShipCountry and drag to Axis 
(Categories).
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Instructions: Results/ Comments:

Action 5.2 - Creating a PivotTable and PivotChart from Access Data,  
continued

 12.  Then drag ShipRegion and 
ShipPostalCode from the PivotChart 
Fields Task Pane into the Axis 
(Categories) under ShipCountry.

 13 . Drag Freight into the Values area.  

 14.  In the Values area, click on the drop-
down arrow next to Sum of Freight 
and select Value Field Settings....

 15.  Select the [Number Format] button. 

 16.  When the Format Cells dialog box 
opens, select Accounting to format the 
field. 

 17.  Click [OK] to close the Format Cells 
dialog box, and then click [OK] again 
to close the Value Field Settings dialog 
box.

 18.  In the PivotChart Fields Task Pane, 
drag the ShipPostalCode out of the 
Axis fields (Categories) box. 

 19.  In the PivotChartTools, click the 
Design Tab. In the Chart Layouts 
group, select [AddChartElment] and 
trace to Data Table and then select No 
Legend Key.

This will start to populate the PivotChart 
and the PivotTable with the items that you 
have selected and you will begin to see 
how the data is going to display.

Notice that the PivotChart which, is 
displayed, does not display very useful 
information at this point. We will make 
changes to display the information we 
need.

Notice that the PivotTable changes to 
show totals by Country and Region and 
a Grand Total is at the bottom of the 
PivotTable.
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Instructions: Results/ Comments:

Action 5.2 - Creating a PivotTable and PivotChart from Access Data, continued

 

 
 20.  Save the file as My PivotChart.xlsx and 

close the file.
A table containing the amounts for each 
region appears below the horizontal axis.

The resulting PivotTable and PivotChart should look like this:
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The Microsoft Query Connection allows you to import data 
from any Microsoft Application while filtering the data.  The 
advantage of using this method is that the data that is imported 
fits a specific criteria and you do not end up with data you 
cannot use or that has to be deleted. In addition, any connection 
established using this method is added to the Existing 
Connections list and can be used in future data retrieval. 

 � Select the  Data Tab.

 � From the Get External Data group, click the [From 
Other Sources] drop-down arrow.

 � A menu is displayed with a number of options for 
connecting to an external data source. 

The bottom option in this menu, Microsoft Query, is a 
powerful tool that will allow you to create a connection 
and build a query.  A query is a way to extract specific 
information from a database.

Importing 
Data Using 
Microsoft Query 
Connection
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 � Once you have selected From Microsoft Query from 
the [Other Sources] button, you will see the following 
dialog box. You will be creating an ODBC connection to 
the database.

 � The <New data source> option should already be 
selected.

 �  Click [OK], 

 � The Create New Data Source dialog box displays.

 � Type a name for your data source.

 � Click the drop-down to select a driver type for the new 
data source.

 � Click the [Connect] button to establish a connection.  

ODBC stands for Open 
Database Connectivity. 
This is a utility used to 

define a connection between a 
computer and a database. The 
ODBC connection contains 
information needed to allow 
a computer user to access 
the information stored in a 
database that is not located 
on the local computer. 

Importing 
Data Using 
Microsoft Query 
Connection, 
continued
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 � Click on the [Select] button

 � Browse to the location of the database and select the 
database you want to connect to. Click [OK].  

 � You may be asked at this point to provide login 
credentials for the data source. Enter your login 
credentials and click [OK].

 � Once this named connection is created, the Query 
Wizard-Choose Columns dialog box will open to 
allow you to choose the tables and the columns of 
information that you can include in your query.

Importing 
Data Using 
Microsoft Query 
Connection, 
continued
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Importing 
Data Using 
Microsoft Query 
Connection, 
continued

 � Select the table you want to include in your query by 
clicking on the [Expand] button, [ + ]. Then, select the 
column of data you want to include in your query. 
Press the [ > ] to move your selection into the Columns 
in your query box.

 � When you have selected all the columns you want to 
include in your query, click [Next] 

 � The Query Wizard - Filter Data dialog box is displayed. 
You can filter the data to extract specific information.

 � Select from one of your Column to filter: and in the Only 
include rows where: drop-down use the search criteria to 
build your filter.

 � Once you have made all of your selections, click [Next].

 � The Query Wizard - Sort Order dialog box will open and 
offer you the option to sort your selected data. Select 
the drop-down under Sort by and choose Ascending or 
Descending.

 � Once you have completed your selections, click [Next].
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Importing 
Data Using 
Microsoft Query 
Connection, 
continued

 � The final step is the Query Wizard - Finish dialog 
box which offers you the options to Return Data 
to Microsoft Excel or View Data or Edit Query in 
Microsoft Query if you want to make any changes, 
and Save Query if you are going to use the query 
again. 

 � Name the query if you are going to save it. You will 
see in the background the information the query is 
extracting from the table. Click [Save].

 � If you are selecting the option to Return Data to 
Microsoft Excel, Click [Finish].
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Importing 
Data Using 
Microsoft Query 
Connection, 
continued

You will now see the Import Data dialog box offering you 
the import options for your data, Click [OK].

Your Query data will then appear in an Excel worksheet 
based on your selections in the dialog box.

Excel table created from imported data
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Instructions: Results/ Comments:

Action 5.3 - Importing From External Data

 1.  Open a blank workbook.

 2.  Select the Data Tab.

 3.  From the Get External Data group, 
click the [From Other Sources] button.

 4.  Select From Microsoft Query.

 5.  Make sure <New Data Source> is 
selected and click [OK].

 6.  In the Create New Data Source dialog 
box, type Test for the name of the Data 
Source.

 7.  From the Select a driver for the type of 
database you want to access: drop-down 
list, select [Microsoft Access Driver 
*.mbd, *.accdb].

 8.  Under Click Connect and enter any 
information requested by the driver:, click 
[Connect]

 9.  In the ODBC Microsoft Access Setup 
dialog box, under Database, click 
on [Select] and browse to select the 
database ShippingDatabase.accdb.

 10.  Click [OK] to close the Select Database 
dialog box.

 11. Then, click [OK] in the ODBC Microsoft 
Access Setup dialog box to return to the 
Create New Data Source dialog box.

 10.  Under Select a Default Table for Your Data 
Source (optional) select the drop-down. 

 11.  Do not make a selection.  Click [OK].

Offers options of connecting to a variety 
of databases to obtain information for 
analysis.

The Choose Data Source dialog box will 
open. 

This ensures the necessary filter is used for 
Excel to interpret the data coming from the 
type of database you are connecting to.

Here, you can see the existing Access 
objects in this file from which you can 
extract information.
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Action 5.3 - Importing From External Data, continued

The Query Wizard – Choose Columns dialog 
box will open and display the Available 
Tables and Columns you can select to add to 
the Columns in Your Query to be imported 
into your Excel workbook.

The Query Wizard – Filter Data dialog box 
will open and offer you the ability to filter 
the data imported by criteria you select. 

The Query Wizard-Sort Order dialog box is 
displayed.

The Query Wizard - Finish dialog box is 
displayed.

 12.  You may be prompted with a Login 
Credentials dialog box.  If so, select 
[OK].

 13.  Click [OK] to close the Choose Data 
Source dialog box.

 

 14.  Click the [+] to expand the 
CompanyNames table.

 15.  Select CompanyName and click the  
[ > ] arrow to move it into the Columns 
in your query: box. 

 16.  Repeat steps 14 and 15 to move 
OrderID, Order Date and Quantity.

 17. Click [Next].

 18.  Select Quantity in the Column to filter: 
box, then select the drop-down under 
Quantity to Only include rows where: 
and choose is greater than or equal to. 
Select 20.0 from the next drop-down. 

 19. Click [Next].

 20.  Select [Next] to skip the Query Wizard-
Sort Order step.
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Instructions: Results/ Comments:

Action 5.3 - Importing From External Data, continued

 21.  At this point, Return Data to Microsoft 
Excel should be selected in the Query 
Wizard-Finish dialog box.

 22.  Click the [Save Query] button and 
name the query Shipping Quantity 
Over 20. Then click [Save].

 23.  Click [Finish] in the Query Wizard-
Finish dialog box.

 24.  Select PivotTable Report in the Select 
how you want to view this data in your 
workbook.

 25.  Click [OK] to place the PivotTable 
frame in the existing worksheet 
starting at cell A1.

 26.  Drag Company Name to the Rows 
area.

 27.  Drag Quantity to the Values area.

 28.  Save file as External Query.xlsx.

We will save the query so that we can  
re-run it if necessary.

The Import Data dialog box will open.

Your Pivot Report 
should look similar 
to this:
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