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Welcome to the Excel 2013 Pivot Tables course. This manual and 
the data files are designed to be used for learning, review and 
reference after the class.  The data files can be downloaded any 
time from The Computer Workshop website: 

http:\\www.tcworkshop.com
There is no login or password required to access these files.  You 
will also find handouts and supplementary materials on the 
website in the Download section.

To Download Data Files

Once on The Computer Workshops website, look at the bottom 
of any page to find the link Download.  Clicking this link opens 
the Download page where you can choose either Data Files or 
Handouts.  

1.	 Data Files opens a list of general application types. 
2.	 Click once on the Microsoft Office Courses link.
3.	 Click once on the software related to the course.
4.	 Click once on the version related to the course.
5.	 If there are multiple folders, click on the TCW folder.
6.	 Click on the course name to download the data files.

You can choose to open or save the zipped folders content to 
your computer.  

The handouts are in PDF format and also available to you 
without login or password.  Simply open the PDF and either 
print or save to your computer.

Using this 
Manual
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Conventions Used in this Manual

The hands-on exercises (Actions) are written in a two-column 
format. The left column (“Instructions”) gives numbered 
instructions, such as what to type, keys to press, commands 
to choose from menus, etc.  The right column (“Results/
Comments”), contains comments describing results of, reasons 
for, quick keys, etc. for the instructions listed on the left.

�� Key names and Functions are bold and enclosed in 
square brackets:

		  [Enter], [Tab], [F5], [F10]

�� Keys you press simultaneously are separated by a plus 
(+) sign, typed in bold and enclosed in square brackets. 
You do not press the plus.

		  [Shift + F5]

�� Keys you press in sequence are separated by a space, 
bold and enclosed in square brackets.

		  [Home] [Down Arrow]

�� Ribbon tab names are in bold and italic:  Example:  
Home 

�� Group names are in bold:  Example:  Font

�� Dialog box names are in italic:  Example: Save As

�� Button names are bold and enclosed in square 
brackets:  Example:  [Sort]

�� Information you are to type will be in bold. Example:

This is the first day of the rest of your life.

�� Information that you need to supply will be indicated 
with pointed brackets.   Example: Type:  <your name>.

	

Conventions



Lesson Overview

You will cover the following concepts in this 
chapter:

Excel 2016: Pivot Table Features
Rel. 1.0, 10/25/2017

Lesson 1: Creating and 
Modifying PivotTables

�� Creating PivotTables

�� Modifying the PivotTable View

�� Formatting PivotTables

�� Refreshing PivotTables

�� Creating Custom PivotTable Styles



Lesson Notes
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Lesson 1: Creating and Modifying PivotTables

PivotTables A PivotTable is a powerful tool for exploring and analyzing 
information. A PivotTable can help you organize and manipulate 
the raw data in your spreadsheet, giving you insight into 
patterns or relationships that might not be obvious at first 
glance. PivotTables also give you the power to view your data 
in a different context without changing the original content or 
structure. 

You can base a PivotTable on data in your current workbook or 
even external data from another source. 

With a PivotTable, you can conveniently drag and drop columns 
of data into different areas of the table to examine relationships 
or trends that may not be obvious in a traditional Excel table or 
database. 

In short, PivotTables enable you to organize your data in 
meaningful ways without doing a lot of tedious work. You could 
say that a PivotTable is like several data tables rolled into one.

Below is a sample of a typical PivotTable.

Guidelines for Data in a PivotTable
�� The data you wish to include in your PivotTable should 

be in a tabular format.

�� The source data should have a row of unique column 
headings.

�� There should be no gaps in the data, no blank columns 
or rows.  Excel treats groups of data as a database.  
Gaps indicate a break in the data and are considered 
the end of the database.  
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Creating 
PivotTables

Selecting Fields for the PivotTable

To make the best use of your PivotTable, you should understand 
what the various areas in a PivotTable are for.

You can see by examining an empty PivotTable Frame that a 
PivotTable is broken into four main areas:

Row labels 
These are fields that you want to group.  When you add a field 
to the Row labels area of the Field List Task Pane, you will 
see unique values extracted or filtered from these fields.  Some 
examples of Row labels are product names, company names, 
locations or business units.

Column labels
These are fields that show trends of data.  For example, you may 
want to put fields that show periods, phases, time, months or 
years here.

Values
This area on the PivotTable contains the data to be reported or 
analyzed.  This data normally has numeric values associated with 
it, such as units sold, profit, or expenses.  This type of data can be 
measured and calculated.

Report filter
The Report Filter should include items that you want to filter.  
For example, you may want to filter regions, periods, business 
units, or employee names.

Defer Layout Update
At the bottom of the Field List Task Pane is the option to 
postpone the PivotTable update.  This turns off the Live Preview 
setting so that you don't have to wait for the screen to show 
potential changes.  Once you have made a change or selection, 
click the [Update] button to apply the changes.

To sort the 
Field List in the 
Task Pane in 

alphabetical order, use 
the [Options] button on 
the PivotTable Tools 
Analyze Tab. At the 
bottom of the Display 
Tab choose the sort 
order using the radio 
buttons.
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Creating  
PivotTables,
continued

Creating a PivotTable
�� Click into the range of data that you want to base the 

table on. 

�� Select the Insert Tab  and click the 
[PivotTable] button to display the Create 
PivotTable dialog box.

�� Choose the data you want to analyze by clicking the 
option button for either Select a table or range or 
Use an external data source. If you choose the table 
or range option, The PivotTable will be based on the 
Excel table or range that includes your selection. 

	If the range that appears is incorrect, you may type 
it in or select it with your mouse.  Make sure that the 
column headings are included.

	If you choose the External Data Source option, 
you can base your PivotTable on data outside your 
current workbook (such as in another workbook or 
perhaps an external database). If you select the Use an 
External Data Source option button, you will be able to 
display a drop-down list of existing connections in the 
Connection Name: field. A typical existing connection 
could be a Microsoft Query or a connection you 
previously made to an Access database for some other 
purpose. 

Ideally, source data 
for a PivotTable 

should be structured like 
a traditional Excel table or 
database. See the guidelines 
on page 3.

continued on next page
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�� Select whether to locate your PivotTable in an Existing 
Worksheet or a New Worksheet. If you choose to 
locate it in an existing worksheet, you can specify the 
starting cell location for the upper left corner of the 
PivotTable by entering it directly into the Location: data 
field, as a cell reference, or by clicking the target cell 
with your mouse. 

If you choose the New Worksheet option, your 
PivotTable will be located in cell A1 of a new 
worksheet that will be added to your workbook.

�� Click the [OK] button to create your PivotTable. 

�� A PivotTable Field List will be placed in the same 
worksheet as your PivotTable.

�� Add information to your PivotTable by placing 
check marks in the boxes next to the headings in the 
PivotTable Field List. The PivotTable will then be 
populated with the selected data.

In the example below, you could put checks next to 
the Order Date field heading, the Product Name field 
heading, and the Extended Price field heading to total 
the amount for each product by date. 

Creating  
PivotTables,
continued

Double-clicking 
a cell in the 
PivotTable 

generates a sheet 
that shows the 
data details that 
contributed to that 
number.

Note:  To get this view, you will need to 'right-
click' on the PivotTable and Select 'PivotTable 
Options' from the list. Then click the 'Display'  tab 
and choose 'Classic PivotTable Layout (enables 
dragging of fields in the grid)'. Click OK.
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Showing More Than One Value Calculation
If you want to show both the sum and the average of the values 
in the PivotTable at the same time, do the following:

�� Add a second instance of the field containing your 
values to the Values Field of the PivotTable.

�� Click the arrow on the second instance and choose 
Value Field Settings.  

�� From the dialog box, choose the Average function. 

�� Click [OK].

Now you have the values both being summed and averaged 
simultaneously.  This can be revised in the Field Settings dialog 
box to any function or combination of functions needed.

Creating  
PivotTables,
continued
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Modifying the 
PivotTable View

You can also create a PivotTable by creating an empty table 
frame, also known as the Classic Layout, and adding and 
arranging data in the table by dragging and dropping fields onto 
the frame.

Using the Classic Layout
�� Open the spreadsheet containing the data you want to 

work with.  

�� Select the range of data on which you want to base the 
PivotTable. 

�� Select the Insert Tab and click the [PivotTable] button 
to display the PivotTable dialog box. 

�� Select your choices in the Create Pivot Table dialog 
box. Make sure the Data Range is correct and choose 
a location for the table (New Worksheet or Existing 
Worksheet).

�� Click the [OK] button when you are ready.

�� Before adding data to the PivotTable, right-click on 
it and choose PivotTable Options from the shortcut 
menu.

	 This will display the PivotTable Options dialog box.
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�� In the Options box, choose the Display Tab. 

�� Click the checkbox before Classic PivotTable layout 
(enables dragging of fields in the grid). 

�� Click [OK].

This will change the PivotTable into a classic PivotTable 
frame. If you are already working with a classic 
PivotTable frame, you can clear this checkbox to convert it 
to an Excel 2016 style PivotTable.

Below, you can see an empty PivotTable frame enhanced 
with blue borders. Beside it, to the right, you can see the 
PivotTable Fields. 

�� From the PivotTable Fields, drag the Field Names to 
the appropriate area on your PivotTable.

The order in which you drag them will determine which 
field will be appear first, second, etc.  You can re-order 
the fields by selecting and dragging them within the field 
area.

By default, fields that are dropped into the Value Fields 
area will sum if there are no blanks in the data. If any 
value areas in the original data are left blank, Excel 
considers this text, rather than a value, and the default 
calculation will be to count. You can change this option as 
you will learn later in this chapter.  

Modifying the 
PivotTable View,
continued
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Instructions:	 Results/ Comments:

Action 1.1 - Creating a PivotTable and Arranging Data in the  
Classic Layout

	 1. 	 Open the workbook named Shipping.
xlsx from your exercise files folder.

	 2. 	 Click anywhere in the data on the  
Invoices sheet.

       
	 3. 	 Select the Insert Tab and click 

the [PivotTable] button. 

	 4. 	 Verify that the Select a table or range 
option button is chosen and the correct 
range is entered in the Table/Range 
field.

	 5.	 Make sure that the New Worksheet 
option button is selected.

 

	 6. 	 Click the [OK] button to create the 
PivotTable. 

                  
	

	 7.	 Right-click on the PivotTable graphic 
and choose PivotTable Options from 
the shortcut menu.

                               
	 8.	 On the Display tab in the PivotTable 

Options dialog box, put a check in the 
Classic PivotTable layout (enables 
dragging of fields in the grid) 
checkbox. 

	 9.	 Click [OK].  You should now see a 
new PivotTable Frame in the new 
worksheet.

Notice the first row is a set of column 
headings, with one heading for each 
column. (The data set does not contain 
any empty cells.)

The Create PivotTable dialog box is 
displayed. The Table/Range: text box should 
show Invoices!$A$1:$K$2156.

You will see a PivotTable Area and a Field 
List appear in a new worksheet. Notice the 
column headings (fields) available in the 
PivotTable Field List that you can now 
add to the table.

To open the PivotTable Options dialog box.
Do not click outside of the PivotTable or 
PivotTable Frame, or you will deactivate 
the PivotTable and the related Ribbon 
tabs will disappear.

Notice that Country went into the Filters  
area of the PivotTable Field List Pane.
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Instructions:	 Results/ Comments:
	11.	 Arrange the data as follows:

		  - Drag the Country field from the 
PivotTable Field List to the Drop 
Report Filter Fields Here area of the 
PivotTable.

		  - Drag the Salesperson field to the 
Drop Rows Fields Here Area of the 
PivotTable. 

		  - Drag the Product Name field to the 
Drop Columns Here Area of the 
table. 

				  
		  - Drag the Unit Price field to the Drop 

Value fields Here Area of the table.  
Your spreadsheet should look like 
this:

 
12. 	 Save your workbook as MyPivotTable 

in your exercise folder.  

	13.	 Leave the file open.

Salesperson is also in the Row  area of the 
PivotTable Field List.

Product Name is also in the Column  area 
of the PivotTable Field List.

Unit Price is placed in the Values 
area of the PivotTable Field List and 
automatically sums.
 

The [F12] key is the shortcut key for the 
Save As command.

Action 1.1 - Creating a PivotTable and Arranging Data in the  
Classic Layout, continued
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Using the PivotTable Options Dialog Box
�� Click on any cell in the PivotTable to display the 

Analyze Tab in the Ribbon. 

�� On the left side of the Analyze Tab, in the PivotTable 
group, click the [Options] button to display the 
PivotTable Options dialog box.

�� On the Layout and Format tab, make sure the Preserve 
cell formatting on update box is checked. This will 
ensure that any formatting you apply will be retained 
if the table is modified or refreshed.

�� On the Totals and Filters tab, specify if grand totals 
for rows or columns will be shown.

�� On the Display tab, select whether filter drop-downs, 
field captions, expand/collapse buttons, and contextual 
tool tips will be shown.

�� On the Printing tab determine what optional elements 
should print. 

�� On the Data tab, specify PivotTable Data options, 
such as having the table refreshed when the workbook 
opens.

�� Click [OK] when you are finished with the PivotTable 
Options dialog box.

Formatting 
PivotTables

Remember to 
always click into 
the PivotTable 

to see the related 
contextual tabs on the 
Ribbon.
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Using the Design Tab 
�� On the Design Tab, you can click on one of the preset 

styles in the PivotTable Styles Gallery to quickly 
apply preset formatting to the table. 

�� There are also checkboxes in the PivotTable Style 
Options group of the ribbon that will let you turn 
on or off banded columns or rows, row headers, or 
column headers. 

�� On the left side of the ribbon are controls that you can 
use to view or hide subtotals and grand totals and to 
specify the PivotTable Report Layout.

Here is a style with banded columns applied to an existing 
PivotTable. 

Other Formatting Options
If you would like to apply specific formatting to a table that is 
not available as a style, you can always select a range of cells 
from the table and use the buttons on the Home Tab to format the 
selected range. 

Another method is to select a range of cells from the table, right-
click in the selected range, and choose Format Cells from the 
shortcut menu. You can then choose from a series of tabs in the 
Format Cells dialog box that will let you select number formats, 
alignment choices, font styles, borders, fill and protection 
options.

Formatting 
PivotTables,
continued
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�� To format the data values in the PivotTable, right-click 
a cell in the data area of the populated table and select 
the Value Field Settings option from the pop up menu.

�� When you see the Value Field Settings dialog box, click 
the [Number Format] button to view the number 
formatting options.

�� Here, you can select a 
number format from the list 
and click [OK] to return to 
the Value Field Settings dialog 
box. 

�� Click [OK] again to format 
all of the data in the selected 
field of the PivotTable with 
the chosen number format.

The image below shows a PivotTable with the accounting 
number format applied to the data area. Notice also that the 
names of Janet Leverling and Laura Callahan in the row area of 
the table have been formatted in bold by using the [Bold] button 
on the Home Tab.

Formatting 
PivotTables,
continued
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The data in a PivotTable is not linked directly to the source table 
or range. Instead, the PivotTable is based on a hidden copy of 
the source data that is kept in memory by Excel. This is called 
the PivotTable Cache. This means that changes to the original 
source list or database will not be automatically updated in the 
PivotTable. If you make changes in the source data, you must 
Refresh the PivotTable to update it.

Refreshing a PivotTable
�� Select the Data Tab or the PivotTable Analyze Tab

�� Click the [Refresh] button. 

-OR-

�� Right-click on a cell in the data area of the table to 
access the shortcut menu. 

�� Select Refresh.

Here is a range of data and a PivotTable that uses the data range 
as its source. 

If you change the quantity for Nancy Davolio's first entry from 
15 to 500 on the spreadsheet, you will notice no change in the 
PivotTable. (The data in cell J2 has been changed to 500 and the 
Extended Price has re-calculated to $27,500.00 but the PivotTable 
has not changed.)

Refreshing 
PivotTables

[Alt + F5] refreshes 
the PivotTable.
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Here is the same data and PivotTable after it has been refreshed. 
Notice that cell N10 has now changed.

Refreshing 
PivotTables,
continued
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Instructions:	 Results/ Comments:

Action 1.2 - Formatting PivotTable Data

If not, open it from the Student Data 
folder.

To display the shortcut menu as shown 
below.

This will display the Value Field Settings 
dialog box.

You will be returned to the Value Field 
Settings dialog box.

	 1. 	 You should still have MyPivotTable.
xlsx open with the PivotTable showing 
from the previous exercise.

	 2.	 Right-click on the Sum of Unit Price 
heading in the upper left corner of the 
table.

	 3.	 Click the Value Field Settings option 
from the shortcut menu.

	 4.	 Click on the [Number Format] button, 
in the bottom left corner of the dialog 
box.

	 5.	 Choose the Accounting format option 
from the list on the left.  Leave the 
defaults as shown in the figure to the 
right.

	 6.	 Click the [OK] button in the lower right 
of the Format Cells dialog box.
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Instructions:	 Results/ Comments:

Action 1.2 - Formatting PivotTable data, continued

A quick way to do this is to use the 
[Select] button on the Analyze Tab.  
Select the Entire PivotTable.  Then use 
the [Format] button on the Home Tab to 
Autofit Column Width.

[Ctrl+S]

	 7.	 Select Average from the Summarize 
value field by list 

	 8.	 Click [OK].  

	 9.	 Resize the columns so that your 
PivotTable looks like the figure below:

	10.	 Save your file.
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Creating a Custom PivotTable Style
�� Click on any cell in the table to display the Design Tab 

on the Ribbon. 

�� In the PivotTable Styles Gallery, click on the [More] 
button.

�� At the bottom of the Styles gallery, click on New 
PivotTable Style. This will open the New PivotTable 
Style dialog box.

�� In the Name: text box, type an appropriate name for 
your PivotTable style.

�� Use the Table Element: list to select an element of the 
PivotTable, then click on the [Format] button to open 
the Format Cells dialog box.

�� In the Format Cells dialog box, click on one of the tabs 
to change the Font, Border, or Fill for that element.

�� Click the checkbox to Set as default PivotTable quick 
style for this document if you wish all PivotTables in 
the current workbook to have this style.

Notice that your changes will show in the Preview 
window of the New PivotTable Style dialog box.

�� Once you have made all of your selections, click [OK] 
to close the dialog box. 

Creating Custom 
PivotTable Styles

To rename the 
PivotTable itself, 
use the PivotTable 

Name text box in 
the PivotTable Tools 
Analyze Tab.

Name text 
box

Set as 
default 
checkbox

To open the 
Format dialog 
box

Preview
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Applying a Custom PivotTable Style
�� Click on any cell in the PivotTable.

�� Select your custom PivotTable Style from the Custom 
section at the top of the PivotTable Styles Gallery.

Modifying a Custom PivotTable Style
�� Click on any cell in the PivotTable.

�� Right-click on your custom PivotTable Style in the 
Custom section of the PivotTable Styles gallery.

�� Select Modify.

�� When the Modify PivotTable Style dialog box opens, 
make the appropriate changes by, once again, selecting 
the Table Element: and then clicking on the [Format] 
button.

�� Click [OK] when you have completed the 
modifications.

Creating Custom 
PivotTable 
Styles,
continued

You can set 
any PivotTable 

quick style from 
the PivotTable 
Styles Gallery as 
the default style by 
right-clicking on it 
and selecting Set 
As Default.

Once created, your 
custom PivotTable 
style will not be 

applied automatically. 
You must click on it in 
the gallery to apply it.
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Using Custom 
PivotTable Styles

Using a PivotTable Style in Another Workbook
�� Select the PivotTable in the originating workbook with 

the style you would like to use.

�� Copy it.

�� Paste it into the workbook where you would like to use 
the PivotTable Style.

�� Click on the PivotTable and create a New PivotTable 
Style using the New PivotTable Style menu item from 
the PivotTable Style Gallery.

�� Click the checkbox at the bottom of the New PivotTable 
Quick Style dialog box to Set as default PivotTable 
quick style for this document.

�� Delete the PivotTable from which you copied the style.
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Instructions:	 Results/ Comments:

Action 1.3 - Creating a Custom PivotTable Style

	 1. 	 You should still have MyPivotTable.
xlsx open.

	 2.	 Click anywhere in the PivotTable.

	 3.	 On the PivotTable Tools Design tab, 
click on the [More] button on the 
PivotTable Styles gallery.

	 4.	 Select New PivotTable Style... from 
the bottom of the gallery.

	 5.	 In the New PivotTable Quick Style 
dialog box, in the Name: text box, type 
My New PivotTable Style.

	 6.	 Select Whole Table from the Table 
Element:  list.

	 7.	 Click on the [Format] button.

	 8.	 On the Font tab, click the dropdown 
arrow on Color: and select Dark Blue, 
text 2 from the Theme Colors palette. 

	 9.	 On the Border tab, select Outline from 
the Presets.

	10.	 Click [OK].

	11.	 From the Table Element: list, select 
Header Row.

	12.		 Click on the [Format] button.

	13.	 On the Font tab, click on the down 
arrow for Color: and select white.

If not, open it from your Student Data 
Folder.

This will display the New PivotTable Style 
dialog box.

To name your new style.

Notice the Preview window in the New 
PivotTable Style dialog box changes.
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Instructions:	 Results/ Comments:

Action 1.3 - Creating a Custom PivotTable Style, continued

	14.	 On the Fill tab, select the medium blue 
color from the Theme Colors at the top 
of the Color Palette.

	
	15.		 Click [OK].

	16.	 Click [OK] again.

	17.	 On the PivotTable Tools Design 
tab, click the [More] button on the 
PivotTable Styles gallery.

18.		 Select My New PivotTable Style from 
the Custom section at the top of the 
gallery.

	19.	 On the PivotTable Styles gallery, right-
click on My New PivotTable Style and 
select Modify.

	20.	 Select Grand Total Row from the Table 
Element: list.

	21.	 Click the [Format] button.

	22.	 On the Font tab, select Bold Italic from 
the Font Style: list.

	23.	 Click [OK].

	24.	 Select First Column.

	25.	 Click on the [Format] button.

	26.	 On the Fill tab, select the second accent 
color under the orange Theme Color.

	27.	 Click [OK], then click [OK] again.

Notice the Preview window in the New 
PivotTable Style dialog box changes.

The new style is applied to the existing 
PivotTable.

This will open the Modify PivotTable Style 
dialog box.

This will bold and italicize the Grand 
Totals at the bottom of the PivotTable.

This will shade the first column of the 
PivotTable.

Your PivotTable Style modifications are 
applied to the PivotTable.
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�� Filtering a PivotTable

�� Grouping Data in a PivotTable

�� Conditional Formatting in a PivotTable

�� Using Slicers 

Lesson Overview

You will cover the following concepts in this 
chapter:

Excel 2016Pivot Table Features
Rel. 1.0, 10/25/2017

Lesson 2: Filtering & 
Modifying PivotTables 
Fields 



Lesson Notes



Excel 2016: Pivot Table Features, Rel. 1.0, 10/25/2017	 Page 27

Lesson 2: Filtering & Modifying PivotTables Fields 

Filtering a 
PivotTable

One of the main features of a PivotTable is that you have the 
ability to present the data in a dynamic format that allows you 
to show exactly what you need and change it when you need 
to.  For example, if you have a PivotTable that shows Sales 
by Region for each Salesperson, you may want to show only 
specific Salespersons or specific Regions. PivotTables  allow 
you the flexibility to show each Region and/or Salesperson and 
to change which Salesperson or which Region shows at any 
time. 

Filtering a PivotTable
�� Click on the drop-down arrow next to any field name 

in the PivotTable.

Excel will determine what data type the data in the 
column belongs to.  If it is a numerical data type, you 
will see Label and Value filters.  If it is a date data type, 
you will see Date and Value filters.

�� Select the Filter type you would like to use.

�� Complete the information in the Filter dialog box.

A Value filter 
allows you to apply 
a filter to numerical 

data.  A Label filter 
allows you to apply 
a filter to textual data 
referred to in row or 
column labels.

Filter menu for number 
data type

Filter menu 
for Date 
data type



Lesson 2: Filtering & Modifying PivotTables Fields  

Page  28	 Excel 2016: Pivot Table Features, Rel. 1.0, 10/25/2017

Filtering a 
PivotTable,
continued

- OR -

�� Click on the drop-down arrow next to any field name 
in the PivotTable Fields.

�� Select the Filter type you would like to use (Value or 
Label).

�� Select the Filter subtype.

�� Complete the information in the Filter dialog box.



Excel 2016: Pivot Table Features, Rel. 1.0, 10/25/2017	 Page 29

Lesson 2: Filtering & Modifying PivotTables Fields 

Using the Top or Bottom 10
Sometimes you would like to see the Top 10 purchasers of your 
product or the Top 10 salespeople in your organization.  You can 
use the Top 10 filter in the Values Filters to see these results.

To Filter the Top 10
�� Click on the drop-down arrow next to any field name 

in the PivotTable.

�� Trace over Value Filters from the drop-down list.

�� Select Top 10... from the submenu. The following 
dialog box is displayed.

�� In the Top 10 Filter dialog box, select whether or not 
you wish to show the Top or Bottom 10 by clicking on 
the drop-down arrow.

�� If needed, change the number of items being shown by 
using the arrows in the spin box to change the number 
or by selecting the number and typing it in.

�� Finally, select whether you wish to see the Top/Bottom 
10 items or Top/Bottom 10 percent.  

	 Select Sum to display what contributed to the top 
number you selected.  For example if you want 
to see which companies contributed to the top 
$100,000 in sales, enter 100,000 in the number box 
and choose Sum from the drop-down.   

Filtering a 
PivotTable,
continued
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Using Wildcards
When you can only specify a portion of what you are filtering, 
you can use wildcards to replace the missing text.  For example, 
if you wish to search for all names that begin with an M and end 
with a T, you can enter M*T.  The asterisk represents any number 
of characters in that position.  The following wildcards may be 
used in your filters:
			 

Character Definition Example

*

Used to represent 
any number of 
characters in that 
position, including 
zero characters.

M*T will return Matt, mint, 
malt, mutt, most.

?
Represents one 
character in that 
position.

M?T will return mat or met.

~
Searches for 
wildcard characters. Computer~Workshop will 

return Computer*Workshop.

Using Multiple Filters
Sometimes, you may want to apply multiple filters 
simultaneously.  By default, Excel will remove a filter on a field 
when another filter is applied.  To maintain your filters while you 
create additional filters:

�� Right-click any cell in your PivotTable. 

�� Select PivotTable Options.

�� Click the Totals 
and Filters tab 
in the dialog 
box.  

�� Click the 
checkbox for 
Allow multiple 
filters per field.

Filtering a 
PivotTable,
continued
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Instructions:	 Results/ Comments:

Action 2.1 - Filtering a PivotTable

	 1. 	 You should still have MyPivotTable.
xlsx open.

	 2.	 Click on the Filter button drop-down 
arrow next to Product Name in the 
PivotTable.

	 3.	 Choose Label Filters and then trace to 
Begins with... 
 

	 4.	 Click into the text box and type c.

	 5.	 Click [OK].

	 6.	 Right-click on any one of the Product 
Names in the PivotTable.

	 7.	 Trace to Filter, then click on Value 
Filters....

	 8.	 Verify that Average of Unit Price and is 
greater than appears in the Show items 
for which lists. If not, use the drop-down 
arrows to select them. 

	 9.	 Type 40 in the text box.

	10.		 Click [OK].

	11.	 Save the file, but do not close it.

First, you will filter the PivotTable to show 
only those products that begin with a “C”.

The PivotTable will refresh itself and show 
only those products that begin with a “C”.

Next, you will filter the PivotTable to 
show those products with Average Unit 
Prices greater than $40.

The PivotTable will refresh itself and 
show only those products with Average 
Unit Prices greater than $40.
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Instructions:	 Results/ Comments:

Action 2.2 - Filtering the Bottom 10 in a PivotTable

	 1. 	 You should still have MyPivotTable.
xlsx open.

	 2.	 Click the drop-down arrow on the 
[Clear] button in the Analyze Tab.

	 3.	 Select Clear Filters.

	 4.	 Trace over Salesperson in the 
PivotTable Field List.

	 5.	 Click on the down arrow.

	 6.	 Trace to Value Filters and then select 
Top 10... from the submenu.

	 7.	 Change Top to Bottom, using the drop-
down arrow.

	 8.	 Change 10 to 5.

	 9.	 Click [OK].

	10.	 Repeat steps 2 and 3 to clear the filter.

	11.	 Drag Average of Unit Price out of the 
Values area in the PivotTable Field 
List Task Pane.

	12.	 Drag Extended Price into the Values 
area in the the PivotTable Field List 
Task Pane.

If not, open it from the Student Data 
folder.

This will show the Bottom 5 Sales 
performers.



Excel 2016:  Pivot Table Features, Rel. 1.0, 10/25/2017 
Lesson 2:  Filtering & Modifying PivotTables Fields , Page  33

Instructions:	 Results/ Comments:

Action 2.2 - Filtering the Bottom 10 in a PivotTable, continued

	13.		 Change the Value Field Settings for the 
Extended Price to a Currency format.

	14.	 Click on the Filter button for 
Salesperson in the PivotTable.

	15.	 Trace to Value Filters and then select 
Top 10... from the submenu.

	16.	 Change 10 to 500000 (don’t click [OK] 
yet).

	17.	 Change Items to Sum, using the drop-
down arrow.

 18.		 Click [OK].

	

 19.		 Clear the filters again.

	20.	 Save the file, but do not close it.

�� In the Values area of the PivotTable Field 
List Task Pane, click on the down arrow 
next to Sum of Extended Price.

�� From the submenu, select Value Field 
Settings.  

�� Click on the [Number Format] button 
(bottom left corner of the dialog box). 

�� Under Category, choose Currency. 

�� Click [OK]. Click [OK] again.

This will show all of the the Products 
and Salespeople that contributed to the 
company’s top $500,000 in sales.
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Instructions:	 Results/ Comments:

Action 2.3 - Using Wildcards in PivotTable Filters

 1. 	 You should still have MyPivotTable.
xlsx open.

	 2.	 Click on the Filter button for 
Salesperson.

	 3.	 Select  Label Filters and then Equals... 
from the menu and submenu.

	 4.	 Type A*R in the text box.

	 5.	 Click [OK]. 
 
 
 

	 6.	 Clear the filter.

	 7.	 Save your file.

If not, open it from the Student Data 
folder.

The filter is not case-sensitive.

Notice that the PivotTable is filtered 
to show Andrew Fuller, but not Anne 
Dodsworth because her name does not 
end with an r.
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Filtering a 
PivotTable,
continued

Using Multiple Report Filters
The Report Filter will give you a high level summary and can 
include multiple combinations of fields.  To filter by more than 
one field, you can add multiple report filters to the PivotTable 
Field List, just as you can add multiple row or column fields.

�� When filtering by more than one field, click and drag 
the field to the Filters section of the PivotTable Fields 
pane.  

�� Place them in the order you wish them to appear in 
the PivotTable or click and drag them to the correct 
position in the list.

�� You can now filter by each field independently and 
combine filters.

Using the Search Box to Apply a Filter
�� First, from one of the Filter 

drop-down buttons, select 
the Multiple Items check 
box, which will activate the 
checkbox for each selection.

�� Type in the search term.  It is 
not necessary to use wildcards 
here.

�� Click [OK] or press [Enter].
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Adding Criteria to an Existing Filter
�� Click on the [Filter] button in the ‘Filter Area’ of the 

PivotTable (not in the PivotTable Fields).

�� Type in the your search criteria.  All matching items 
will be added to the bottom of the list.

�� Click [OK] or press [Enter]. Your PivotTable is now 
displaying only those items that matched your search 
criteria.

�� To add another search criteria, click on the desired 
[Filter] button again.  

�� Type in the next search criteria.

�� Click on the [Add current selection to filter] checkbox 
to turn it on and make sure the Seclect Multiple Items is 
checked.

�� Click [OK]. 

	 The additional search results will be added to the 
existing results.

Filtering a 
PivotTable,
continued
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Using Multiple Row Filters
Sometimes, you will want to filter by multiple fields within your 
rows.  By adding multiple fields to the Rows section of your 
PivotTable Field List, you will be able to apply multiple filters at 
the same time.

�� Drag a second or third field to the Row area in the 
PivotTable Field List Task Pane.

�� Click on the [Filter] button next to Row Labels in the 
PivotTable.

�� Click on the drop-down arrow next to the Select field: 
text box. 

�� Select the field on which you want to filter.

�� Select the appropriate filter options.

�� To apply the second filter, click on the [Filter] button 
again and click on the drop-down arrow next to the 
Select field: text box and choose the field on which you 
would like to apply the second filter.

�� Repeat these steps as many times as needed.

Filtering a 
PivotTable,
continued

If you are have 
chosen, PivotTable 

Options, Display, and 
checked Classic PivotTable 
layout (enables dragging 
of fields in the grid), you 
simply choose which 
filter you want for each 
Row that is displayed.  
There is no Select field: 
choice when you click 
the [Filter] button.
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Instructions:	 Results/ Comments:

Action 2.4 - Multiple Report Filters

	1. 	 You should still have MyPivotTable.
xlsx open.

	2.	 Drag Company Name and Required 
Date to the Filters area of the 
PivotTable Field List Task Pane.

	 3.	 Click the Filter button next to Country.

	 4.	 Select Ireland.

	 5.	 Click [OK].

	 6.	 Click the Filter button next to Required 
Date.

	 7.	 Select the checkbox next to Select 
Multiple Items.

	 8.	 De-select the All checkbox.

	 9.	 Click the checkboxes for 	
		  27-APR-2007 
		  22-MAY-2007
		
	10.	 Click [OK].

	11.	 Click the Filter button next to 
Company Name.

	12.	 Select Hungry Owl All-Night Grocers.

	13.	 Click [OK].

	

	14.	 Clear the filters for all of the fields.

If not, open it from the Student Data 
folder.

This will add Company Name  and 
Required Date to the top of the 
PivotTable.

Now you will only see Prices for products 
sold to Irish companies.

The PivotTable now shows only those 
items sold to Irish companies where the 
Required Date is one of the checkmarked 
dates.

The PivotTable should show only those 
Products sold to the Irish company named 
Hungry Owl All-Night Grocers and the 
Salesperson assigned to that company.
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Instructions:	 Results/ Comments:

Action 2.5 - Using the Search Box

	 1.	 Click on the Filter button for the 
Country field in the PivotTable.

	 2.	 Click into the Search text box and type 
land.

	 3.	 Click the Select Multiple Items 
checkbox.

	 4.	 Make sure the (Select All Search 
Results) checkbox is selected.

	 5.	 Click [OK].

	 6.	 Click on the Filter button for the 
Country field in the PivotTable Report 
Filter.

	 7.	 Click into the Search text box and type 
ar.

	 8.	 Click the checkbox to Add current 
selection to filter.

	 9.	 Click [OK].

	

	10.		 Save the file.

Notice the results shown in the Filter box.

Notice Denmark and Argentina appear in 
the results.

The PivotTable is updated to show only 
those products sold to companies in 
Argentina, Denmark, Finland, Ireland, 
Poland and Switzerland.
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Conditional 
Formatting in a 
PivotTable

Just like in a spreadsheet, you can apply different formatting to 
your PivotTable data based on the values the data assumes at 
any give time.  This is called conditional formatting.  It is a great 
way to emphasize data of particular interest.  For example you 
can highlight in red any budget items that are  greater than 20% 
over budget.  The technique to apply Conditional Formatting is 
similar to the technique used in a spreadsheet.

Using Conditional Formatting
�� Select a value within the field to which you want the 

formatting applied.

�� Click on the [Conditional Formatting] button located 
on the Home Tab.  A menu of conditional formatting 
options will be displayed.

�� Choose one of the following:

�� Highlight Cells Rules — 
will highlight cells that 
are greater than, less than, 
between or equal to values 
that you specify.

�� Top/Bottom Rules — will 
allow you to highlight the 
highest or lowest numbers 
or percent in the selected 
cells.

�� Data Bars — will display 
colored bars that compare 
the value in the cell to the 
other cells in the range.

�� Color Scales — will use 
different shades of color to 
represent different values 
from low to high.

�� Icon Sets — will use sets of similar icons that will 
visually indicate a cell's value relative to a set 
threshold.

	There are also options for creating a new rule, for 
clearing rules, and for managing rules.  
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�� When you select a menu option, a submenu will 
appear with additional selections.  For the Highlight 
Cells Rules and Top/Bottom Rules you will get an 
additional dialog box to enter a value and color choice. 

�� As you point to an option in the submenu, you will see 
a preview of the conditional formatting applied to the 
selected cell.  For the Highlight Cells and Top/Bottom 
Rules options, you will not see the preview until you 
have selected the specific rule or submenu.

�� To implement the conditional formatting, just click the 
submenu option of your choice.  Shown below is an 
example of Highlight Cells Rules.

�� Click on the down arrow on the Smart Tag to apply 
the conditional formatting to all of the items in the 
field.

�� You can apply multiple conditional formatting rules to 
a group of cells by simply re-selecting the group and 
adding another conditional format.

Highlight Cells Greater than 98%Highlight Cells Rules 
submenu

Conditional 
Formatting in a 
PivotTable, 
continued

Selecting the 
second option from 
the Smart Tag list 

will let you switch Row 
labels if needed because 
the formatting is applied 
to the values, not the 
field.
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Clearing Conditional Formats
�� To clear the formatting, select a cell within the field.

�� Click on the [Conditional Formatting] button.

�� Select Clear Rules from the menu.

�� Then, select Clear Rules from This PivotTable from 
the submenu.

	

Conditional 
Formatting, 
continued
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Instructions:	 Results/ Comments:

Action 2.6 - Applying Conditional Formatting to a PivotTable

	 1.	 Clear the filters in the PivotTable. 

	 2.	 Select cell B7.

	 3.	 On the Home Tab, in the Styles group, 
click on the [Conditional Formatting] 
button.

	 4.	 Trace to Highlight Cells Rules, and 
then select Greater Than... from the 
submenu.

	 5.	 Type 3000 in the text box and click 
[OK].

	 6.	 Click on the Smart Tag that appears 
next to cell B7.

	 7.	 Select the third option button.

	
	 8.	 Re-select cell B7 if necessary.

	 9.	 On the Home Tab, in the Styles group, 
click on the [Conditional Formatting] 
button.

	10.	 Trace to Icon Sets, and then select the 
first set of directional icons with the 
arrows from the submenu.

	11.	 Click on the Smart Tag that appears 
next to cell B7.

This indicates that we want to highlight 
any cells showing numbers greater than 
3000.

All cells showing “Sum of Extended 
Price” values for “Salesperson” and 
“Product Name”. This option highlights 
the data and excludes the Grand Total.

Next, you want to show values less than 
$500 with a red down arrow.

Don’t skip this step.  The Smart Tag may 
not appear later and you will have to edit 
the rule to include the range of data.
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Instructions:	 Results/ Comments:
	12.	 Select the third option button.

	13.	 Click the [Conditional Formatting] 
button again, then select Manage 
Rules....

	14.	 Click on the Icon Set rule, then on the 
[Edit Rule...] button.

	15.	 Change Type to Number for both of the 
top icons.

	16.	 For the first Icon, in the when value is >= 
text box, type: 10000.

	17.		 For the second Icon, in the when value is 
>= text box, type: 500.

	18.	 Change Icon to No Cell Icon using 
the drop-down arrows for the top two 
items.

	19.	 Click [OK]

	20.	 Click [OK] again.

This will only show red icons when <500.

Notice that Anne Dodsworth’s data for 
Alice Mutton is less than $3,000, so the 
figure is not shaded in light red and does 
not have red text.

Notice also, that Laura Callahan’s total for 
Alice Mutton is greater than $500, but less 
than $3,000, so it is not shaded in light red 
and does not have red text.

Neither figure has a red down arrow.

Notice that several Salespersons have Red 
Arrows for selling less than $500.00 or the 
product Aniseed Syrup.

Action 2.6 - Applying Conditional Formatting to a PivotTable, continued
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Instructions:	 Results/ Comments:

Action 2.6 - Applying Conditional Formatting to a PivotTable, continued

	21.	 On the Invoices sheet, change the 
following cells:

Cell location Original Value New Value
J173 16 160
J2115 20 2
J1013 15 1
J394 35 3

	22.	 On Sheet1, click on the PivotTable.

	23.	 On the Analyze Tab, click on the 
[Refresh] button.

	
	24.		 Save the file.

Use the Name Box to quickly go to the cell 
locations.

Notice the formatting changes in cells B8 
and B10 of the PivotTable.
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When your PivotTable data is in its smallest value, you 
frequently end up with detailed information that would be better 
represented by being grouped.  For example, if one of the fields 
in your data table is Date, you can group these dates by Month, 
Quarter, or Year.

Grouping Data in a PivotTable
�� Select the fields in your PivotTable. Use your [Ctrl] or 

[Shift] keys to select multiple fields.

�� Right-click on the field and choose Group from the 
shortcut menu.

PivotTable with Grouped Date Field PivotTable with Ungrouped Date Field

Grouping Data 
in a PivotTable

Right-clicking 
on any value in 

a field will reveal a 
shortcut menu with 
options to Group 
and Filter.
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Instructions:	 Results/ Comments:

Action 2.7 - Grouping Data in a PivotTable

	 1.	 You should still have your PivotTable 
active.

	 2.	 Move Salesperson to the Columns area 
in the PivotTable Field List Task Pane.

	 3.	 Move Shipped Date to the Rows area 
in the PivotTable Field List Task Pane.

	 4.	 Make sure Country is still in the Filters 
area of the PivotTable Field List Task 
Pane.

	 5.	 Drag Extended Price out of the Values 
area and replace it with Unit Price.

 
	 7. 	 Click on the Shipped Date field in the 

PivotTable.

	 8.	 On the PivotTable Tools Analyze 
Tab, in the Group group, click on the 
[Group Selection] button. (You can 
also Right-Click on the Shipped Date 
field in the PivotTable.)

	 9.	 Months is selected in the Grouping 
dialog box. 

	10.	 Click [OK].

	

If not, select your PivotTable.

The Grouping dialog box is 
opened.

Do not click on Months. 
Clicking on Months will 
de-select it.

The row headings in the 
PivotTable are now grouped 
by month.
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Using the Slicer Slicers enable you to depict the datasheet fields more 
comprehensively. The real benefit of Slicers can be seen on 
a Dashboard with PivotTables and PivotCharts. Although 
PivotTables allow you to filter the datasheet, a Slicer allows you 
to compare and evaluate the data from different perspectives 
quickly, easily and visually. This section will explain how you 
can use Slicers with PivotTables and PivotCharts.

Generating Slicers 
�� Open your document that contains a datasheet and 

create a PivotTable.

�� Click a cell within the PivotTable. 

�� Navigate to the Analyze Tab. 

�� Click the [Insert Slicer] 
button in the Filter group.  

�� The Insert Slicers dialog 
box will be displayed, 
containing the fields from 
the PivotTable.

�� Select the Fields from the 
list that you want to display 
or manipulate in your 
PivotTable.

�� Click [OK].

You will see a Slicer box 
containing each field you checked.  The Slicer Tools 
Options Tab will also be available on the ribbon.  This tab 
will allow you to change the title, format, size and position 
of the Slicers. 
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Using Slicers
To display information that pertains 
only to a specific item or combination 
of items, click on that option in one of 
the available Slicers.  The PivotTable 
will automatically show only the 
information related to the selected 
item(s).  If you have a PivotChart 
created based on the same PivotTable, 
the PivotChart will also display the 
selection(s).
 
By using Slicers, you can filter down 
your data into more detail. Its real 
usage can be seen when you are 
dealing with large data sheets.

Using a Filter Versus Using a Slicer
Is it better to use a Filter or a Slicer?   Prior to 2010, Slicers were 
not available for use in a PivotTable.  Slicers make it easier to see 
the current filtering state when you filter on multiple items.  This 
makes it easy to understand what is exactly being shown in a 
filtered PivotTable.  Additionally, Slicers have some additional 
functionality, like the ability to use one Slicer for multiple tables.  
This is explored further in the Excel Dashboard class.

Clearing a Slicer Filter
�� Click on the [Clear Filter] button in the top right 

corner of the Slicer.

Closing or Deleting a Slicer
�� Click on the Slicer to select it.

�� Press the [Delete] key.

- OR -
�� Right-click on the Slicer.

�� Select Remove <Slicer Name> from the shortcut list.

Using the Slicer 
continued

To make multiple 
selections, hold 
down your [Ctrl] 

key while clicking on 
the field.

To select all of the 
Slicers, select one 

of them and press 
[Ctrl + A].
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Formatting a 
Slicer

Using the Ribbon
�� Select the Slicer you would like to format.

�� When the Slicer Tools Options Tab appears, use the 
tools to change the appearance of the Slicer.

�� In the Slicer group, you can change the Slicer Caption, 
or click on the [Slicer Settings] button to open the 
dialog box.  You can also connect one Slicer to multiple 
PivotTables using the [Report Connections] button.

�� Choose a Slicer style from the Slicer Styles Gallery by 
selecting an option from the gallery.  

Use the [More] button to expand the gallery and view 
all of the styles.  Notice, the Live Preview option does not 
work in this gallery.

�� The Arrange group contains tools to layer the Slicers 
and objects on your spreadsheet, as well as to align the 
Slicers.

�� The Buttons group allows you to set the size of 
the buttons in the Slicer and how the buttons are 
displayed.  

�� The Size group allows you to change the size of the 
Slicer frame. The height and width can be changed 
using the spin buttons in the Height: and Width: text 
boxes on the Ribbon, or by using the sizing handles on 
the Slicer itself.

By changing the number of columns, as well as the height 
and width of the Slicer, you can position the Slicer in a 
smaller space.

See Appendix A for additional Slicer formatting options.

Be careful when 
changing the height 
and width of the 

Slicer buttons.  Use 
the Height and Width 
settings in the Button 
group.
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Formatting a 
Slicer,
continued

Using the Slicer Settings Dialog Box
The following options are available in the Slicer Settings dialog 
box which you can display by clicking the [Slicer Settings] 
button or right-clicking on the Title Bar for the Slicer you want to 
change.

�� Name:  This is to identify the object on the spreadsheet.  
The default name is usually displayed, but can be 
changed to a more appropriate title.

�� The Display Header checkbox will turn the Header on 
the Slicer off and on. You may wish to turn the header 
off when it is unnecessary or you are trying to fit the 
Slicer into a small area.

�� The Item Sorting and Filtering section is to determine 
how you wish the values in the Slicers to appear.

�� Visually indicate items with no data means that even 
if there is no data, the button for that category/item 
will still appear in the Slicer.  You may see this when 
you connect your Slicer to multiple PivotTables.  The 
button will simply be grayed out if there is no data 
associated with it.

�� Show items with no data last, will put that button 
at the bottom of the Slicer. The buttons will be re-
arranged to show those with data first, going from left-
to-right, top-to-bottom.

�� Similarly, Show items deleted from the data source 
will still show a button in the Slicer for items that have 
been deleted, as long as items deleted from the data 
source are being retained in the PivotTable Options.

For additional information on PivotTables and Slicers, try the 
Excel Dashboard class.

Show items 
with no data 
last cascades 

underneath Visually 
indicate items with 
no data because it is 
dependent on whether 
Visually indicate items 
with no data is checked 
or not.
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Instructions:	 Results/ Comments:

Action 2.8 - Using and Formatting the Slicer 

	 1.	 You should still have MyPivotTable.
xlsx open.

	 2.	 On Sheet1, click into the PivotTable to 
select it.  

	 3.	 Remove Product Name from the 
Columns area.

	 4.	 Drag another instance of the Unit Price 
field into the Values area of the Field 
List Task Pane.

	 5.	 Click the drop-down arrow of one of 
the two instances of Unit Price in the 
Field List Task Pane and choose Value 
Field Settings 

	 6.	 Choose Average from the Summarize 
value field by list.

	 7.	 Click the [Number Format] button.

	 8.	 Select Accounting from the index on 
the left.

	 9.	 Change the number of Decimal places: to 
0.

	10.	 Click [OK].

	11.	 Click [OK] again.

	12.	 On the Analyze Tab, click the [Insert 
Slicer] button.

If not, open it.

This adds a second instance of the same 
field so that you are able to calculate 
using a different function.

This opens the Field Settings dialog box.

The Insert Slicer dialog box opens.
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Instructions:	 Results/ Comments:

Action 2.8 - Using and Fomratting the Slicer, continued 

	13.	 Place check marks next to Company 
Name, Country, and Product Name.  

	14.	 Click [OK].  Move the Slicers below the 
PivotTable.

	

	15.		 Select the Product Name Slicer.

	16.	 Select Slicer Style Dark 6 (the last 
option) from the Slicer Styles Gallery 
on the Slicer Tools Options Tab.

	17.	 Pass your mouse pointer over the 
different values in the Product Name 
Slicer and notice the format change of 
the buttons passed over.

	18.	 Make sure the Product Name Slicer is 
selected. Click Aniseed Syrup in the 
Slicer to filter the data. Notice the 
Values change in the PivotTable.

	19.	 Select the Company Name Slicer. Right 
click and choose Slicer Settings....

	20.	 Click the Descending option button 
to sort the values on the Slicer in  
descending order.

	21.	 Click [OK].

	22.		 Save your file. 

To choose the fields to ‘slice’.

A Slicer window for each field is opened 
on the sheet with the PivotTable. Notice 
you can open Slicers for fields that do not 
appear on the PivotTable.

Notice the new contextual tool tab.

Use the [Ctrl] key to select multiple values 
in each Slicer.

[Ctrl+S].
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Lesson Overview

You will cover the following concepts in this 
chapter:

Excel 2016: Pivot Table Features
Rel. 1.0, 10/25/2017

Lesson 3: Creating and 
Modifying PivotCharts

�� Creating PivotCharts

�� Modifying PivotCharts

�� Using the Slicer with the PivotChart 



Lesson Notes
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In Excel you can create a PivotChart from scratch, or create a 
PivotChart based on an existing PivotTable. 

Creating a Chart Based on an Existing PivotTable

�� Select a cell in the PivotTable. The PivotTable Tools 
Tab is displayed.

�� With the Analyze Tab active, click the [PivotChart] 
button in the Tools group.

�� Choose the type of chart most suited to your data and 
click [OK]. 

	 Notice the addition of the PivotChart Tools Tabs.

PivotCharts

When you create 
a PivotChart 
from scratch, a 

corresponding PivotTable 
is automatically 
generated.
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In the image above, a basic column chart has been created from 
an existing PivotTable. This particular chart shows quantities 
sold by salespersons broken down over countries.

Any changes made to the source data or rearrangement of field 
values in the PivotTable will be automatically reflected in the 
PivotChart. Refreshing will update both the PivotTable and the 
PivotChart. This makes the PivotChart every bit as malleable as 
the PivotTable upon which it is based.

Changing the Chart Style
If you don't like the chart type chosen, you can select any 
other chart type from the Change Chart Type  dialog box except 
XY (Scatter), Bubble, or Stock charts to display the data in a 
PivotTable. 

�� Click on the PivotChart.

�� Make sure the PivotChart Tools Tab is displayed and 
click the Design Tab.

�� Click the [Change Chart Type] button in the Type 
group.

�� Choose the chart type you want and click [OK].

Keep in mind that not all chart types are equally suited for 
displaying your PivotTable data. Pick the chart type that most 
clearly illustrates the point you want to communicate.

PivotCharts,
continued
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Instructions:	 Results/ Comments:

Action 3.1 - Creating a PivotChart 

	 1. 	 You should still have MyPivotTable.
xlsx open.

	 2.	 Click on the Invoices sheet.

	 3.	 Click anywhere in the data on the  
Invoices sheet.

  4. 	 Select the Insert Tab and click the 
[PivotTable] button. 

	 5. 	 Verify that Select a table or range 
option button is chosen and the correct 
range is entered in the Table/Range 
field.

	 6.	 Make sure that the New Worksheet 
option button is selected.

 
	 7. 	 Click the [OK] button to create the 

PivotTable. 

	 8.	 Place Shipped Date in the Filters, 
Salesperson in the Columns, Country 
in the Rows, and Quantity in the 
Values field.

	 9.	 On the Analyze Tab click the 
[PivotChart] button.

	10.	 Choose the Clustered Column type 
and click [OK].

	11.	 Notice the PivotChart Tools tabs 
added to the Ribbon. 

If not, open it from the Student Data 
folder.

You will create a new PivotTable first.

Invoices!$A$1:$K$2156

The Insert Chart dialog box opens.

A chart is added to the same sheet as the 
PivotTable sheet.

Three new tabs are added: Analyze, 
Design, and Format.
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The [Insert Slicer] 
button is only 
available when 

the PivotChart and 
PivotTable are in the 
same worksheet.

Chart Elements box

Formatting 
PivotCharts

When you click into the PivotChart you have created, you will 
notice that several contextual tabs appear:  The Analyze, Design,   
and Format ribbons.

The Analyze Ribbon

The Analyze Tab, contains many of the tools that you need to 
affect the data that is actually displayed on your PivotChart.  For 
example, you can use this Ribbon to insert a Slicer connected to 
your PivotChart.  In the Active Field group, you can expand and 
collapse fields you have selected on the PivotChart.

The Format Ribbon

This Ribbon is used to change the appearance of any of the 
elements in the PivotChart.

�� Click on the drop-down arrow in the Chart Elements 
box.  Select an item from the drop-down list.

- OR -

�� Select the element in the PivotChart. Notice the name 
in the Chart Elements box changes to reflect the 
selection.

�� Use the tools on the Ribbon to change the appearance 
of the selected item.
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Formatting 
PivotCharts,
continued

The Design Ribbon

This Ribbon is for quickly adding chart elements, selecting a 
chart style, changing the chart type and moving the chart to a 
different worksheet.

�� The Chart Layouts Group lets you add, remove and 
change these elements of the PivotChart by clicking 
the down arrow on the [Add Chart Element] button.  
Each choice has a sub-menu that also has a 'More...' 
choice that will display a Format Panel for that object. 
Not this is where you can add a Trendline to your 
PivotChart. 
 
This group also has a button for [Quick Layout] with 
pre-determined elements already displayed

�� The Chart Styles Group has tools to format the 
background area of the PivotChart.  Each chart type, 
will have it's own set of styles available in the Styles 
Gallery.  The [ChangeColors] button changes the color 
of the Data Series area.

�� The Data Group lets you Switch Rows and Columns in 
the PivotChart and select a specific Data Source using 
the [Select Data] button.

�� The Type Group is a quick way to change the type of  
PivotChart displayed.

�� The Location Group allows you to move the Chart to a 
New Sheet  or as an object in a specified sheet in your 
workbook.

You can also change and add elements to your PivotChart from 
the following choices on the Insert Ribbon.  

�� Add pictures & shapes using the Illustrations Group; 

�� Insert a chart or change the chart type from the Charts 
Group; 

�� Add a Slicer or Timeline from the Filters Group; 

�� Use the Text Group to add a Text Box or Header & 
Footer.
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Using the Format Shape Dialog Box
An alternative to using the tools on the Format Ribbon is 
to use the Format Task Pane.  To open the Task Pane, click 
on the [Format Selection] button on the Format Tab of the 
Format Ribbon.  The options in the Format Selection Task 
Pane will change based on the element that is selected in 
the PivotChart. You can use the words at the top, or the 
icons below those, or the index below the icons to select the 
different elements you wish to affect.

Keep in mind that while this Task Pane is open, other 
elements in the PivotChart can be affected when selected.  
You may keep the Task Pane open, click on the element you 
wish to change, and make changes to multiple chart elements 
before closing the Task Pane.

Format Task Pane

Clicking into the 
PivotChart and 

pressing [Ctrl + 1] 
will also open the 
Format Selection 
dialog box.

Formatting 
PivotCharts,
continued
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Instructions:	 Results/ Comments:

Action 3.2 - Modifying a PivotChart

Your PivotChart is now on a new sheet 
named Chart1.

The Change Chart Type dialog box opens.

The new PivotChart type replaces the 
current PivotChart.

A chart title text box appears above the 
chart.

Notice you do not need to click into the 
Chart Title text box.  As you type, the title 
will appear in the Formula Bar. It appears 
in the Chart Title text box when you press 
[Enter].

Make sure the Chart Title text box is still 
selected.

The text is now also big enough to read 
easily.

This allows you to choose which of the 
field filter buttons are visible and which 
fields users can filter by.

You are now able to filter this data only by 
Shipped Date.

	 1. 	 On the Design Tab, click the [Move 
Chart] button.

	 2.	 Check the New Sheet option button 
and click [OK].

	 3.	 On the Design Tab click the [Change 
Chart Type] button.

	 4.	 Choose the first Bar chart option and 
click [OK].

	 5.	 On the Design Tab click the [ Add 
Chart Element] button and trace to 
Chart Title and then select Above 
Chart.

	 6.	 With the Chart Title text box active, 
type Sales and press the [Enter] key.

	 7.	 On the Format Tab choose a WordArt 
style from the WordArt Styles gallery.

	 8.	 Right-click the Chart Title text box. 
Choose Font on the menu and  change 
the font size to 40 pts.

 
	 9.	 On the Analyze Tab, in the Show/Hide 

group, click the [Field Buttons] drop-
down arrow.

	10.	 Uncheck all except the Show Report 
Filter Field Buttons.
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Instructions:	 Results/ Comments:
Notice how the PivotChart changes to 
reflect only those sales in March.

If needed, deselect the All checkbox.

Notice again how the chart changes to 
reflect the new selection.  

Notice also that although a Shipped Date 
month has been selected, the month does 
not appear on the PivotChart by default.  
Slicers on the PivotTable would alleviate 
this problem.

Action 3.2 - Modifying a PivotChart, continued

	11.	 Click on the Shipped Date filter button 
in the PivotChart and select Mar.

	12.		 Click [OK].

	13.	 Click on the Shipped Date filter button 
again.  Select the Select Multiple Items 
checkbox.

	14.	 Select the Mar and Apr checkboxes.

	15.	 Click [OK].
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Instructions:	 Results/ Comments:

Action 3.3 - Moving a PivotChart and Using a Slicer with a PivotChart

Now, we will move the PivotChart back 
to Sheet1 in order to insert a Slicer that 
will affect both the PivotTable and the 
PivotChart.

	 1.	 Click on the [Move Chart] button in the 
Design Tab.

	 2.	 Select the Object in: option button.

	 3.	 Use the drop-down arrow to select 
Sheet1.

	 4.	 Click [OK]. 

	 5.	 Move the PivotChart so that it does not 
overlap the PivotTable.

	 6.	 Click into the PivotChart on Sheet1.

	 7.	 Select the [Insert Slicer] button from 
the Analyze Tab.

	 8.	 Click on the Product Name and 
Shipped Date checkboxes.

	 9.	 Click [OK].

	10.	 Move the Slicer so that it does 
not overlap the PivotChart or the 
PivotTable.

	11.	 Select a Product from the Product 
Name Slicer and observe the changes 
in both the PivotTable and the 
PivotChart.

12.		 Save and close the file.



Tips and Notes



Lesson Overview

You will cover the following concepts in this 
chapter:

Lesson 4: Advanced 
Features of PivotTables

Excel 2016: Pivot Table Features
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�� Consolidating Multiple Workbooks, and 
Ranges

�� Using Page Fields in a PivotTable Report

�� Using Calculated Fields and Calculated 
Items in a PivotTable Report

 	

	

	



Lesson Notes
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Consolidating 
Multiple 
Workbooks & 
Ranges 

Frequently, the goal of a PivotTable is to consolidate information 
into a format that can be manipulated in various combinations 
without modifying the original data source.

With a PivotTable, we can select different options, filter for 
specific criteria, and apply conditional parameters to identify 
trends or to display patterns or relationships that might not 
otherwise be obvious when reviewing a traditional spreadsheet.

One of the ways that you can consolidate multiple workbooks 
or data ranges on different worksheets into one PivotTable is to 
utilize the PivotTable and PivotCharts Wizard.

Installing the PivotTable & PivotCharts Wizard

�� On your Quick Access 
Toolbar (QAT), located at the 
upper-left corner of your Excel 
screen, select the [Customize] 
button and select the More 
Commands option. 

�� From the Customize the 
Quick Access Toolbar page of 
the Excel Options dialog box, 
under the Choose commands from: drop-down, select All 
Commands.

�� Scroll down and select the 
[PivotTable and PivotChart 
Wizard] icon, then select [Add] to 
add it to the right-hand column. 

�� Click the [OK] button 

�� The PivotTable and PivotChart 
Wizard icon will appear on your QAT and 
return you back to your Excel worksheet.



Lesson 4: Advanced Features of PivotTables 

Page  70	 Excel 2016: Pivot Table Features, Rel. 1.0, 10/25/2017

Once you have the PivotTable and PivotCharts Wizard 
installed on the QAT, you need to decide how you are going to 
consolidate your data from each separate worksheet range into a 
PivotTable report on a master worksheet.  Selected ranges can be 
in the same workbook as the master worksheet or in a different 
workbook. When you are consolidating the data, remember 
that you are assembling this data so you can easily update and 
aggregate it regularly or as needed.

Your resulting consolidated PivotTable Report can have the 
following fields in the PivotTable Field List, which you will add 
to the PivotTable Report: Row, Column and Value. In addition, 
your report can have up to four page filter fields called Page1, 
Page2, Page3, and Page4. 

Considerations for Setting Up Your Source Data
�� Your data ranges should be set up in a cross-tabular 

format with matching column names for items that 
you want to summarize together. 

�� You should not include any total rows or total columns 
from the source data when you are specifying the data 
range for the report.

�� Consolidations can use Page Fields that contain items 
representing one or more of the data source ranges. 

For example, when representing multiple items, such 
as departments for a budget, a Page Field can include 
one item to show the data for each department, plus 
an item to show the combined data.

�� Consolidations can use Named Ranges which perform 
better for data that is likely to change the next time 
you perform a consolidation action on the worksheet 
or workbook. 

This would include changes such as data within the 
rows or the number of rows that make up the Named 
Range.

�� Consolidations can also use formulas such as a 3D 
Reference, or the [Consolidate] command located on 
the Data Tab in the Data Tools group.

Consolidating 
Multiple 
Workbooks & 
Ranges,
continued
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Consolidating 
Multiple 
Workbooks & 
Ranges,
continued

What Type of Consolidation do I want?
In Step 1 of the PivotTable and PivotChart Wizard, there are 
several selections to determine the type of consolidation you 
wish to produce.  

Microsoft Excel List or Database
Choose this option when the source data is on an Excel 
spreadsheet.  Excel recognizes data that is contiguous, with no 
row or column separators, as a list or database.  So, as long as the 
data does not have blank rows or columns, Excel can use it for 
consolidation.

External Data Source
Choose this option when the data source is not in the active 
workbook and is not necessarily Excel data.  If the source data 
is from an Access table or other file type, Excel will develop 
the consolidation from this data.  The following dialog box will 
display in Step 2 of the Wizard when the [Get Data...] button is 
selected.  

This dialog box will also display existing connections that have 
been created as queries using the Data Tab.

Multiple Consolidation Ranges
When your source data is Excel data on different spreadsheets or 
in different files, you should select this option.  This will generate 
the dialog box that allows you to select data from different 
locations. 

Another PivotTable Report or PivotChart Report
Select this option if the source data is in an existing PivotTable 
Report or PivotChart.  This will consolidate data that is 
generated when the PivotTable or PivotChart is refreshed.

Existing 
connections



Lesson 4: Advanced Features of PivotTables 

Page  72	 Excel 2016: Pivot Table Features, Rel. 1.0, 10/25/2017

Consolidating Data Without Using Page Fields
To combine data from all your ranges and create a consolidation 
that does not contain Page Fields do the following:

�� Click in a blank cell that is not currently part of a 
PivotTable Report.

�� Start the PivotTable and PivotChart Wizard.

�� On Step 1 of the PivotTable and PivotChart Wizard, 
click Multiple Consolidation Ranges, then click 
[Next].

�� On Step 2a of the PivotTable and PivotChart Wizard, 
click I will create the page fields, then click [Next].

Consolidating 
Multiple 
Workbooks and 
Ranges,
continued

If the cell ranges that 
you want to add 
are located in other 

workbooks, open those 
workbooks first to make 
accessing the cell range 
easier.
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�� On Step 2b of the PivotTable and PivotChart Wizard, 
for each range of cells you want to select, click on the 
[Collapse Dialog Box] button, select the cell range on 
the worksheet, close the [Selection Tool], and then 
click [Add].  

	

�� Under How many page fields do you want?, click 0, and 
then click [Next].

�� On Step 3 of the PivotTable and PivotChart Wizard, 
select a location for the PivotTable Report and then 
click [Finish].

�� When the PivotTable and PivotChart Wizard closes it 
will return you to your master worksheet and display 
the consolidation of the data ranges that you selected.

Sheets to be consolidated being viewed in Tiled format.

Consolidating 
Multiple 
Workbooks and 
Ranges,
continued

Collapse 
Dialog Box 
button
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�� The master worksheet will contain the PivotTable 
Report and display the PivotTable Field List on the 
right-hand side of the worksheet.

Click on the [Maximize] icon on the top of the page to 
make your new consolidation a full-size window.

Select a cell inside the PivotTable, then right-click and 
select PivotTable Options to go to the Display tab and 
check the Classic PivotTable layout (enables dragging 
of fields in the grid) option to turn on the Classic 
PivotTable Layout.

	

Consolidating 
Multiple 
Workbooks and 
Ranges,
continued
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Action 4.1 - Creating a PivotTable Using the PivotTable and  
PivotChart Consolidation Wizard

	 1. 	 On your Quick Access Toolbar at the 
top left of your Excel workbook,  click 
on the [Customize] button and select 
[More Commands].

	 2. 	 In the Excel Options dialog box, under 
Choose commands from:, select the drop-
down and select All Commands.

	 3.	 Scroll down and select the PivotTable 
and PivotChart Wizard icon, then 
select [Add] to add it to the right-hand 
column. 

	 4.	 Click the [OK] button and the 
PivotTable and PivotChart Wizard 
icon will appear on your QAT and 
return you to your Excel worksheet.

     
	 5. 	 Open the workbooks named 

PivotTable Report.xlsx, Detroit.xlsx, 
Dayton.xlsx, and Columbus.xlsx from 
your exercise files folder.

	
	 6.	 From your View Tab, select the 

[Arrange All] button in the Window 
group.

	 7.	 In the Arrange Windows dialog box, 
select the Tiled option button and click 
[OK].

            
	 8. 	 Click on cell A2 on the NoPage 

sheet in the tile containing the 
PivotTableReport.xlsx workbook.

 	 9. 	 Launch the PivotTable and PivotChart 
Wizard from the QAT in the PivotTable 
Report.xlsx workbook.

Your workbooks will now be arranged in 
a tiled format so you can see all four files 
at one time.

This is where we are going to put the 
PivotTable Report Frame when we 
consolidate the data.
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	10.	 In Step 1 of the Wizard, select the 

[Multiple consolidation ranges] option 
button, then click [Next].

                        
   
	11.	 For Step 2a of the Wizard, select the 

I will create the page fields option 
button, then click [Next].

 	12.	 Click into the Range: box, then click the 
[Columbus.xlsx] workbook to activate 
it.

	13.	 Select the range A3:E7.

	14.	 In the PivotTable and PivotChart Wizard 
dialog box, under the Range box, select 
[Add] to add the selected range from 
the Columbus.xlsx spreadsheet to the 
All Ranges box.

   
	15. 	 Repeat the steps above to Add the 

same range from the Dayton.xlsx and 
Detroit.xlsx workbooks.  

	16. 	 Once you have all three workbooks 
added in the All Ranges box, select [0] 
option button under How many page 
fields do you want?.

	17.		 Click [Next] to continue. 

	18. 	 On Step 3 of the Wizard, select the 
Existing worksheet option button.  

 

	19.	 Click [Finish] to complete the 
consolidation wizard.

You are selecting this option because 
you are using multiple workbooks 
or worksheets to construct your 
consolidation.

Selecting this option allows you to control 
the number of Page Fields.

In Step 2b of the Wizard, you will 
be selecting the ranges you want to 
consolidate.

Notice that the range selected is defined 
as [Columbus.xlsx]Columbus!$A$3:$E$7.  
These are absolute cell references to the 
Columbus.xlsx workbook.

The order in which you select the ranges 
does not matter since Excel will sort the 
ranges alphabetically.

Action 4.1 - Creating a PivotTable Using the PivotTable and PivotChart 
Consolidation Wizard, continued
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Action 4.1 - Creating a PivotTable Using the PivotTable and PivotChart 
Consolidation Wizard, continued

20. 	 When the Wizard completes, you will 
be returned to the Tiled view and 
PivotTable Report.xlsx will be active.

	21.	 Maximize the workbook to see the 
report fields. Click on the filter buttons 
and change what is displayed. 

	22. 	 Press [F12] and save your file as My 
PivotTable Report.xlsx.

	23.	 Leave your files open and in Tiled 
view.

Completed consolidated sheet and 
workbooks in Tiled View.

Completed consolidated sheet in 
Maximized Window View.
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There are other options in the PivotTable and PivotChart Wizard 
which will change the type and way that your data will be 
displayed when consolidated.

One is to include a Page Field which will allow you to filter the 
resulting PivotTable.  Essentially, a Page Field is a Report Filter 
for the PivotTable that is generated by the wizard.  

In our example consolidation of Columbus, Dayton and 
Detroit for the fields of Sales, Cost, Expenses and Income, we 
consolidated into a PivotTable Report to show all three of the 
cities' weeks as rows with the fields as column headings.

If you compare them on the surface, they are identical, except for 
the additional heading of Page1 and (All) with a drop-down in 
the adjacent column.  The addition of this Page1 Field gives you 
the opportunity to filter your data by a new selection called Item, 
which represents the cities in your PivotTable Report.

PivotTable Report without Page1 Field

Using a 
Generated Page 
Field

PivotTable Report with Page1 Field
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Using a Single Generated Page Field to Consolidate 
Data
To combine data from all your ranges and create a consolidation 
that contains a single Page Field do the following:

�� Click in a blank cell that is not currently part of a 
PivotTable Report.

�� Start the PivotTable and PivotChart Wizard.

�� On Step 1 of the PivotTable and PivotChart Wizard, 
click Multiple consolidation ranges, then click [Next].

�� On Step 2a of the PivotTable and PivotChart Wizard, 
click Create a single page field for me, then click 
[Next].

Using a 
Generated Page 
Field,
continued
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�� On Step 2b of the PivotTable and PivotChart Wizard, 
for each range of cells you want to select, click on the 
[Collapse Dialog Box] button, or click into the Range 
text box and select the cell range on the worksheet. 
Then click [Add].  

�� When all the ranges have been added, select [Next].

To edit any ranges that you have added, select the 
range in the All ranges: list and click the [Delete] 
button.  Then, you can add the the correct range.

�� On Step 3 of the PivotTable and PivotChart Wizard, 
select New Worksheet or use the [Collapse Dialog 
Box] button to place your PivotTable Report in an 
Existing Worksheet, then click [Finish].

Using a 
Generated Page 
Field,
continued

If the cell ranges 
that you want to 
add are located in 

other workbooks, open 
those workbooks first 
to make accessing the 
cell ranges easier.
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�� When the PivotTable and PivotChart Wizard closes 
you will return to your master worksheet which 
displays the consolidation of the data ranges that you 
selected.

�� The master worksheet will contain the PivotTable 
Report and display the PivotTable Field List on the 
right-hand side of the worksheet.

What you will notice is the additional Page1 Field at 
the top of your PivotTable Report.

�� Click on the (All) drop-down and you will see Item1, 
Item2, and Item3 which represent Columbus, Dayton, 
and Detroit.

	

Using a 
Generated Page 
Field,
continued

Filtered for Item1 and displaying 
information for Columbus.

Page Fields are 
always displayed in 
alphabetical order 

even though they are 
assigned the names 
Item1, Item2, etc.

Page field
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Instructions:	 Results/ Comments:
  1. 	 Your file My PivotTable Report.xlsx 

should still be open.

		  The Columbus.xlsx, Dayton.xlsx and 
Detroit.xlsx files should be open and 
all four workbooks should still be 
displayed in a Tiled view.

		
	 2. 	 Click on cell A2 in the SinglePage 

worksheet, of the MyPivotTable Report 
file, to activate it.

  3.		 Select and launch the [PivotTable and 
PivotChart Wizard] from the QAT.

  4.		 In Step 1 of the PivotTable and 
PivotChart Wizard, select the Multiple 
consolidation ranges option button. 
Make sure the PivotTable option button 
is selected, then select [Next].

 	 5.	 In Step 2a of the PivotTable and 
PivotChart Wizard, select the Create a 
single page field for me option button. 
Select [Next].

  6.		 In Step 2b of the PivotTable and 
PivotChart Wizard, select the range 
A3:E7 in the Columbus.xlsx workbook.

	 7.	 Select [Add] to add the range to the All 
Ranges area.

Action 4.2 - Creating a PivotTable Using the PivotTable and PivotChart 
Consolidation Wizard and Adding Page Fields
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  8.		 Repeat the steps above to add the fields 

from Dayton.xlsx and Detroit.xlsx.

	 9.	 When you have all three workbooks 
added, click [Next].

	10.	 In Step 3 of the PivotTable and 
PivotChart Wizard, select where you 
will be placing your PivotTable Report. 
Cell text box should be set to $A$4.

	11.	 Click [Finish] to create your PivotTable 
Report.

	

	12.	 In cell B2, select the (All) drop-down 
and select Item1. Click [OK].

	13.	 Click on the filter button and change to 
Item2 and then Item3 to see how the 
display changes.

Action 4.2 - Creating a PivotTable Using the PivotTable and PivotChart 
Consolidation Wizard and Adding Page Fields, continued

You are now viewing the results for 
Columbus.xlsx. Notice that the PivotTable 
Report changes to display Item1 and a 
[Filtered] button appears next to Item1 in 
the heading.

Is it easy to tell which City is being 
displayed?
No, the cities are only referred to as Item1, 
Item2 and Item3 in the list and not by the 
individual city's name.

This is the default display and you cannot 
modify it in the Page1 settings.
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	14.		 Select the Page1 Field from the 
PivotTable Field List Report Filter area 
and drag it into the Rows area.

	15.	 Select the Home Tab, from the Editing 
group, from the [Find & Select] drop-
down, select [Replace...].

	16.		 In the Find what: text box enter Item1 
and in the Replace with: box, type 
Columbus, then select [Replace All].

	17.		 Repeat this step replacing Item2 with 
Dayton, and Item3 with Detroit. 

	18.		 Close the Find and Replace dialog box.

	19.		 Move the Page1 field back to the Filters 
area.

	20.		 Click on the filter button for Page1

	21.		 Save My PivotTable Report.xlsx and 
close the file.

	22.		 Close the Columbus.xlsx,  
Dayton.xlsx and Detroit.xlsx files and 
when prompted, select  
[Don't Save].

This adds each Item number under the 
Week with a breakdown for Item1, Item2, 
and Item3. 

Since you cannot change Item1, Item 2 
and Item3 to the actual city names, in the 
Page1 setup, we will use the [Replace] 
button.

This opens up the Find and Replace dialog 
box.

Observe the Page1 field values now:

Action 4.2 - Creating a PivotTable Using the PivotTable and PivotChart 
Consolidation Wizard and Adding Page Fields, continued
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Creating Your 
Own Page Field

You may wish to create your own Page Field to filter the 
PivotTable Report based on the fields you choose.  To do this, 
make your specific selections in Steps 2a and 2b.

�� On Step 2a of the PivotTable and PivotChart Wizard, 
click I will create the page fields, then click [Next].

�� On Step 2b of the PivotTable and PivotChart Wizard, 
select the cell range on the worksheet. Then click 
[Add].  

�� Before clicking next, select how many page fields you 
wish to create.  

�� Then, click on the ranges in the Range text box 
individually and type or select the Page Field the 
range belongs in.

Once you have 
created a Page 
Field in Step 2b 

of the PivotTable and 
PivotChart Wizard, it 
will appear in the drop-
down list.

Number of page 
fields

Page field title
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Creating Your 
Own Page Field, 
continued

�� When all the ranges and Page Fields have been added, 
select [Next].

�� Continue with the remaining steps of the PivotTable 
and PivotChart Wizard.
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Action 4.3 - Creating a PivotTable Using the PivotTable and  
PivotChart Consolidation Wizard and Adding Your Own Page Fields

  	1. 	 Open Page Fields.xlsx from the 
exercise files folder.

	 2.	 Click on the View Tab and click on the 
[New Window] button 4 times.

		

	 3.	 Click on the [Arrange All] button on 
the View Tab. Select Tiled and Click on 
the checkbox for Windows of Active 
Workbook.

	 4.	 Click [OK].
 
	 5.	 Click into each window to activate it 

and select the appropriate sheet that 
you wish to see on top.

This will create 4 new windows of the 
same file.  Notice the Title Bar shows the 
window number after the filename.
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Action 4.3 - Creating a PivotTable Using the PivotTable and PivotChart 
Consolidation Wizard and Adding Your Own Page Fields, continued

	 6. 	 Click on cell A2 of Sheet1, in the Page 
Fields file, to activate it.

  	7.		 Select and launch the [PivotTable and 
PivotChart Wizard] from the QAT.

  	8.		 In Step 1 of the PivotTable and 
PivotChart Wizard, select the Multiple 
consolidation ranges option button. 
Make sure the PivotTable option 
button is selected, then select [Next].

 	 9.	 In Step 2a of the PivotTable and 
PivotChart Wizard, select the I will 
create the page fields option button. 
Select [Next].

  10.		 In Step 2b of the PivotTable and 
PivotChart Wizard, select the range 
A2:E7 in the window that shows the 
East92 worksheet.

	11.	 Select [Add] to add the range to the All 
Ranges area.

 	12.		 Repeat steps 10 and 11 to add the fields 
from the West92, East93, and West93 
worksheets.  

	13.	 When you have all four worksheet 
ranges added, select 2 under How many 
page fields do you want?

	14.	 Select 'East92'!$A$2:$E$7 in the All 
ranges: textbox.  

	15.	 Type 1992 in the Field one: text box.

	16.	 Type East in the Field two: text box.

Notice the ranges are not all the same size.

You will select each data range and assign 
it to the filter fields.

This will create the field filter 1992.

This will create the field filter East.
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Action 4.3 - Creating a PivotTable Using the PivotTable and PivotChart 
Consolidation Wizard and Adding Your Own Page Fields, continued

	17.	 Select 'East93'!$A$2:$E$7 in the All 
ranges: text box.

	18.	 Type 1993 in the Field one: text box.

	19.	 Click the down-arrow in the Field two: 
text box and select East.

	20.	 Select 'West92'!$A$2:$E$6 in the All 
ranges: text box.

	21.	 Click the down arrow in Field one: and 
select 1992.

	22.	 Click into the text box in Field two: and 
type West. 

	23.	 Select 'West93'!$A$2:$E$8.  Click the 
down-arrow on Field one: and select 
1993.  Click the down-arrow on Field 
two: and select West. 

	24.	 Click [Next].

	25.	 In Step 3 of the PivotTable and 
PivotChart Wizard, select where 
you will be placing your PivotTable 
Report. 

	26.	 Click [Finish] to create your 
PivotTable Report.

	27.	 Maximize the window that is showing 
Sheet1.

This will create the filter field 1993.

Since this field has already been created, 
you can select it from the list.

This will create the filter field West.

You may need to click on cell A2 in Sheet1 
again.
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Action 4.3 - Creating a PivotTable Using the PivotTable and PivotChart 
Consolidation Wizard and Adding Your Own Page Fields, continued

	28.	 In cell B1, select the (All) drop-down 
and select 1992. Click [OK].

	29.	 Click on the filter button in cell  B2 and 
select East. Click [OK].

	30. 	 Save as My Page Fields.xlsx and close 
the file.

The PivotTable is filtered and shows 
figures from both regions for 1992.

Now the PivotTable shows only data from 
the East92 sheet. 
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Using Calculated 
Fields and Items

You can use summary functions in value fields from an 
underlying data source in PivotTable Reports.  If they do not 
provide the results that you want or need, you can create your 
own Formulas using Calculated Fields and Calculated Items.

The difference between a Calculated Field and a Calculated Item 
is that a Calculated Field will add an additonal row or column 
to your PivotTable, which then becomes a row or column from 
which other calculations can be created.  A Calculated Item, on 
the other hand, creates a calculation within a field.

For example, you might use a summary function to add up 
January, February, and March to return a First Quarter Total. 
You could then use First Quarter Total as a Calculated Field in a 
formula.

An example of a Calculated Item would be if you want to sum 
only those occurrences on certain days of the week. 

When you are working with Calculated Fields, it is important to 
remember the summary functions that are available for source 
data (with the exception of On Line Analytical Processing or 
OLAP data).

Function Summarizes
SUM Sum of the values. Default function for numeric data.
COUNT Counts the number of data values.
AVERAGE The average of the values.
MAX The largest value.
MIN The smallest value.
PRODUCT The product of the values.
COUNT 
NUMBERS

Counts the number of data values that are numerical.

StDEV Estimate of the standard deviation of a population, where 
the sample is a subset of the entire population.

StDEVP Standard deviation of a population, where the population is 
all of the data to be summarized.

VAR Estimate of the variance of a population, where the sample 
is a subset of the entire population.

VARP The variance of a population, where the population is all of 
the data to be summarized.
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In addition to these summary functions, there are other functions 
available for Custom Calculations in Value Fields. The list below 
shows some of the available options from the  Show Values As 
calculations list.

Function Result

Difference From Displays values as the difference from the value of the 
Base Item in the Base Field.

% Of Displays values as a percentage of the value of the Base 
Item in the Base Field.

% Difference 
From

Displays values as the percentage difference from the 
value of the Base Item in the Base Field

Running Total In Displays the value for successive items in the Base Field 
as a running total.

% of Row Displays the value in each row or category as a 
percentage of the total for the row or category.

% of Column Displays all of the values in each column or series as a 
percentage of the total for the column or series

% of Total Displays values as a percentage of the Grand Total of 
all of the values or data points in the report.

Index
Calculates values as follows:
((Value in Cell) x (Grand Total of Grant Totals)) / 
((Grand Row Total) x (Grand Column Total))

If Summary Functions and Custom Calculations do not provide 
the desired results, you can create your own Formulas in 
Calculated Fields and Calculated Items.

For data that comes from an external data source or from worksheet 
data, Excel uses the Sum function to calculate Value Fields that 
contain numeric data, and the Count function to calculate Value 
Fields that contain text.

You can choose a different summary function like Average, Max 
or Min to further analyze or customize the data.  

Using Calculated 
Fields and Items,
continued
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When you use Formulas in a PivotTable Report, you must be 
aware of syntax rules and formula behaviors.

�� You can use operators and expressions as you do in 
other worksheet formulas.

�� You can use constants and refer to data from the 
report, however you cannot use cell references or 
defined names.

�� Formulas for Calculated Fields operate on the sum 
of the underlying data for any fields in the formula. 
Therefore, you cannot sort a Calculated Field.

�� Formulas cannot refer to totals.

�� You can include the Field Name in a reference to an 
Item but the Item Name must be in square [ ] brackets.

�� If you refer to an Item by its position in your 
PivotTable Report as it is currently sorted and 
displayed, the Item referred to can change whenever 
the position of the Item changes or is displayed or 
hidden. Hidden Items will not be counted in an index.

�� You cannot add Calculated Items to PivotTable data 
that contains Averages.

�� You cannot add Calculated Items to data that has been 
Grouped. 

Creating a Formula in a PivotTable Report
�� Decide whether you are creating a Calculated Field or 

a Calculated Item within a field. 
 
Use a Calculated Field when you want to use the data 
from another field in your formula. 
 
Use a Calculated Item when you want something 
calculated within a field.

Using Calculated 
Fields and Items,
continued
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Once a Calculated 
Field is created, it is 
added to the Field 

List and can be used in 
other calculations.

Adding a Calculated Field
�� Click in the PivotTable Report.

�� On the Analyze Tab, in the Calculations group, click 
on [Fields, Items, & Sets], then select Calculated Field

�� In the Name box, type a Name for the Field.

�� In the Formula box, enter the Formula for the Field.

�� To use data from another Field in the Formula, click 
the Field in the Fields box, then click [Insert Field], 
click [Add].

Adding a Calculated Item to a Field
�� If the Items in the Field are grouped, select the 

Analyze Tab, in the Group group select [Ungroup].

�� Select the Field where you want to place the 
Calculated Item.

�� On the Analysis Tab, in the Calculations group, click 
on [Fields, Items, & Sets], then select Calculated Item.

�� In the Name box, type a Name for the Calculated Item.

�� In the Formula box, enter the Formula for the Item.

�� To use data from an Item in the Formula, click the 
Item in the Items list, then click [Insert Item].  The item 
must be from the same field as the Calculated Item.

�� Click [Add].  You can regroup the items if you 
ungrouped them previously.

�� For Calculated Items, different Formulas can be 
entered cell by cell.

Changing a Formula
�� Click the cell that you want to change the Formula in.

If you are changing several Formulas, click on the first 
cell to be changed, hold down the [Ctrl] key, click on 
the next cells to be changed,

�� In the Formula Bar, make the changes to your 
Formula.

Using Calculated 
Fields and Items,
continued
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Changing the Order
If you are not getting the results that you expected, you can 
change the order in which the calculations are performed for your 
Multiple Calculated Items. 

�� Click on a cell inside your PivotTable Report.

�� On the Analyze Tab, in the Calculations group, click 
on [Fields, Items, & Sets], then select Solve Order

�� Select a Formula, click on the [Move Up] or [Move 
Down] button to change the Formula calculation 
order.

Displaying Formulas
To display or view all the Formulas that you are using in your 
PivotTable Report do the following:

�� On the Analyze Tab, in the Calculations group, click 
on [Fields, Items, & Sets], then select List Formulas. 
 
This is also a quick way to edit Formulas for 
Calculated Fields or Calculated Items.  Select the 
Formula you want to edit from the list and perform 
the edit.

�� On the Analyze Tab, in the Calculations group, click 
on [Fields, Items, & Sets], then select Calculated Item.

�� In the Name box, select the Calculated Item using the 
drop-down arrow, and in the Formula box, edit the 
formula, click  [Modify].

�� To delete a Formula, select [Delete]. 

Using Calculated 
Fields and Items,
continued

To temporarily 
remove a 

Calculated 
Field from the 
PivotTable, 
deselect the 
checkbox in the 
Field List Task 
Pane.

To apply filter 
buttons to the 

heading of a 
Calculated Item or 
Field, press [Ctrl + 
Shift + L].
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Action 4.4 - Creating a Calculated Field in a PivotTable Report

	 1.	 Open the workbook named PivotTable 
Calculated.xlsx. 

	 2.	 Save the workbook as My PivotTable 
Calculated.xlsx.

  	3.		 Create a PivotTable Report for the data 
presented in the range A1:C10.

Your Scenario:
		  You will be working with this Sales information after your PivotTable Report 

has been created to present it to the Sales Manager.

		  He would like to see your PivotTable Report formatted so the Row Headings 
read as Region, the Column Headings show each individual Month, and a Grand 
Total for each Region and a Grand Total for each Month. Format the Sales figures 
with the Currency format. Edit cell F2 to read "Month" and E3 to read "Region".
Your initial PivotTable Report should resemble something like the one below 
after you have created it and made the requested changes:
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	 4.		 Click on a cell inside the PivotTable 
Report. On the PivotTable Tools Tab, 
select the Design Tab. In the Layout 
group, select the [Grand Totals] drop-
down and select off for Rows and 
Columns.

  	5.		 Click on the May column heading.

  	6.		 On the PivotTable Tools Tab, select 
the Analyze Tab. In the Calculations 
group, select the [Fields, Items & Sets] 
drop-down and select Calculated Item. 
The Insert Calculated Item dialog box 
will open.

   	7.		 In the Name: box, enter Forecast.

	 8.	 In the Formula: box, enter the formula to 
calculate the Sum for March, April and 
May and then multiply it by 110%.

	 9.		 Type =Sum( and then click on Mar, 
then click on the [Insert Item] button, 
then type ,. Click on April and click on 
the [Insert Item] button, then type,. Do 
the same for  May. Then type )*1.1.

	

Action 4.4 - Creating a Calculated Field in a PivotTable Report,  
continued

To insert the Calculated Items and 
Calculated Fields needed to complete the 
request, we will need to turn off the Grand 
Totals that are currently being displayed.

=Sum(Mar, Apr, May)*1.1

		
		  You have completed the PivotTable Report as requested and shown it to the Sales 

Manager and he has decided that he would like to see a custom calculated field to 
forecast a 10% increase for each Region.  You will do this by creating a Calculated 
Item.
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	10.		 When you have all three Months in the 

Formula: box, click on [OK].

  

		
	11.	 Click on a cell inside the PivotTable 

Report. 

	12.	 On the PivotTable Tools Tab, select the 
Analyze Tab. In the the Calculations 
group, select the [Fields, Items & Sets] 
drop-down and select Calculated 
Field. 

	13.		 In the Name: box enter Bonus. Clear the 
Formula: box and enter in the formula 
to calculate the Bonus based on the 
scenario's criteria. 

This places a column titled Forecast to the 
right and puts a forecasted total for each of 
the regions.

The Insert Calculated Field dialog box will 
open.

The scenario indicated that to be eligible 
for a bonus that month, the sales have 
to be greater than $5,000. The standard 
bonus amount is 3% of the monthly sales 
amount.  An IF function will need to be 
entered into the formula.

Action 4.4 - Creating a Calculated Field in a PivotTable Report,  
continued

Your Next Scenario:
		  The Sales Manager likes what you have done so far, but now he needs to figure 

out how much of a Bonus he needs to pay each Region based on their Monthly 
Sales Total.  

		  The standard Bonus that is paid is 3% of the Monthly Sales Total if the Sales Total 
is Greater Than $5,000 in that Month. 

		  You need to calculate the Bonus amount for each month and display that 
in your PivotTable Report. To do this, you are going to need to create a 
Calculated Field with a formula.
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	14.	 To insert Sales into your formula, select 

Sales from the Fields: text box. Then 
select [Insert Field].

	15.	 Enter in the remainder of the formula    

		  Click [Add] to add the Formula.

	16.	 Click [OK] to return to the PivotTable 
Report and view the new column.

		

=IF(Sales >5000,Sales*3%,0)

Your PivotTable Report will now have a 
column called Sum of Bonus displayed 
next to the Sum of Sales column, with 
each individual month labeled above it.

Action 4.4 - Creating a Calculated Field in a PivotTable Report,  
continued

		
		  While all the requested fields and calculations are on your report, this probably 

is not what your Sales Manager is looking for as a final product. 

		  We will need to re-arrange our columns so our data is presented in a more 
logically grouped format. 
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Action 4.4 - Creating a Calculated Field in a PivotTable Report,  
continued

	17.		 Drag the Values field from the Columns 
area to the Rows area.

	18.		 On the Design Tab, click on the drop-
down arrow on the [Grand Totals] 
button.

	19.		 Select On for columns only.

		  Your PivotTable Report should look 
like the figure at right when you have 
completed all of the steps.

	20.		 Take a look at your PivotTable Report.

	 -	 Does it meet all the criteria that the 
Sales Manager requested in the two 
Scenarios?

	 -	 Is it accurately reflecting the data? 
Have you selected a field or two 
and done a manual check to see if 
the formula is returning the correct 
answer?

	21.		 Save My PivotTable Calculated.xlsx 
and close the file.



Lesson Overview

You will cover the following concepts in this 
chapter:

Excel 2016: Pivot Table Features
Rel. 1.0, 10/25/2017

Lesson 5: Creating 
PivotTables from 
External Data

�� Importing External Data into a 
PivotTable Using the PivotTable Tool.

�� Importing Access Database Objects into 
a PivotTable

�� Creating a PivotTable Using the 
Microsoft Query Connection

�� Understanding Object Database 
Connections (ODBC)



Lesson Notes
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It is often the case that the data you need for your Excel 
PivotTable is stored in a database application. Database 
applications are great for managing, maintaining, and retrieving 
large amounts of data. Database programs also provide features 
for defining relationships between data entities, for developing 
queries to extract information, and for securing sensitive 
information. For these reasons and more, organizations often 
make extensive use of databases.

Excel allows you to import data from a number of external 
sources. Moreover, the imported data can be linked to the source, 
so that any changes to the underlying source data tables can be 
refreshed and updated in your Excel worksheets.

The Microsoft Office suite provides drivers that will allow Excel 
to connect to a wide array of data sources.

Some of the data sources that you can connect to with Excel are:
�� Microsoft SQL Server

�� SQL Server Analysis Services Cube

�� Microsoft Access and Microsoft FoxPro

�� ODBC DSN

�� OLAP Services and OLAP cubes

�� dBase 

�� Oracle 

�� Paradox 

In this lesson, we will discuss three different methods of 
importing external data into a PivotTable.

�� Using the Insert PivotTable tool

�� Using the From Access Object tool

�� Using the Microsoft Query Connection

The advantages of each are discussed in their respective sections.  

Connections to external data in the current workbook can be 
viewed and refreshed with the [Connections] button in the 
Connections Group on the Data Tab.  

In a PivotTable or PivotChart, external connections can be 
refreshed using the [Refresh] button on the Analyze Tab.

Importing Data 
from External 
Data Sources

 A driver is 
software that 

helps programs 
communicate with 
each other without 
knowing the 
precise details of 
the program being 
accessed.
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Saved Microsoft 
Queries Area

Previously 
made connec-
tions Area

Creating a PivotTable from External Data Using the 
PivotTable Tool
The advantage of creating the External Data Connection from 
the PivotTable tool is efficiency.  By using the Create PivotTable 
dialog box, you can create the connection and the PivotTable 
simultaneously.

�� Select the Insert Tab and click the down arrow on the 
[PivotTable] button.

	 The Create PivotTable dialog box will be displayed.

�� Click the Use an External Data Source option button.

�� Click the [Choose Connection...] button.

�� When the Existing Connections dialog box appears, 
select an item from the list and click [Open].

- OR -
�� Select [Browse for More...] to select a database not 

yet connected.

Importing 
External Data 
Using the 
PivotTable Tool
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�� Once you have selected the database, click [Open].

�� Depending on the external data source you have 
chosen, you may be asked for login credentials 
(a username and password) or other verifying 
information.  If so, enter the appropriate information 
in the fields provided and click [OK].

�� You will be returned to the Create PivotTable dialog box 
to continue making your selections.

�� When you click [OK], the PivotTable will be created.  
You will see the PivotTable area and PivotTable Field 
List Task Pane as before, but now the field headings 
in the PivotTable Field List are from the external data 
source that you have selected.

�� Once you build a PivotTable using external data, you 
can refresh the table by clicking the Refresh button 
on the Data Tab. You may also use the [Refresh] 
button on the PivotTable Tools Analyze Tab or 
the PivotChart Analyze Tab.  This will update the 
PivotTable with any changes made to pertinent data in 
the source database.

The connection you have created will be listed in the 
Existing Connections dialog box located on the Data Tab in 
the Connections Group for future use.

Importing 
External Data 
Using the 
PivotTable Tool,
continued
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Action 5.1 - Creating a PivotTable from External Data Using the  
PivotTable Tool

	 1.		 Open a blank workbook.

	 2.		 Select the Insert Tab.

	 3.		 From the Tables group, select the 
[PivotTable] button.

	 4.		 Select the Use an external data source 
option button.

	 5.		 Click [Choose Connection...].

	 6.		 Click the [Browse for More...] button.

	 7.		 From the exercise files folder, select the 
MultipleCriteria.accdb file.

	 8.		 Click [Open].

	 9.		 From the list of available tables in 
the Select Table dialog box, choose the 
Products table.

	10.	 Click [OK], then click [OK] again 
to close the Create PivotTable dialog 
box.	

	11.	 Drag CategoryID to the Rows area.

	12.	 Drag SupplierID to the Columns area.

	13.	 Click on the checkbox for 
UnitsInStock.

	14.	 Save the file in your Student Folder 
with the name Products PivotTable 
and close the file.

This will open an Explorer window to 
allow you to browse for the database file.

This will open the Select Table  dialog box 
which lists all of the tables and queries 
available to import. 

This will create a PivotTable frame and 
show a PivotTable Field List with fields 
from the Products table.
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PivotTables can also be created from Access database objects 
using the Data Ribbon.  Just like a linked spreadsheet, the data in 
the PivotTable is also linked to the data in the Access database.

The advantage to using this method is that Excel only looks for 
Access data, making it easier to browse for the source file.

The disadvantage to using this method is that this method does 
not add the connection to the existing connections for future use.

Using the Data Ribbon
�� Display Excel’s Data Ribbon.

�� In the Get External Data group, click the [From 
Access] button.

�� The Select Data Source dialog box will be displayed.

�� Select the Access database that will serve as the source 
of the data.

�� Click the [Open] button.

Creating a 
PivotTable from 
an Access Object

It is a good idea 
to run advanced 
queries in the 

database program and 
then connect to the 
resulting query or table.
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�� If the Access database being used has multiple tables 
or queries, the Select Table dialog box will be displayed.

�� Choose the table or query that contains your source 
data.

�� Click the [OK] button. 

�� The next step is to use the Import Data dialog box to 
select how you want to view the imported data in 
Excel. 

�� Click the [Properties] button in the Import Data dialog 
box to see the Connection Properties dialog box.

Creating a 
PivotTable 
from an Access 
Object,
continued

	 If the Access 
database has only 
one table, the Select 

Table dialog box will not 
appear.

If you miss this 
step, you can 
also access the 

[Properties] button from 
the Connections group 
on the Data Tab

Continued on next page
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�� In this box you can enable or disable settings for 
connections to external data sources, and use, reuse or 
switch connection files.

�� The Usage tab is used to control the way that the 
connection information is used in the workbook.

�� If you put a check by Refresh data when opening 
the file, the table data will be refreshed from the 
database when you open the Excel workbook. 

�� You can also specify how much time should pass 
between refreshes with the Refresh every check 
box. 

�� The Definition tab controls how the connection 
information is defined and the source of the connection 
information.

�� When everything is set the way you want, click 
[OK] to implement the changes and return to the 
Import Data dialog box.

�� When you have selected the PivotTable Report or 
PivotChart option button in the Import Data dialog 
box, click the [OK] button.

Creating a 
PivotTable 
from an Access 
Object,
continued

Continued on next page
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Here is the original data from the Access database.

Here is a PivotTable report based on imported data from the 
database.

�� If you right click on the table you created in Excel, and 
click the Refresh option from the pop up menu that 
appears, the data in your Excel table will be updated 
with any changes made to the source data in the 
database.

Creating a 
PivotTable 
from an Access 
Object, 
continued



Excel 2016:  Pivot Table Features, Rel. 1.0, 10/25/2017 
Lesson 5:  Creating PivotTables from External Data, Page  111

Instructions:	 Results/ Comments:

Action 5.2 - Creating a PivotTable and PivotChart from Access Data

	 1.		 Open a blank workbook.

	 2.		 Select the Data Tab.

	 3.		 From the Get External Data group, 	
select the [From Access] button.

	 4.		 Select the MultipleCriteria.accdb 
database from your exercise files folder, 
click [Open].

	 5.		 In the Select Table dialog box, select 
Orders and click [OK].

	 6.		 In the Import Data dialog box, select 
[PivotChart]. 

	 7.		 In the Where do you want to put the data? 
area, make sure Existing Worksheet is 
selected and the range in the text box is 
[$A$1]. 

	 8.		 Click [OK].

	 9.		 The PivotChart and PivotTable frames 
will appear on the worksheet and the 
PivotChart Fields will appear on the 
right-side of the worksheet.

	10.		 Click on the PivotChart frame.

	11.		 In the PivotChart Fields Task Pane 
select ShipCountry and drag to Axis 
(Categories).
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Instructions:	 Results/ Comments:

Action 5.2 - Creating a PivotTable and PivotChart from Access Data,  
continued

	12.		 Then drag ShipRegion and 
ShipPostalCode from the PivotChart 
Fields Task Pane into the Axis 
(Categories) under ShipCountry.

	 13	 .	Drag Freight into the Values area.  

	14.		 In the Values area, click on the drop-
down arrow next to Sum of Freight 
and select Value Field Settings....

	15.		 Select the [Number Format] button. 

	16.		 When the Format Cells dialog box 
opens, select Accounting to format the 
field. 

	17.		 Click [OK] to close the Format Cells 
dialog box, and then click [OK] again 
to close the Value Field Settings dialog 
box.

	18.		 In the PivotChart Fields Task Pane, 
drag the ShipPostalCode out of the 
Axis fields (Categories) box. 

	19.		 In the PivotChartTools, click the 
Design Tab. In the Chart Layouts 
group, select [AddChartElment] and 
trace to Data Table and then select No 
Legend Key.

This will start to populate the PivotChart 
and the PivotTable with the items that you 
have selected and you will begin to see 
how the data is going to display.

Notice that the PivotChart which is 
displayed does not display very useful 
information at this point. We will make 
changes to display the information we 
need.

Notice that the PivotTable changes to 
show totals by Country and Region and 
a Grand Total is at the bottom of the 
PivotTable.
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Action 5.2 - Creating a PivotTable and PivotChart from Access Data, continued

A table containing the amounts for each 
region appears below the horizontal axis.

The resulting PivotTable and PivotChart should look like this:
	

	
	20.		 Save the file as My PivotChart.xlsx and 

close the file.
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The Microsoft Query Connection allows you to import data 
from any Microsoft Application while filtering the data.  The 
advantage of using this method is that the data that is imported 
fits a specific criteria and you do not end up with data you 
cannot use or that has to be deleted. In addition, any connection 
established using this method is added to the Existing 
Connections list and can be used in future data retrieval. 

�� Select the  Data Tab.

�� From the Get External Data group, click the [From 
Other Sources] drop-down arrow.

�� A menu is displayed with a number of options for 
connecting to an external data source. 

The bottom option in this menu, Microsoft Query, is a 
powerful tool that will allow you to create a connection 
and build a query.  A query is a way to extract specific 
information from a database.

Importing 
Data Using 
Microsoft Query 
Connection

Continued on next page
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�� Once you have selected From Microsoft Query from 
the [Other Sources] button, you will see the following 
dialog box. You will be creating an ODBC connection to 
the database.

�� The <New data source> option should already be 
selected.

��  Click [OK], 

�� The Create New Data Source dialog box displays.

�� Type a name for your data source.

�� Click the drop-down to select a driver type for the new 
data source.

�� Click the [Connect] button to establish a connection.  

ODBC stands for Open 
Database Connectivity. 
This is a utility used to 

define a connection between a 
computer and a database. The 
ODBC connection contains 
information needed to allow 
a computer user to access 
the information stored in a 
database that is not located 
on the local computer. 

Importing 
Data Using 
Microsoft Query 
Connection, 
continued

Continued on next page
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�� Click on the [Select] button

�� Browse to the location of the database and select the 
database you want to connect to. Click [OK].  

�� You may be asked at this point to provide login 
credentials for the data source. Enter your login 
credentials and click [OK].

�� Once this named connection is created, the Query 
Wizard-Choose Columns dialog box will open to 
allow you to choose the tables and the columns of 
information that you can include in your query.

Importing 
Data Using 
Microsoft Query 
Connection, 
continued

Continued on next page
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Importing 
Data Using 
Microsoft Query 
Connection, 
continued

�� Select the table you want to include in your query by 
clicking on the [Expand] button, [ + ]. Then, select the 
column of data you want to include in your query. 
Press the [ > ] to move your selection into the Columns 
in your query box.

�� When you have selected all the columns you want to 
include in your query, click [Next] 

�� The Query Wizard - Filter Data dialog box is displayed. 
You can filter the data to extract specific information.

�� Select from one of your Column to filter: and in the Only 
include rows where: drop-down use the search criteria to 
build your filter.

�� Once you have made all of your selections, click [Next].

�� The Query Wizard - Sort Order dialog box will open and 
offer you the option to sort your selected data. Select 
the drop-down under Sort by and choose Ascending or 
Descending.

�� Once you have completed your selections, click [Next].

Continued on next page
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Importing 
Data Using 
Microsoft Query 
Connection, 
continued

�� The final step is the Query Wizard - Finish dialog 
box which offers you the options to Return Data 
to Microsoft Excel or View Data or Edit Query in 
Microsoft Query if you want to make any changes, 
and Save Query if you are going to use the query 
again. 

�� Name the query if you are going to save it. You will 
see in the background the information the query is 
extracting from the table. Click [Save].

�� If you are selecting the option to Return Data to 
Microsoft Excel, Click [Finish].

Continued on next page
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Importing 
Data Using 
Microsoft Query 
Connection, 
continued

You will now see the Import Data dialog box offering you 
the import options for your data, Click [OK].

Your Query data will then appear in an Excel worksheet 
based on your selections in the dialog box.

Excel table created from imported data
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Instructions:	 Results/ Comments:

Action 5.3 - Importing From External Data

	 1.		 Open a blank workbook.

	 2.		 Select the Data Tab.

	 3.		 From the Get External Data group, 
click the [From Other Sources] button.

	 4.		 Select From Microsoft Query.

	 5.		 Make sure <New Data Source> is 
selected and click [OK].

	 6.		 In the Create New Data Source dialog 
box, type Test for the name of the Data 
Source.

	 7.		 From the Select a driver for the type of 
database you want to access: drop-down 
list, select [Microsoft Access Driver 
*.mbd, *.accdb].

	 8.		 Under Click Connect and enter any 
information requested by the driver:, click 
[Connect]

	 9.		 In the ODBC Microsoft Access Setup 
dialog box, under Database, click 
on [Select] and browse to select the 
database ShippingDatabase.accdb.

	10.		 Click [OK] to close the Select Database 
dialog box.

	11.	 Then, click [OK] in the ODBC Microsoft 
Access Setup dialog box to return to the 
Create New Data Source dialog box.

	10.		 Under Select a Default Table for Your Data 
Source (optional) select the drop-down. 

	11.		 Do not make a selection.  Click [OK].

Offers options of connecting to a variety 
of databases to obtain information for 
analysis.

The Choose Data Source dialog box will 
open. 

This ensures the necessary filter is used for 
Excel to interpret the data coming from the 
type of database you are connecting to.

Here, you can see the existing Access 
objects in this file from which you can 
extract information.
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Action 5.3 - Importing From External Data, continued

The Query Wizard – Choose Columns dialog 
box will open and display the Available 
Tables and Columns you can select to add to 
the Columns in Your Query to be imported 
into your Excel workbook.

The Query Wizard – Filter Data dialog box 
will open and offer you the ability to filter 
the data imported by criteria you select. 

The Query Wizard-Sort Order dialog box is 
displayed.

The Query Wizard - Finish dialog box is 
displayed.

	12.		 You may be prompted with a Login 
Credentials dialog box.  If so, select 
[OK].

	13.		 Click [OK] to close the Choose Data 
Source dialog box.

	

	14.		 Click the [+] to expand the 
CompanyNames table.

	15.		 Select CompanyName and click the  
[ > ] arrow to move it into the Columns 
in your query: box. 

	16.		 Repeat steps 14 and 15 to move 
OrderID, Order Date and Quantity.

	17.	 Click [Next].

	18.		 Select Quantity in the Column to filter: 
box, then select the drop-down under 
Quantity to Only include rows where: 
and choose is greater than or equal to. 
Select 20.0 from the next drop-down. 

	19.	 Click [Next].

	20.		 Select [Next] to skip the Query Wizard-
Sort Order step.
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Action 5.3 - Importing From External Data, continued

	21.		 At this point, Return Data to Microsoft 
Excel should be selected in the Query 
Wizard-Finish dialog box.

	22.		 Click the [Save Query] button and 
name the query Shipping Quantity 
Over 20. Then click [Save].

	23.		 Click [Finish] in the Query Wizard-
Finish dialog box.

	24.		 Select PivotTable Report in the Select 
how you want to view this data in your 
workbook.

	25.		 Click [OK] to place the PivotTable 
frame in the existing worksheet 
starting at cell A1.

	26.		 Drag Company Name to the Rows 
area.

	27.		 Drag Quantity to the Values area.

	28.		 Save file as External Query.xlsx.

We will save the query so that we can  
re-run it if necessary.

The Import Data dialog box will open.

Your Pivot Report 
should look similar 
to this:



�� Unlocking a Slicer

�� Formatting Slicers

�� Creating a Custom Slicer Style

�� PivotTable Layout Options

Lesson Overview

You will cover the following concepts in this 
chapter:

Excel 2016: Pivot Table Features
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Unlocking a 
Slicer

Unlocking a Slicer in a Protected Worksheet
�� Select the slicer(s) you wish the user 

to be able to  manipulate.

�� Right-click on a slicer and select Size 
and Properties.. from the shortcut 
menu.

�� In the Task Pane select Properties.

�� Deselect the check box next to 
Locked.

�� Click into the worksheet to deselect 
the Slicer(s).

�� Click the Review Tab. In the Changes 
group, click on the [Protect Sheet] button.

�� Click on the checkbox to Allow all users of this 
worksheet to: Use PivotTable & PivotChart.

�� Click on the checkbox to Allow all users of this 
worksheet to: Select unlocked cells.



Custom Slicer 
Styles

There are different ways to format your Slicers so that the user 
can see what values have been selected and applied.  Using 
the New Slicer Style item from the Slicer Styles Gallery on 
the Slicer Tools Options Tab, you can change the way a button 
appears when hovered over or selected.

�� Select the Slicer you would like to affect, or choose one 
and press [Ctrl + A] to select all of the Slicers.

�� Click the Options Tab. Click on the [More] button on 
the Slicer Styles  Gallery.

�� Select New Slicer Style.

�� Type in an appropriate name for your Slicer Style in 
the Name: text box.

�� In the New Slicer Style dialog box, select one of the 
Slicer Elements in the list.

�� Click on the [Format] button and select the formatting 
you would like to apply to that Element.

�� Repeat the previous steps for all of the Slicer Elements 
you would like to change.

�� To reuse the Slicer Style you just created, click on it in 
the Custom section of the Slicer Style Gallery. 
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Custom Slicer 
Styles,
continued

Some of the items that can be changed in a Slicer Style are:
�� Header - This is the Field Name at the top of the 

Slicer.

�� Selected Item with Data - This is a value in the 
Slicer that is selected and has associated data in the 
PivotTable, and therefore, the PivotChart.

�� Selected Item with no Data - This is a value in the 
Slicer that is selected and does not have associated 
data in the PivotTable and PivotChart.  An example 
is if you filter the PivotTable and PivotChart to show 
data for a certain month, but there were no sales of the 
selected Product on the Slicer in that month.

�� Unselected Item with Data - This is a value in the 
Slicer which has corresponding data within the filter 
criteria, but has not yet been selected in the Slicer.

�� Unselected Item with no Data - It is helpful to format 
this element when you wish to see items that do not 
have corresponding data within the filter criteria.  
Using the example above, you may format this element 
if you would like to see which Products do not have 
sales in that month before you even select them.

�� Hovered Selected Item with Data - This is a value in 
the Slicer that has already been selected.  However, 
you may wish to also see a format change when you 
pass your mouse pointer over the value.
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Custom Slicer 
Styles,
continued

�� Hovered Selected Item with no Data - This is a value 
that has been selected in the Slicer that does not 
have corresponding data in the PivotTable and/or 
PivotChart.  When you pass your mouse pointer over 
this value, you may want to see a change in format.

�� Hovered Unselected Item with Data - Change this 
element when you want a different format when you 
Pass your mouse pointer over a value that has not 
been selected, but does have corresponding data in the 
PivotTable and/or PivotChart.

�� Hovered Unselected Item with no Data - Change the 
format of this element when you wish to emphasize, on 
hover, buttons which do not have corresponding data 
in the PivotTable.  This way you can see which items 
will not produce a result when selected.
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PivotTable 
Layout Options

The [Report Layout] drop-down button in the  Layout group of 
the PivotTable Tools Design ribbon will help you see the format 
that works best for you.

Compact Form
In Compact Form, you can use the PivotTable Options dialog box 
from the [Options] button on the PivotTable Tools Analyze 
Tab to change the number of characters to indent the additional 
fields. This option lets you see multiple fields in one column.

Outline Form
An Outline Form layout separates the row fields into separate 
columns.  Use this view to show Row Item Labels separately. 

Tabular Form
The Tabular Form is the legacy format.  Similar to the Outline 
Form, it shows the Row Labels in separate columns, but also 
includes separate rows for the Totals.

Compact Form Outline Form Tabular Form
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Repeat All Item Labels
In Outline or Tabular format, this option will fill in the blanks 
with the corresponding row labels. This is helpful when you 
want to copy and paste the data into a new spreadsheet for 
further analysis.

Changing the Display of Report Filters
Use the PivotTable Options dialog box to show the report filters in 
columns.

�� Select the PivotTable Tools Analyze tab.

�� Click on the [Options] button.

�� Select the Layout and Format tab.

�� Increase the number of Report filter fields per column:

PivotTable 
Layout Options, 
continued

Repeat All Item Labels
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�� Eliminating Leading and Trailing 
Spaces

�� Removing Blank Rows and Columns in 
Your Data

Lesson Overview

You will cover the following concepts in this 
chapter:

Excel 2016: Pivot Table Features
Rel. 1.0, 10/25/2017

Appendix B



Troubleshooting 
Data 

Leading and Trailing Spaces
Sometimes the data being used for your PivotTable does not 
summarize correctly.  One reason for this is that there may be 
extra spaces in the data itself.  This can happen when the data is 
imported from another database or application.  Excel treats a 
space as a character, therefore, this data is considered separate 
pieces of information even though it looks the same in the 
spreadsheet. This issue can be resolved with the Trim function.

The TRIM Function
In the datasheet, click into a blank cell or create a “dummy” 
column to create the formula.

�� Type =TRIM(reference cell)

�� Fill the formula down to the rest of the cells in the 
column.

�� Copy the cells just created.

�� Paste the values back to the original column.

�� Refresh the PivotTable.

Selecting Blank Rows/Columns for Elimination
�� Click on the Home Tab, then select the [Find & Select] 

button in the Editing group.

�� Click on Go To Special... to open the Go To Special 
dialog box

�� Select the Blanks option button and click [OK].
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Troubleshooting 
Data,
continued

�� Delete the cells using the Delete (cells) dialog box from 
the [Delete] button on the Home Tab.

Press [Ctrl + -] to 
open the Delete 

(cells) dialog box.
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Tips and Notes
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